Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: tablet  (Přečteno 2600 krát)

adam.t

  • Návštěvník
  • Příspěvků: 22
tablet
« kdy: 02 Září 2008, 13:50:39 »
Zdravím, koupil jsem si tablet Genius G-Pen F610. Rozběhal jsem ho podle wiki, funguje perfektně, ale dvě věci se mi stále nedaří vyřešit:
Nefungují tlačítka na spouštění programů.
Když tablet odpojím a zas připojím, úplně se mi rozhodí kalibrace rozměrů a musím restartovat počítač.
Dá se s tím něco dělat?

adam.t

  • Návštěvník
  • Příspěvků: 22
Re: tablet
« Odpověď #1 kdy: 03 Září 2008, 18:56:45 »
Díval jsem se do systémového protokolu na Xorg.0.log, změní se jen při prvním odpojení:
Kód: [Vybrat]
Error reading wacom device : Invalid argument
Ostatní logy hlásí připojení/odpojení USB zařízení vždy, ale nikde žádnou chybu, tady např. výpis z kern.log:
Kód: [Vybrat]
Sep  3 18:49:45 loki kernel: [ 4852.580096] usb 4-5.1: USB disconnect, address 7
A po opětovném připojení
Kód: [Vybrat]
Sep  3 18:49:47 loki kernel: [ 4854.810933] usb 4-5.1: new full speed USB device using ehci_hcd and address 8
Sep  3 18:49:47 loki kernel: [ 4854.867076] usb 4-5.1: configuration #1 chosen from 1 choice
Sep  3 18:49:47 loki kernel: [ 4854.872002] input: WALTOP International Corp. Slim Tablet as /devices/pci0000:00/0000:00:1d.7/usb4/4-5/4-5.1/4-5.1:1.0/input/input14
Sep  3 18:49:48 loki kernel: [ 4854.917729] input,hiddev96,hidraw0: USB HID v1.10 Mouse [WALTOP International Corp. Slim Tablet] on usb-0000:00:1d.7-5.1
Na manuál ke xorg.conf jsem se taky mrknul, ale ono to spíš vypadá že po vyjmutí a zapojení si nastavení nenačte - tablet se chová přesně tak, jako když jsem ho zapojil prvně, ještě před nastavováním.

Všechno se to navíc chová tak nějak divně... Zkoušel jsem něco z http://linuxwacom.sourceforge.net/index.php/howto/main, například
Kód: [Vybrat]
xxd /dev/input/tablet Ten se chová normálně, pokud je tablet v tom polofunkčním stavu, po startu počítače jako by z něho žádná data nešla, tablet přitom funguje tak, jak má (Pro jistotu jsem prošel všechny položky, které tam jsou). To samé i wacdump - jako by tam žádný tablet nebyl.

A co se týče tlačítek na spouštění aplikací, taky mi to nepřijde moc růžové - xxd na jejich stisk vůbec nereaguje.

adam.t

  • Návštěvník
  • Příspěvků: 22
Re: tablet
« Odpověď #2 kdy: 03 Září 2008, 19:47:44 »
Celý je moc dlouhý, takže ke stažení zde: http://sweb.cz/Adam2/xorg.log.txt

adam.t

  • Návštěvník
  • Příspěvků: 22
Re: tablet
« Odpověď #3 kdy: 03 Září 2008, 20:47:32 »
xsetwacom nainstalovaný mám.
V dmesg se mi po odpojení a připojení hlásí jako
Kód: [Vybrat]
[   66.421256] usb 4-5.1: new full speed USB device using ehci_hcd and address 7
[   66.439108] usb 4-5.1: configuration #1 chosen from 1 choice
[   66.451342] input: WALTOP International Corp. Slim Tablet as /devices/pci0000:00/0000:00:1d.7/usb4/4-5/4-5.1/4-5.1:1.0/input/input13
[   66.508232] input,hiddev96,hidraw0: USB HID v1.10 Mouse [WALTOP International Corp. Slim Tablet] on usb-0000:00:1d.7-5.1

EDIT: xsetwacom je součást balíku wacom-tools

adam.t

  • Návštěvník
  • Příspěvků: 22
Re: tablet
« Odpověď #4 kdy: 03 Září 2008, 22:13:42 »
Změny mi připadnou jen takové kosmetické, nicméně jsem to zkusil a ne, dostávím pořád stejný výsledek. Docela by mě zajímalo jestli se takto chová i autorovi toho návodu...

adam.t

  • Návštěvník
  • Příspěvků: 22
Re: tablet
« Odpověď #5 kdy: 04 Září 2008, 12:31:12 »
Tak to je zdá se v hájku... Ale i tak dík

 

Provoz zaštiťuje spolek OpenAlt.