Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Nestandardní chování wifi - iwl3945 na HP nx7300  (Přečteno 3769 krát)

Lord Lover

  • Návštěvník
  • *
  • Příspěvků: 3
    • Zobrazit profil
Nestandardní chování wifi - iwl3945 na HP nx7300
« kdy: 22 Listopad 2008, 17:14:28 »
Zdravím,
   mám problém se síťovkou a snažím se ji už 3tí den rozchodit. Jsem naprostý začátečník s Linuxem a přes tohle se mi nedaří prokousat.
1)Popíšu problém od začátku. Wifi nemůžu po instalaci zapnout jinak než že nabootuju do windows XP a restartuju se zapnutou wifi. Speciální tlačítko na klávesnici jinak v Linuxu nefunguje. Jelikož mám notebook od HP, našel jsem jejich stránky o problematice velmi pěkně zpracované (http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Linux.Wireless.usage.html#vendor). Postupně jsem se prokousal na projekt Intelu iwlwifi (http://intellinuxwireless.org/?p=iwlwifi) kde jsou novější informace. Nakonec jsem se prokousal až na stránku o compat-wireless project (http://linuxwireless.org/en/users/Download), kde odkazují na nejnovější wireless drivery. Nainstaloval jsem nejnovější  compat-wireless (22.11.2008) podle jejich návodu, po
Citace
$ sudo make load mi to hodilo na konci tuto hlášku:
FATAL: Error inserting b43 (/lib/modules/2.6.27-7-generic/updates/drivers/net/wireless/b43/b43.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting b43legacy (/lib/modules/2.6.27-7-generic/updates/drivers/net/wireless/b43legacy/b43legacy.ko): Unknown symbol in module, or unknown parameter (see dmesg)
b43 loaded successfully
b43legacy loaded successfully

Po instalaci mi šla wifi vypnout tlačítkem, ovšem zapnout už nešla :( Ani příkazem $ sudo ifconfig wlan0 up nešla zapnout.



Pokus 1: Nainstaloval jsem nejnovější compat-wireless > NEPOMOHLO.
Pokus 2: Použít ovladač z windowsu (stažený z HP) > fungovalo to dokonale. I po restartu. Pak jsem ale nabootoval windowsy a po jejich restartu se mi ubuntu sekl při bootování. Musel jsem přeinstalovat celej systém Linuxu :(

Ted jsem po nové instalaci ubuntu a tlačítko na wifi fungovalo 3krát po sobě. Třikrát jsem zapnul sitovku a už zapnout nejde :( Tlačítkem tedy zapnout nejde, ovšem příkazovou řádkou ano:
Citace
biolog@hubinka:~$ ifconfig
eth0      Link encap:Ethernet  HWadr 00:1a:4b:6f:e9:d6 
          AKTIVOVÁNO VŠESMĚROVÉ_VYSÍLÁNÍ MULTICAST  MTU:1500  Metrika:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          kolizí:0 délka odchozí fronty:1000
          Přijato bajtů: 0 (0.0 B) Odesláno bajtů: 0 (0.0 B)
          Přerušení:16

lo        Link encap:Místní smyčka 
          inet adr:127.0.0.1  Maska:255.0.0.0
          inet6-adr: ::1/128 Rozsah:Počítač
          AKTIVOVÁNO SMYČKA BĚŽÍ  MTU:16436  Metrika:1
          RX packets:256 errors:0 dropped:0 overruns:0 frame:0
          TX packets:256 errors:0 dropped:0 overruns:0 carrier:0
          kolizí:0 délka odchozí fronty:0
          Přijato bajtů: 16296 (16.2 KB) Odesláno bajtů: 16296 (16.2 KB)

biolog@hubinka:~$ sudo ifconfig wlan0 up
biolog@hubinka:~$ sudo ifconfig wlan0 up
SIOCSIFFLAGS: No such device
To jsou příkazy hned po sobě. Po prvním příkazu se sitovka zapla a tak jsem zkoušel chvíli mačkat tlačítko pro zapnutí a vypnutí. Po pár sekundách (cca 5x zapnuto a vypnuto) už zapnout nešla a nešla zapnout ani přes příkazovou řádku, jak vidíte ve výpise výše. Ty 2 příkazy hned po sobě.

Když jsem zkoušel zapínat a vypínat síťovku příkazy $ sudo ifconfig wlan0 up/down tak to šlo v pohodě pořád až do chvíle kdy se mi v notifikanční oblasti neobjevila zpráva „ Připojení k síti bylo odpojeno“ (taková ta bulbina nahoře). Působí to na mě, jako kdybych se mohl připojit jen dokud je síťovka „horká“. Jakmile ji nechám vyplou o chvilku déle, tak už ji nemůžu zapnout. Až zase po restartu.

Tak jsem po restartu. Tlačítkem zapnout nešla, ale přes příkaz ano. Pak šla i tlačítkem. A když jsem wifi zapínal / vypínal rychle po sobě, šlo to v pohodě. Ovšem, jakmile jsem ji nechal zapnoutou dostatečně dlouho na to, aby se začala přihlašovat do sítě a pak ji vypnul, zapnout už nešla. Zase se objeliva hláška v bublině „Připojení k síti bylo odpojeno“ a zapnout nešla vubec. Příkazová řádka vyhodila:
Citace
biolog@hubinka:~$ sudo ifconfig wlan0 up
SIOCSIFFLAGS: No such device

2) Taky se LED diodka na wifi chová jinak než ve Windowsech a docela často bliká. Blikání je asociováno s prací wifi, jakmile wifi přijímá nebo vysílá, LED bliká. Dost to táhne oči a já bych se toho chtěl zbavit – nevíte jak?


Kdyby mi někdo dokázal pomoci, byl bych mu velmi vděčný. Už nevím kde hledat pomoc :(


Info o systému
Distribuce: Ubuntu 8.1 (kernel: 2.6.27-7
Síťovka: Intel® PRO/Wireless 3945ABG Network Connection adapters.


Výpisy
Citace
LSPCI:
02:0e.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

IFCONFIG – během fungující síťovky:
eth0      Link encap:Ethernet  HWadr 00:1a:4b:6f:e9:d6 
          AKTIVOVÁNO VŠESMĚROVÉ_VYSÍLÁNÍ MULTICAST  MTU:1500  Metrika:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          kolizí:0 délka odchozí fronty:1000
          Přijato bajtů: 0 (0.0 B) Odesláno bajtů: 0 (0.0 B)
          Přerušení:16

lo        Link encap:Místní smyčka 
          inet adr:127.0.0.1  Maska:255.0.0.0
          inet6-adr: ::1/128 Rozsah:Počítač
          AKTIVOVÁNO SMYČKA BĚŽÍ  MTU:16436  Metrika:1
          RX packets:268 errors:0 dropped:0 overruns:0 frame:0
          TX packets:268 errors:0 dropped:0 overruns:0 carrier:0
         kolizí:0 délka odchozí fronty:0
          Přijato bajtů: 17008 (17.0 KB) Odesláno bajtů: 17008 (17.0 KB)

wlan0     Link encap:Ethernet  HWadr 00:1b:77:bc:4f:2f 
          inet adr:192.168.2.103  Všesměr:192.168.2.255  Maska:255.255.255.0
          inet6-adr: fe80::21b:77ff:febc:4f2f/64 Rozsah:Linka
          AKTIVOVÁNO VŠESMĚROVÉ_VYSÍLÁNÍ BĚŽÍ MULTICAST  MTU:1500  Metrika:1
          RX packets:16041 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11374 errors:0 dropped:0 overruns:0 carrier:0
          kolizí:0 délka odchozí fronty:1000
          Přijato bajtů: 22140528 (22.1 MB) Odesláno bajtů: 1375898 (1.3 MB)

wmaster0  Link encap:NEZNÁM  HWadr 00-1B-77-BC-4F-2F-66-32-00-00-00-00-00-00-00-00 
          AKTIVOVÁNO VŠESMĚROVÉ_VYSÍLÁNÍ BĚŽÍ MULTICAST  MTU:1500  Metrika:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          kolizí:0 délka odchozí fronty:1000
          Přijato bajtů: 0 (0.0 B) Odesláno bajtů: 0 (0.0 B)


IWCONFIG – během fungující síťovky:
lo        no wireless extensions.
eth0      no wireless extensions.
pan0      no wireless extensions.
wmaster0  no wireless extensions.
wlan0     IEEE 802.11abg  ESSID:"Medlanecka" 
          Mode:Managed  Frequency:2.417 GHz  Access Point: 00:0E:2E:92:6A:29   
          Bit Rate=1 Mb/s   Tx-Power=15 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Power Management:off
          Link Quality=80/100  Signal level:-54 dBm  Noise level=-92 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


IFCONFIG – vypnutá síťovka:
eth0      Link encap:Ethernet  HWadr 00:1a:4b:6f:e9:d6 
          AKTIVOVÁNO VŠESMĚROVÉ_VYSÍLÁNÍ MULTICAST  MTU:1500  Metrika:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          kolizí:0 délka odchozí fronty:1000
          Přijato bajtů: 0 (0.0 B) Odesláno bajtů: 0 (0.0 B)
          Přerušení:16

lo        Link encap:Místní smyčka 
          inet adr:127.0.0.1  Maska:255.0.0.0
          inet6-adr: ::1/128 Rozsah:Počítač
          AKTIVOVÁNO SMYČKA BĚŽÍ  MTU:16436  Metrika:1
          RX packets:268 errors:0 dropped:0 overruns:0 frame:0
          TX packets:268 errors:0 dropped:0 overruns:0 carrier:0
          kolizí:0 délka odchozí fronty:0
          Přijato bajtů: 17008 (17.0 KB) Odesláno bajtů: 17008 (17.0 KB)


IWCONFIG – vypnutá síťovka:
lo        no wireless extensions.
eth0      no wireless extensions.
pan0      no wireless extensions.
wmaster0  no wireless extensions.
wlan0     IEEE 802.11abg  ESSID:"Medlanecka" 
          Mode:Managed  Frequency:2.417 GHz  Access Point: Not-Associated   
          Tx-Power=15 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Lord Lover

  • Návštěvník
  • *
  • Příspěvků: 3
    • Zobrazit profil
Re: Nestandardní chování wifi - iwl3945 na HP nx7300
« Odpověď #1 kdy: 25 Listopad 2008, 23:12:52 »
Koukám, že jsem to napsal asi moc složitě. Zkusím to zkrátit:

Wifina mi jde zapnout jen jednou v ubuntu 8.10. Když ji vypnu a nechám odhlásit síť už nejde zapnout. A to ani tlačítkem, ani příkazem $ sudo ifconfig wlan0 up.
Nevíte jak to spravit?

Bližší podrobnosti viz víše. Děkuji

Martin Gabriel

  • Návštěvník
  • *
  • Příspěvků: 55
    • Zobrazit profil
Re: Nestandardní chování wifi - iwl3945 na HP nx7300
« Odpověď #2 kdy: 26 Listopad 2008, 09:56:53 »
Notebook HP Compaq 6720s /1024MB /Core2Duo /GPU Intel X3100 /WiFi /BT / Linux Ubuntu
V LINUXu jsem naprostý začátečník - tak to prosím omluvte a respektujte-Díky

truhlik

  • Závislák
  • ****
  • Příspěvků: 1626
    • Zobrazit profil
Re: Nestandardní chování wifi - iwl3945 na HP nx7300
« Odpověď #3 kdy: 26 Listopad 2008, 10:07:26 »
Zjistuj zda mas natazen modul (ovladac) pro tu kartu.
Kód: [Vybrat]
lsmod | grep iwlPripadne ho tam narvi:
Kód: [Vybrat]
sudo modprobe iwl3945a pozoruj vypis:
Kód: [Vybrat]
dmesg | tail
http://wiki.ubuntu.cz/P%C5%99ipojen%C3%AD%20disku
http://www.linuxsoft.cz/article.php?id_article=1351
http://www.root.cz/clanky/klonovani-obrazu-a-dva-monitory-v-linuxu
Citace: Otakar
Červi jsou moc milá zvířátka, zvláště když má jejich chovatel výhrady proti chování tučňáků

reaper

  • Člen
  • **
  • Příspěvků: 434
    • Zobrazit profil
    • http://ronny.rammsteinfan.cz/
Re: Nestandardní chování wifi - iwl3945 na HP nx7300
« Odpověď #4 kdy: 26 Listopad 2008, 11:36:01 »
Koukám, že jsem to napsal asi moc složitě. Zkusím to zkrátit:

Wifina mi jde zapnout jen jednou v ubuntu 8.10. Když ji vypnu a nechám odhlásit síť už nejde zapnout. A to ani tlačítkem, ani příkazem $ sudo ifconfig wlan0 up.
Nevíte jak to spravit?

Bližší podrobnosti viz víše. Děkuji

je to bug v kernelu... musis zapnout ubuntu s tlacitkem a wifi bohuzel nevypinat..  mel by byt update kernelu.. ale kdy to nevim :) via release notes
IBM/Lenovo Thinkpad R61 14", Intel Core 2 Duo T7250 - 2GHz @ 800MHz, 2GB RAM, 160GB + 300GB HDD, Intel X3100 - Ubuntu 8.04

Lord Lover

  • Návštěvník
  • *
  • Příspěvků: 3
    • Zobrazit profil
Re: Nestandardní chování wifi - iwl3945 na HP nx7300
« Odpověď #5 kdy: 26 Listopad 2008, 23:02:16 »
Výborně kluci, děkuji. Sice je to nepotěšující zpráva o tom bugu, ale co se dá dělat, už jsem se s tím naučil žít.

Co se týče výpisu, tak jen pro pořádek:
Citace
biolog@hubinka:~$ lsmod | grep iwl
iwl3945                98804  0
rfkill                 17176  2 iwl3945
mac80211              216820  1 iwl3945
led_class              12164  1 iwl3945
cfg80211               32392  2 iwl3945,mac80211
biolog@hubinka:~$ dmesg | tail
[   62.107203] wlan0: RX ReassocResp from 00:0e:2e:92:6a:29 (capab=0x401 status=0 aid=2)
[   62.107213] wlan0: associated
[   62.807691] CPU0 attaching NULL sched-domain.
[   62.807710] CPU1 attaching NULL sched-domain.
[   62.812113] CPU0 attaching sched-domain:
[   62.812123]  domain 0: span 0-1 level MC
[   62.812128]   groups: 0 1
[   62.812140] CPU1 attaching sched-domain:
[   62.812144]  domain 0: span 0-1 level MC
[   62.812149]   groups: 1 0
biolog@hubinka:~$
To vypadá v pořádku, alespoň si myslím.


A teď k bodu 2. Co dělat s tím blikáním té síťovky při každém přenosu?

umiyaki

  • Člen
  • **
  • Příspěvků: 194
    • Zobrazit profil
Re: Nestandardní chování wifi - iwl3945 na HP nx7300
« Odpověď #6 kdy: 26 Listopad 2008, 23:41:47 »
Výborně kluci, děkuji. Sice je to nepotěšující zpráva o tom bugu, ale co se dá dělat, už jsem se s tím naučil žít.

Co se týče výpisu, tak jen pro pořádek:
Citace
biolog@hubinka:~$ lsmod | grep iwl
iwl3945                98804  0
rfkill                 17176  2 iwl3945
mac80211              216820  1 iwl3945
led_class              12164  1 iwl3945
cfg80211               32392  2 iwl3945,mac80211
biolog@hubinka:~$ dmesg | tail
[   62.107203] wlan0: RX ReassocResp from 00:0e:2e:92:6a:29 (capab=0x401 status=0 aid=2)
[   62.107213] wlan0: associated
[   62.807691] CPU0 attaching NULL sched-domain.
[   62.807710] CPU1 attaching NULL sched-domain.
[   62.812113] CPU0 attaching sched-domain:
[   62.812123]  domain 0: span 0-1 level MC
[   62.812128]   groups: 0 1
[   62.812140] CPU1 attaching sched-domain:
[   62.812144]  domain 0: span 0-1 level MC
[   62.812149]   groups: 1 0
biolog@hubinka:~$
To vypadá v pořádku, alespoň si myslím.


A teď k bodu 2. Co dělat s tím blikáním té síťovky při každém přenosu?

Mám HP530, led umístěnu hned pod lcd uprostřed notebooku a je to o nervy. Na Ubuntu 8.10 jsem blikání a vypínání wifi tlačítkem řešil dost dlouho a dopadl stejně jako Ty. Na to, že je to hlášeno jako bug (vypínání) jsem přišel, ale po marných pokusech s blikáním (různé scripty, které měli fungovat a nefungovali) jsem se vrátil na Hardyho (ubuntu 8.04.1) Tady led nesvítí vůbec, ale tlačítko funguje bez problému. Vypnu, vypne se wifi, zapnu, zapne se wifi :-)
Pokud je blikání při přenosu funkce a ne bug, zůstávám na Hardym :-)
Testoval jsem dnes Fedoru 10 a tam tlačítko bliká a při vypnutí vyskočí dokonce hláška chyba kernelu. Jsou na tom trošku lépe, protože to jde opravit bez restartu.
Každopádně jsem si na to, že je ledka vypnutá zvykl natolik, že mi dnes vadilo i to, že se po startu Fedora Core 10 LiveCD pouze zapnula ... neblikala :-)

btw: KDE 4 ve fedoře ... hmmm ... kde je stabilita linuxu. Asi tam je, ale ukrytá hluboko pod tou grafickou nástavbou z vepřovicových cihel ... :-/
« Poslední změna: 26 Listopad 2008, 23:47:32 od umiyaki »
"Prvním stupněm debility je pocit geniality."
Notebook HP 530 - Ubuntu 10.04; PC P4 2.8GHz - Ubuntu 10.04

reaper

  • Člen
  • **
  • Příspěvků: 434
    • Zobrazit profil
    • http://ronny.rammsteinfan.cz/
Re: Nestandardní chování wifi - iwl3945 na HP nx7300
« Odpověď #7 kdy: 27 Listopad 2008, 09:10:47 »
ja mam teda IBM.. ale v /proc si ledku muzu vypnout pres

franta@flinta:~$ cat /proc/acpi/ibm/led
status:      supported
commands:   <led> on, <led> off, <led> blink (<led> is 0-7)

ale jak je to u HP nemam poneti.. jinak blikani je samozrejme feature.. spravne by to blikat melo :)
IBM/Lenovo Thinkpad R61 14", Intel Core 2 Duo T7250 - 2GHz @ 800MHz, 2GB RAM, 160GB + 300GB HDD, Intel X3100 - Ubuntu 8.04

umiyaki

  • Člen
  • **
  • Příspěvků: 194
    • Zobrazit profil
Re: Nestandardní chování wifi - iwl3945 na HP nx7300
« Odpověď #8 kdy: 27 Listopad 2008, 11:42:59 »
ja mam teda IBM.. ale v /proc si ledku muzu vypnout pres

franta@flinta:~$ cat /proc/acpi/ibm/led
status:      supported
commands:   <led> on, <led> off, <led> blink (<led> is 0-7)

ale jak je to u HP nemam poneti.. jinak blikani je samozrejme feature.. spravne by to blikat melo :)

Dík, zkusím. Nabootuji LiveCD U8.10 II a mrknu se na to...
"Prvním stupněm debility je pocit geniality."
Notebook HP 530 - Ubuntu 10.04; PC P4 2.8GHz - Ubuntu 10.04