Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Intel Corporation PRO/Wireless 3945ABG [vyřešeno]  (Přečteno 3350 krát)

fenquick

  • Člen
  • **
  • Příspěvků: 225
  • Professional llama
    • Zobrazit profil
    • Linux User #487408
Intel Corporation PRO/Wireless 3945ABG [vyřešeno]
« kdy: 06 Listopad 2008, 18:11:46 »
Intel Corporation PRO/Wireless 3945ABG

Po instalaci Kubuntu 8.10 jede tahle wifina v módu US (méně kanálů). Kde to lze nastavit na EU standard?
Potom - nepřipojím se network managerem pokud mám domácí wifinu zabezpečenou WEP - ASCII. Musím to mít HEX. Nevíte proč?
« Poslední změna: 17 Únor 2009, 18:03:32 od Petr Merlin Vaněček »
******** Neděkujte mně! Poděkujte přitažlivé síle Měsíce! ********
.........................................................................................MacGyver

Petr Merlin Vaněček

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5005
    • Zobrazit profil
    • Lomítkáři
Re: Intel Corporation PRO/Wireless 3945ABG
« Odpověď #1 kdy: 07 Listopad 2008, 20:35:08 »
Jaký modul je natažený pro tu kartu? Tuším, že v její dokumentaci bude přesně info o tom s jakým parametrem jej zavést, aby podporoval naše normy.

ASCII/HEX - problém je v tom, že pokud zadáváte klíč v ASCII je stejně převeden na HEXa a tím se autentifikuje u AP. Bohužel existují nejmenovaní výrobci, kteří převod (na straně AP) z ASCII do HEX prostě provedou podle svých vlastních pravidel - ano, je to nepochopitelné, neomluvitelné, leč po letech laborovaní a zjišťování konstatuji toto jako fakt. Tedy pokud se Vám dvě zařízení nechtějí potkat právě kvůli šifrování, zkuste použít na obou stranách HEXa.
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

fenquick

  • Člen
  • **
  • Příspěvků: 225
  • Professional llama
    • Zobrazit profil
    • Linux User #487408
Re: Intel Corporation PRO/Wireless 3945ABG
« Odpověď #2 kdy: 07 Listopad 2008, 22:35:30 »
Jak jsem již napsal - HEX funguje. Jen - že na HH to fungovalo v pohodě i v ASCII. Takže to na straně výrobce, hádám, až tak nebude.

Driver je "iwl3945"
« Poslední změna: 07 Listopad 2008, 22:40:48 od fenquick »
******** Neděkujte mně! Poděkujte přitažlivé síle Měsíce! ********
.........................................................................................MacGyver

Petr Merlin Vaněček

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5005
    • Zobrazit profil
    • Lomítkáři
Re: Intel Corporation PRO/Wireless 3945ABG
« Odpověď #3 kdy: 08 Listopad 2008, 08:02:25 »
http://intellinuxwireless.org/bugzilla/show_bug.cgi?id=1690
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/272407
...

Citace
I found, finally. I had to add to /etc/modprobe.d/options:

options cfg80211 ieee80211_regdom=EU

And I can connect, jippie.

I still consider it as a bug. this option should be enabled by default for all eu-country locale settings.
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

garmada

  • Člen
  • **
  • Příspěvků: 178
  • A.I.
    • Zobrazit profil
    • Môj blog o IT
Re: Intel Corporation PRO/Wireless 3945ABG
« Odpověď #4 kdy: 08 Listopad 2008, 14:19:21 »
Mam presne taku istu kartu a tiez som mal problem so sifrovanym, nainstaluj si KNetwork Manger ktory ide v poriadku. :)
Os: Ubuntu 9.10 Desktop i686 | Linux User #480898 | Ubuntu User #24615

fenquick

  • Člen
  • **
  • Příspěvků: 225
  • Professional llama
    • Zobrazit profil
    • Linux User #487408
Re: Intel Corporation PRO/Wireless 3945ABG
« Odpověď #5 kdy: 11 Listopad 2008, 20:30:31 »
1) Tak provedl jsem úpravu, ale stále vidím na 2,4G pouze 11 kanálů.
Kód: [Vybrat]
sudo kate /etc/modprobe.d/options

#EU norma pro wifinu
options cfg80211 ieee80211_regdom=EU

# Enable double-buffering so gstreamer et. al. work
options quickcam compatible=2

# Default hostap to managed mode
options hostap_pci iw_mode=2
options hostap_cs iw_mode=2

# Stop auto-association.
# LP: #264104
options ipw2200 associate=0

# XXX: Ignore HPA by default. Needs to be revisted in jaunty
options libata ignore_hpa=1

Kód: [Vybrat]
iwlist wlan0 channel
wlan0     19 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 36 : 5.18 GHz
          Channel 40 : 5.2 GHz
          Channel 44 : 5.22 GHz
          Channel 48 : 5.24 GHz
          Channel 52 : 5.26 GHz
          Channel 56 : 5.28 GHz
          Channel 60 : 5.3 GHz
          Channel 64 : 5.32 GHz
2) KNetwork Manager používám a dělá to to, co jsem popsal. :(

Na starším kernelu v Hardym to jelo jak má.
« Poslední změna: 11 Listopad 2008, 20:33:45 od fenquick »
******** Neděkujte mně! Poděkujte přitažlivé síle Měsíce! ********
.........................................................................................MacGyver

Petr Merlin Vaněček

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5005
    • Zobrazit profil
    • Lomítkáři
Re: Intel Corporation PRO/Wireless 3945ABG
« Odpověď #6 kdy: 11 Listopad 2008, 20:48:11 »
Zkuste ten parametr ieee80211_regdom=EU hodit za options ipw2200 associate=0
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

fenquick

  • Člen
  • **
  • Příspěvků: 225
  • Professional llama
    • Zobrazit profil
    • Linux User #487408
Re: Intel Corporation PRO/Wireless 3945ABG
« Odpověď #7 kdy: 11 Listopad 2008, 20:57:27 »
Pořád stejné.
******** Neděkujte mně! Poděkujte přitažlivé síle Měsíce! ********
.........................................................................................MacGyver

Petr Merlin Vaněček

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5005
    • Zobrazit profil
    • Lomítkáři
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

fenquick

  • Člen
  • **
  • Příspěvků: 225
  • Professional llama
    • Zobrazit profil
    • Linux User #487408
Re: Intel Corporation PRO/Wireless 3945ABG
« Odpověď #9 kdy: 11 Listopad 2008, 21:36:10 »
Hm, to se mi nezdá.  Na HH jsem nic patchovat nemusel a jelo to jak má.

(A patchovat EEPROM - no to už vůbec!!  :D)
******** Neděkujte mně! Poděkujte přitažlivé síle Měsíce! ********
.........................................................................................MacGyver

fenquick

  • Člen
  • **
  • Příspěvků: 225
  • Professional llama
    • Zobrazit profil
    • Linux User #487408
Re: Intel Corporation PRO/Wireless 3945ABG
« Odpověď #10 kdy: 17 Únor 2009, 15:46:40 »
Info o modulech souvisejících s wifinou:
Kód: [Vybrat]
lsmod | grep iwl3945
iwl3945                96920  0
rfkill                 17176  4 thinkpad_acpi,iwl3945
lbm_cw_mac80211       215856  1 iwl3945
lib80211               15236  1 iwl3945
lbm_cw_cfg80211        46744  2 iwl3945,lbm_cw_mac80211
led_class              12164  2 thinkpad_acpi,iwl3945

Z toho plyne zaklínadlo:

Kód: [Vybrat]
sudo sh -c "echo 'options lbm_cw_cfg80211 ieee80211_regdom=\"EU\"' > /etc/modprobe.d/lbm_cw_cfg80211"
« Poslední změna: 17 Únor 2009, 15:52:22 od fenquick »
******** Neděkujte mně! Poděkujte přitažlivé síle Měsíce! ********
.........................................................................................MacGyver

Petr Merlin Vaněček

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5005
    • Zobrazit profil
    • Lomítkáři
Re: Intel Corporation PRO/Wireless 3945ABG [vyřešeno]
« Odpověď #11 kdy: 17 Únor 2009, 18:03:48 »
k+ :)
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

plusik

  • Člen
  • **
  • Příspěvků: 209
    • Zobrazit profil
Intel Corporation PRO/Wireless 3945ABG-nejde vůbec
« Odpověď #12 kdy: 22 Únor 2009, 18:08:13 »
dobrý den já mám problém s touto kartou..po instalaci kubuntu tato karta nejede prostě vůbec, iwlist vypíše "root@radek-kubuntu:/home/radek# iwlist wlan0 scan
wlan0     Interface doesn't support scanning : Network is down" :-( přitom, ale když zadám ifup wlan0, vyleze toto "root@radek-kubuntu:/home/radek# ifup wlan0
Ignoring unknown interface wlan0=wlan0"

Petr Merlin Vaněček

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5005
    • Zobrazit profil
    • Lomítkáři
Re: Intel Corporation PRO/Wireless 3945ABG [vyřešeno]
« Odpověď #13 kdy: 22 Únor 2009, 20:14:55 »
Dejte sem prosím výpis
Kód: [Vybrat]
lspci
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová