Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Ubuntu 8.04 a ati x1350?  (Přečteno 798 krát)

Cepo

  • Návštěvník
  • Příspěvků: 4
Ubuntu 8.04 a ati x1350?
« kdy: 02 Listopadu 2009, 14:30:51 »
Pozdravujem všetkých.

Vo verzii Ubuntu 9.10 sa mi ani za svet nepodarilo rozbehnúť grafiku ati mobility radeon X1350. Správca neslobodných ovládačov ju ani nezobrazí - a najnovšie
ovládače zo stránky ati nie sú podporované v tejto verzii. Spravil som preto downgrade na ubuntu 8.04. Cez správcu som nainštaloval ovládače a cez syntaptic
som dohodil fglrx ati catalyst control center - 3D rendering funguje, fglrxinfo píše ati radeon X1350 glxgears v priemere 2600 FPS /5 sec. Nainštaloval som RTCW
originál pre linux - multiplayer demo - no výkon je strašne nízky. Som však nováčik, neviem či je to normálne, no myslím že na tak starej hre by ten výkon mal
byť vyšší. Alebo je to v linuxe normálne? Neexistuje dáky spôsob ako ho mám zvýšiť a upraviť FPS? Za akékoľvek informácie vopred dík.

Evžen Šubrt

  • Závislák
  • ***
  • Příspěvků: 2218
    • EuGenio's Lair
Re: Ubuntu 8.04 a ati x1350?
« Odpověď #1 kdy: 02 Listopadu 2009, 15:01:04 »
1) Na Ubuntu 9.04 a 9.10 (a na všech dalších) nemůžeš s tvojí kartou (konkrétně se všemi, které nejsou "HD") používat ovladače od ATI, protože buď nepodporují tvojí kartu nebo nejsou kompatibilní s novým xserverem.
2) V 8.04 (nebo v 8.10) zkus nainstalovat poslední ovladače podporující tvojí kartu - konprétně to je Catalyst 9-3 (dá se stáhnout ze stránek ATI). K instalaci můžeš použív i tento návod - metoda 2 (akorát všude zaměníš 9-10 za 9-3).
Athlon X2 6000+, MB ASUS M2R32-MVP, 6GB RAM, ATI Radeon HD7850 1GB, 1GB SSHD + 250GB HDD, Ubuntu 13.10 Saucy Salamander 64bit

Cepo

  • Návštěvník
  • Příspěvků: 4
Re: Ubuntu 8.04 a ati x1350?
« Odpověď #2 kdy: 02 Listopadu 2009, 17:00:16 »
Ahoj, no spravil som to presne podľa toho manuálu. Všetko šlo bez akýchkoľvek problémov. No fglrxinfo mi stále hlási iba MESU  :-\
Píše sa tam, že pokiaľ to hlási MESU, musím odobrať balíček xserver-xgl príkazom "sudo apt-get remove xserver-xgl".
No hlási mi:

Balík xserver-xgl nie je nainštalovaný, nedá sa teda odstrániť

Dalej sa tam píše, že pokiaľ je to "důvodu nepovoleného "Composite", zkontrolujte svůj xorg.conf, jestli sekce "Extension" neobsahuje řádku Option "Composite" "Disabled". Pokud ano, změňte nastavení na "Enabled".

To som chcel aj urobiť, no môj xorg.conf žiadnu sekciu "Extensions" neobsahuje. Myslíš že by som to tam mal manuálne dopísať? A ak, tak na ktoré miesto v poradí
medzi ostatnými informáciami v xorg ?

Evžen Šubrt

  • Závislák
  • ***
  • Příspěvků: 2218
    • EuGenio's Lair
Re: Ubuntu 8.04 a ati x1350?
« Odpověď #3 kdy: 02 Listopadu 2009, 18:56:53 »
Hmm, podivné.

Zkus. co vypíše
Kód: [Vybrat]
sudo fglrxinfo
glxinfo | grep direct
jestli mesa a No, tak bych odinstalovat ovladač fglrx (postup v návodu), nainstaloval ovladač z repozitářů (metoda 0 či 1), zkusil funkčnost a potom kdyžtak nahodil 9-3 pomocí metody 2.
Athlon X2 6000+, MB ASUS M2R32-MVP, 6GB RAM, ATI Radeon HD7850 1GB, 1GB SSHD + 250GB HDD, Ubuntu 13.10 Saucy Salamander 64bit

 

Provoz zaštiťuje spolek OpenAlt.