Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Aktualizacie vypisujú chyby, ako to opravím ? [vyriešené]  (Přečteno 3110 krát)

eva

  • Návštěvník
  • Příspěvků: 23
Pri aktualizácii vždy a pri inštalácii nejakých programov mi vypisuje chyby. Skúšala som preinštalovať niektoré z programov, ktoré zlyhali (napr. som si našla v synaptiku python), ale neúspešne, chyby to vypisuje stále. Neviete, čo mám opraviť?
Kód: [Vybrat]
E: update-manager-core: podproces instalovaný post-installation skript vrátil chybový status 1
E: python-problem-report: podproces instalovaný post-installation skript vrátil chybový status 1
E: python-apport: problém se závislostmi - nechávám nezkonfigurované
E: apport: problém se závislostmi - nechávám nezkonfigurované
E: apport-gtk: problém se závislostmi - nechávám nezkonfigurované
E: jockey-common: podproces instalovaný post-installation skript vrátil chybový status 1
E: jockey-gtk: problém se závislostmi - nechávám nezkonfigurované
E: libgda-4.0-4: podproces instalovaný post-installation skript vrátil chybový status 2
E: libgdl-1-3: podproces instalovaný post-installation skript vrátil chybový status 2
E: nvidia-common: podproces instalovaný post-installation skript vrátil chybový status 1
E: python2.5-minimal: podproces instalovaný post-installation skript vrátil chybový status 2
E: python2.5: problém se závislostmi - nechávám nezkonfigurované
E: python-all: problém se závislostmi - nechávám nezkonfigurované
E: python-eggtrayicon: podproces instalovaný post-installation skript vrátil chybový status 2
E: python-gda: problém se závislostmi - nechávám nezkonfigurované
E: python-gdl: problém se závislostmi - nechávám nezkonfigurované
E: python-gksu2: podproces instalovaný post-installation skript vrátil chybový status 2
E: python-gtkspell: podproces instalovaný post-installation skript vrátil chybový status 2
E: python-gnome2-extras: problém se závislostmi - nechávám nezkonfigurované
E: python-ubuntuone-client: podproces instalovaný post-installation skript vrátil chybový status 1
E: ubuntuone-client: problém se závislostmi - nechávám nezkonfigurované
E: ubuntuone-client-gnome: problém se závislostmi - nechávám nezkonfigurované
E: update-manager: problém se závislostmi - nechávám nezkonfigurované
« Poslední změna: 28 Ledna 2010, 17:52:02 od eva »
Acer Aspire 5310, Ubuntu 9.10

arrange

  • Závislák
  • ***
  • Příspěvků: 4031
  • "jdu s hlavou vztyčenou..."
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #1 kdy: 23 Ledna 2010, 22:01:58 »
To vypadá pěkně rozhašeně...  :(

Pošli nám tady podrobnější výpis, viz můj příspěvek
http://forum.ubuntu.cz/index.php/topic,43544.msg318152.html#msg318152

Také jaké máš Ubuntu a výpis z
Kód: [Vybrat]
grep '^[^#]' /etc/apt/sources.list
http://www.openstreetmap.org - mapy celého světa "wiki style"

eva

  • Návštěvník
  • Příspěvků: 23
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #2 kdy: 23 Ledna 2010, 22:13:40 »
takže najprv ten grep Ubuntu 9.10):
Kód: [Vybrat]
eee@eee-nbacer:~$ grep '^[^#]' /etc/apt/sources.list
deb http://cz.archive.ubuntu.com/ubuntu/ karmic main restricted
deb-src http://cz.archive.ubuntu.com/ubuntu/ karmic main restricted
deb http://cz.archive.ubuntu.com/ubuntu/ karmic universe
deb-src http://cz.archive.ubuntu.com/ubuntu/ karmic universe
deb http://cz.archive.ubuntu.com/ubuntu/ karmic multiverse
deb-src http://cz.archive.ubuntu.com/ubuntu/ karmic multiverse
deb http://security.ubuntu.com/ubuntu/ karmic-security restricted main multiverse universe
deb http://cz.archive.ubuntu.com/ubuntu/ karmic-updates restricted main multiverse universe
Potom z tej odkazovanej stranky - dpkg -vypísalo mi nekonečný zoznam chýb...
Kód: [Vybrat]
root@eee-nbacer:~# rm -f /var/lib/apt/lists/partial/*
root@eee-nbacer:~# rm -f /var/cache/apt/archives/partial/*
root@eee-nbacer:~# dpkg --configure -a
Nastavuji balík python-gtkspell (2.25.3-3ubuntu1) ...
dpkg (podproces): nelze spustit instalovaný post-installation skript: Exec format error
dpkg: chyba při zpracovávání python-gtkspell (--configure):
 podproces instalovaný post-installation skript vrátil chybový status 2
Nastavuji balík python-eggtrayicon (2.25.3-3ubuntu1) ...
dpkg (podproces): nelze spustit instalovaný post-installation skript: Exec format error
dpkg: chyba při zpracovávání python-eggtrayicon (--configure):
 podproces instalovaný post-installation skript vrátil chybový status 2
Nastavuji balík python-ubuntuone-client (1.0.2-0ubuntu2) ...
Traceback (most recent call last):
  File "/usr/bin/pycentral", line 2196, in <module>
    main()
  File "/usr/bin/pycentral", line 2190, in main
    rv = action.run(global_options)
  File "/usr/bin/pycentral", line 1502, in run
    self.options.exclude, byte_compile_default=True)
  File "/usr/bin/pycentral", line 1088, in install
    rt.byte_compile(linked_files, bc_option, exclude_regex, ignore_errors)
  File "/usr/bin/pycentral", line 231, in byte_compile
    shell=False, stdin=subprocess.PIPE)
  File "/usr/lib/python2.6/subprocess.py", line 621, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1126, in _execute_child
    raise child_exception
OSError: [Errno 8] Exec format error
dpkg: chyba při zpracovávání python-ubuntuone-client (--configure):
 podproces instalovaný post-installation skript vrátil chybový status 1
Nastavuji balík libgda-4.0-4 (4.0.4-1ubuntu3) ...
dpkg (podproces): nelze spustit instalovaný post-installation skript: Exec format error
dpkg: chyba při zpracovávání libgda-4.0-4 (--configure):
 podproces instalovaný post-installation skript vrátil chybový status 2
Nastavuji balík jockey-common (0.5.5-0ubuntu3) ...
Traceback (most recent call last):
  File "/usr/bin/pycentral", line 2196, in <module>
    main()
  File "/usr/bin/pycentral", line 2190, in main
    rv = action.run(global_options)
  File "/usr/bin/pycentral", line 1502, in run
    self.options.exclude, byte_compile_default=True)
  File "/usr/bin/pycentral", line 1094, in install
    rt.byte_compile(files, bc_option, exclude_regex, ignore_errors)
  File "/usr/bin/pycentral", line 231, in byte_compile
    shell=False, stdin=subprocess.PIPE)
  File "/usr/lib/python2.6/subprocess.py", line 621, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1126, in _execute_child
    raise child_exception
OSError: [Errno 8] Exec format error
dpkg: chyba při zpracovávání jockey-common (--configure):
 podproces instalovaný post-installation skript vrátil chybový status 1
Nastavuji balík python2.5-minimal (2.5.4-1ubuntu6) ...
dpkg (podproces): nelze spustit instalovaný post-installation skript: Exec format error
dpkg: chyba při zpracovávání python2.5-minimal (--configure):
 podproces instalovaný post-installation skript vrátil chybový status 2
dpkg: nesplněné závislosti zamezily konfiguraci balíku ubuntuone-client:
 ubuntuone-client závisí na python-ubuntuone-client (= 1.0.2-0ubuntu2); avšak:
  Balík python-ubuntuone-client zatím není zkonfigurován.
dpkg: chyba při zpracovávání ubuntuone-client (--configure):
 problém se závislostmi - nechávám nezkonfigurované
dpkg: nesplněné závislosti zamezily konfiguraci balíku python-gda:
 python-gda závisí na libgda-4.0-4; avšak:
  Balík libgda-4.0-4 zatím není zkonfigurován.
dpkg: chyba při zpracovávání python-gda (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Nastavuji balík update-manager-core (1:0.126.9) ...
Traceback (most recent call last):
  File "/usr/bin/pycentral", line 2196, in <module>
    main()
  File "/usr/bin/pycentral", line 2190, in main
    rv = action.run(global_options)
  File "/usr/bin/pycentral", line 1502, in run
    self.options.exclude, byte_compile_default=True)
  File "/usr/bin/pycentral", line 1094, in install
    rt.byte_compile(files, bc_option, exclude_regex, ignore_errors)
  File "/usr/bin/pycentral", line 231, in byte_compile
    shell=False, stdin=subprocess.PIPE)
  File "/usr/lib/python2.6/subprocess.py", line 621, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1126, in _execute_child
    raise child_exception
OSError: [Errno 8] Exec format error
dpkg: chyba při zpracovávání update-manager-core (--configure):
 podproces instalovaný post-installation skript vrátil chybový status 1
dpkg: nesplněné závislosti zamezily konfiguraci balíku python2.5:
 python2.5 závisí na python2.5-minimal (= 2.5.4-1ubuntu6); avšak:
  Balík python2.5-minimal zatím není zkonfigurován.
dpkg: chyba při zpracovávání python2.5 (--configure):
 problém se závislostmi - nechávám nezkonfigurované
dpkg: nesplněné závislosti zamezily konfiguraci balíku ubuntuone-client-gnome:
 ubuntuone-client-gnome závisí na ubuntuone-client (= 1.0.2-0ubuntu2); avšak:
  Balík ubuntuone-client zatím není zkonfigurován.
dpkg: chyba při zpracovávání ubuntuone-client-gnome (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Nastavuji balík python-problem-report (1.9.3-0ubuntu4.2) ...
Traceback (most recent call last):
  File "/usr/bin/pycentral", line 2196, in <module>
    main()
  File "/usr/bin/pycentral", line 2190, in main
    rv = action.run(global_options)
  File "/usr/bin/pycentral", line 1502, in run
    self.options.exclude, byte_compile_default=True)
  File "/usr/bin/pycentral", line 1094, in install
    rt.byte_compile(files, bc_option, exclude_regex, ignore_errors)
  File "/usr/bin/pycentral", line 231, in byte_compile
    shell=False, stdin=subprocess.PIPE)
  File "/usr/lib/python2.6/subprocess.py", line 621, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1126, in _execute_child
    raise child_exception
OSError: [Errno 8] Exec format error
dpkg: chyba při zpracovávání python-problem-report (--configure):
 podproces instalovaný post-installation skript vrátil chybový status 1
Nastavuji balík python-gksu2 (2.25.3-3ubuntu1) ...
dpkg (podproces): nelze spustit instalovaný post-installation skript: Exec format error
dpkg: chyba při zpracovávání python-gksu2 (--configure):
 podproces instalovaný post-installation skript vrátil chybový status 2
dpkg: nesplněné závislosti zamezily konfiguraci balíku jockey-gtk:
 jockey-gtk závisí na jockey-common (= 0.5.5-0ubuntu3); avšak:
  Balík jockey-common zatím není zkonfigurován.
dpkg: chyba při zpracovávání jockey-gtk (--configure):
 problém se závislostmi - nechávám nezkonfigurované
dpkg: nesplněné závislosti zamezily konfiguraci balíku python-all:
 python-all závisí na python2.5; avšak:
  Balík python2.5 zatím není zkonfigurován.
dpkg: chyba při zpracovávání python-all (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Nastavuji balík nvidia-common (0.2.15.1) ...
Traceback (most recent call last):
  File "/usr/bin/pycentral", line 2196, in <module>
    main()
  File "/usr/bin/pycentral", line 2190, in main
    rv = action.run(global_options)
  File "/usr/bin/pycentral", line 1502, in run
    self.options.exclude, byte_compile_default=True)
  File "/usr/bin/pycentral", line 1094, in install
    rt.byte_compile(files, bc_option, exclude_regex, ignore_errors)
  File "/usr/bin/pycentral", line 231, in byte_compile
    shell=False, stdin=subprocess.PIPE)
  File "/usr/lib/python2.6/subprocess.py", line 621, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1126, in _execute_child
    raise child_exception
OSError: [Errno 8] Exec format error
dpkg: chyba při zpracovávání nvidia-common (--configure):
 podproces instalovaný post-installation skript vrátil chybový status 1
Nastavuji balík libgdl-1-3 (2.28.0-1) ...
dpkg (podproces): nelze spustit instalovaný post-installation skript: Exec format error
dpkg: chyba při zpracovávání libgdl-1-3 (--configure):
 podproces instalovaný post-installation skript vrátil chybový status 2
dpkg: nesplněné závislosti zamezily konfiguraci balíku update-manager:
 update-manager závisí na update-manager-core (= 1:0.126.9); avšak:
  Balík update-manager-core zatím není zkonfigurován.
dpkg: chyba při zpracovávání update-manager (--configure):
 problém se závislostmi - nechávám nezkonfigurované
dpkg: nesplněné závislosti zamezily konfiguraci balíku python-gnome2-extras:
 python-gnome2-extras závisí na python-eggtrayicon (= 2.25.3-3ubuntu1); avšak:
  Balík python-eggtrayicon zatím není zkonfigurován.
 python-gnome2-extras závisí na python-gtkspell (= 2.25.3-3ubuntu1); avšak:
  Balík python-gtkspell zatím není zkonfigurován.
 python-gnome2-extras závisí na python-gksu2 (= 2.25.3-3ubuntu1); avšak:
  Balík python-gksu2 zatím není zkonfigurován.
 python-gnome2-extras závisí na python-gda (= 2.25.3-3ubuntu1); avšak:
  Balík python-gda zatím není zkonfigurován.
dpkg: chyba při zpracovávání python-gnome2-extras (--configure):
 problém se závislostmi - nechávám nezkonfigurované
dpkg: nesplněné závislosti zamezily konfiguraci balíku python-apport:
 python-apport závisí na python-problem-report (>= 0.94); avšak:
  Balík python-problem-report zatím není zkonfigurován.
dpkg: chyba při zpracovávání python-apport (--configure):
 problém se závislostmi - nechávám nezkonfigurované
dpkg: nesplněné závislosti zamezily konfiguraci balíku python-gdl:
 python-gdl závisí na libgdl-1-3; avšak:
  Balík libgdl-1-3 zatím není zkonfigurován.
dpkg: chyba při zpracovávání python-gdl (--configure):
 problém se závislostmi - nechávám nezkonfigurované
dpkg: nesplněné závislosti zamezily konfiguraci balíku apport:
 apport závisí na python-apport (>= 0.120); avšak:
  Balík python-apport zatím není zkonfigurován.
dpkg: chyba při zpracovávání apport (--configure):
 problém se závislostmi - nechávám nezkonfigurované
dpkg: nesplněné závislosti zamezily konfiguraci balíku apport-gtk:
 apport-gtk závisí na python-apport (>= 0.80); avšak:
  Balík python-apport zatím není zkonfigurován.
 apport-gtk závisí na apport (>= 0.41); avšak:
  Balík apport zatím není zkonfigurován.
dpkg: chyba při zpracovávání apport-gtk (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Při zpracování nastaly chyby:
 python-gtkspell
 python-eggtrayicon
 python-ubuntuone-client
 libgda-4.0-4
 jockey-common
 python2.5-minimal
 ubuntuone-client
 python-gda
 update-manager-core
 python2.5
 ubuntuone-client-gnome
 python-problem-report
 python-gksu2
 jockey-gtk
 python-all
 nvidia-common
 libgdl-1-3
 update-manager
 python-gnome2-extras
 python-apport
 python-gdl
 apport
 apport-gtk
root@eee-nbacer:~#
« Poslední změna: 24 Ledna 2010, 12:57:40 od eva »
Acer Aspire 5310, Ubuntu 9.10

arrange

  • Závislák
  • ***
  • Příspěvků: 4031
  • "jdu s hlavou vztyčenou..."
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #3 kdy: 23 Ledna 2010, 22:49:15 »
?Co vypíše
Kód: [Vybrat]
sudo update-python-modules -v python-gtkspell.public
« Poslední změna: 23 Ledna 2010, 23:01:35 od arrange »
http://www.openstreetmap.org - mapy celého světa "wiki style"

eva

  • Návštěvník
  • Příspěvků: 23
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #4 kdy: 24 Ledna 2010, 07:51:51 »
Kód: [Vybrat]
WARNING: Parse error in /usr/share/python-support/python-gtkspell.public
WARNING: Parse error in /usr/share/python-support/python-gksu2.public
WARNING: Parse error in /usr/share/python-support/python-gda.public
WARNING: Parse error in /usr/share/python-support/python-gda.public
WARNING: Parse error in /usr/share/python-support/python-gnome2-extras.public
WARNING: Parse error in /usr/share/python-support/python-eggtrayicon.public
WARNING: Parse error in /usr/share/python-support/python-eggtrayicon.public
WARNING: Parse error in /usr/share/python-support/python-gdl.public
Generation of /usr/lib/pymodules/python2.5/.path...
Byte-compilation of whole /usr/lib/pymodules/python2.5...
Generation of /usr/lib/pymodules/python2.6/.path...
Byte-compilation of whole /usr/lib/pymodules/python2.6...
eee@eee-nbacer:~$
« Poslední změna: 24 Ledna 2010, 12:59:05 od eva »
Acer Aspire 5310, Ubuntu 9.10

arrange

  • Závislák
  • ***
  • Příspěvků: 4031
  • "jdu s hlavou vztyčenou..."
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #5 kdy: 24 Ledna 2010, 10:36:08 »
Co obsahuje např. soubor /usr/share/python-support/python-gtkspell.public?
http://www.openstreetmap.org - mapy celého světa "wiki style"

eva

  • Návštěvník
  • Příspěvků: 23
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #6 kdy: 24 Ledna 2010, 11:42:26 »
Kód: [Vybrat]
eee@eee-nbacer:~$ /usr/share/python-support/python-gtkspell.public
bash: /usr/share/python-support/python-gtkspell.public: Permission denied

ale ked si ten súbor vyhladám a  pozriem priamo, tak je tam toto:

Kód: [Vybrat]
[MIME Cache]
application/vnd.ms-powerpoint.slideshow.macroEnabled.12=openoffice.org-impress.desktop
text/plain=openo
« Poslední změna: 24 Ledna 2010, 12:58:35 od eva »
Acer Aspire 5310, Ubuntu 9.10

arrange

  • Závislák
  • ***
  • Příspěvků: 4031
  • "jdu s hlavou vztyčenou..."
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #7 kdy: 24 Ledna 2010, 12:10:42 »
Jak je možné, že tam máš MIME?! Instalovala jsi něco z jiných než oficiálních repozitářů?

Vezmi postupně tyto balíky:
Kód: [Vybrat]
python-gtkspell
python-gksu2
python-gda
python-gnome2-extras
python-eggtrayicon
python-gdl
Najeď do adresáře /var/lib/dpkg/info/ a najdi k těm balíkům odpovídající .postrm a .postinst soubory. Tzn. např. pro ten první balík to jsou soubory
/var/lib/dpkg/info/python-gtkspell.postinst
/var/lib/dpkg/info/python-gtkspell.postrm

Vymaž všechny ty soubory. Budeš potřebovat práva roota, takže to můžeš udělat třeba přes Alt+F2 a gksudo nautilus.
Potom odinstaluj všechny ty balíky, třeba přes Synaptic.

Kdyby byla nějaká chyba, zkopíruj ji zase sem. Pokud ne, zkus znovu postup viz můj první příspěvek.
http://www.openstreetmap.org - mapy celého světa "wiki style"

eva

  • Návštěvník
  • Příspěvků: 23
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #8 kdy: 24 Ledna 2010, 12:36:35 »
Balíčky som zmazala, ale iba *.postinst. Žiaden nebol *.postrm, všetky majú ale  *.prerm.

Začala som odinštalovávař cez synaptic, vypísalo chybu:
E: python-gksu2: podproces instalovaný pre-removal skript vrátil chybový status 2
E: python-gtkspell: podproces instalovaný pre-removal skript vrátil chybový status 2

K tomu MIME - viem instalovat iba cez synaptic, takže asi iba oficiálne zdroje, nič iné som tam nepridávala.
Acer Aspire 5310, Ubuntu 9.10

arrange

  • Závislák
  • ***
  • Příspěvků: 4031
  • "jdu s hlavou vztyčenou..."
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #9 kdy: 24 Ledna 2010, 12:43:18 »
Takže vymaž i ty prerm soubory. Pak je budem zpátky instalovat, takže to nevadí.
http://www.openstreetmap.org - mapy celého světa "wiki style"

eva

  • Návštěvník
  • Příspěvků: 23
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #10 kdy: 24 Ledna 2010, 12:51:58 »
Tak som vymazala aj *prerm, ale zase chyba pri odinštalácii cez Synaptic:
Kód: [Vybrat]
E: update-manager-core: podproces instalovaný post-installation skript vrátil chybový status 1
E: python-problem-report: podproces instalovaný post-installation skript vrátil chybový status 1
E: python-apport: problém se závislostmi - nechávám nezkonfigurované
E: apport: problém se závislostmi - nechávám nezkonfigurované
E: apport-gtk: problém se závislostmi - nechávám nezkonfigurované
E: jockey-common: podproces instalovaný post-installation skript vrátil chybový status 1
E: jockey-gtk: problém se závislostmi - nechávám nezkonfigurované
E: libgda-4.0-4: podproces instalovaný post-installation skript vrátil chybový status 2
E: libgdl-1-3: podproces instalovaný post-installation skript vrátil chybový status 2
E: nvidia-common: podproces instalovaný post-installation skript vrátil chybový status 1
E: python2.5-minimal: podproces instalovaný post-installation skript vrátil chybový status 2
E: python2.5: problém se závislostmi - nechávám nezkonfigurované
E: python-all: problém se závislostmi - nechávám nezkonfigurované
E: python-ubuntuone-client: podproces instalovaný post-installation skript vrátil chybový status 1
E: ubuntuone-client: problém se závislostmi - nechávám nezkonfigurované
E: ubuntuone-client-gnome: problém se závislostmi - nechávám nezkonfigurované
E: update-manager: problém se závislostmi - nechávám nezkonfigurované
[\code]
Acer Aspire 5310, Ubuntu 9.10

arrange

  • Závislák
  • ***
  • Příspěvků: 4031
  • "jdu s hlavou vztyčenou..."
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #11 kdy: 24 Ledna 2010, 12:58:40 »
Pokud je v tom výpise u balíku podproces instalovaný post-installation skript vrátil chybový status, vymaž tomu balíku ty soubory postinst.

Pozor potom při odinstalovávání. Pokud by to hlásilo, že to chce odinstalovat kromě daného balíku ještě nějaké další, pečlivě to zkontroluj, příp. se zeptej.

Pro jistotu si i zálohuj důležitá data, máš to dost rozvrtaný.
http://www.openstreetmap.org - mapy celého světa "wiki style"

eva

  • Návštěvník
  • Příspěvků: 23
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #12 kdy: 24 Ledna 2010, 17:27:01 »
No, nepodarilo sa.... Odinštalovala som všetko podla chybových výpisov, potom postupne
Kód: [Vybrat]
sudo -s
rm -f /var/lib/apt/lists/partial/*
rm -f /var/cache/apt/archives/partial/*
dpkg --configure -a
apt-get update
apt-get install -f
apt-get dist-upgrade
Vypísalo mi to nejakú chybu pri upgrade, ale neviem nájsť súbor, kde som si to uložila...
Chcelo to reštart, ale už som Ubuntu úspešne nespustila. Recovery mode ide, ale tam neviem čo mám robiť, ide aj predchádzajúca verzia 2.6.31-14-generic.
Možem teraz upgradovať pomocou
Kód: [Vybrat]
sudo apt-get upgrade
 aby mi znova fungovala tá tuším 2.6.31-17? Nechcem to už viac pokaziť, tak sa pýtam.

Podarilo sa mi najsť ten súbor s chybovým výpisom pri upgrade:
Kód: [Vybrat]
Zpracování spouštěčů pro balík libc-bin ...
ldconfig deferred processing now taking place
/sbin/ldconfig.real: /usr/lib/libdb-4.6.so is not an ELF file - it has the wrong magic bytes at the start.

dpkg-deb: „/var/cache/apt/archives/gcc-4.4-base_4.4.1-4ubuntu9_i386.deb“ nemá formát balíku debian
dpkg: chyba při zpracovávání /var/cache/apt/archives/gcc-4.4-base_4.4.1-4ubuntu9_i386.deb (--unpack):
 podproces dpkg-deb --control vrátil chybový status 2
Při zpracování nastaly chyby:
 /var/cache/apt/archives/gcc-4.4-base_4.4.1-4ubuntu9_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
« Poslední změna: 24 Ledna 2010, 18:00:51 od eva »
Acer Aspire 5310, Ubuntu 9.10

arrange

  • Závislák
  • ***
  • Příspěvků: 4031
  • "jdu s hlavou vztyčenou..."
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #13 kdy: 24 Ledna 2010, 20:57:28 »
Těch chyb je opravdu nějak moc, nejdřív bych doporučoval zkontrolovat disk na chyby:
- nejlépe asi v LiveCD přes GParted/Editor diskových oddílů (Oddíl → Zkontrolovat)
- dále je možno zkontrolovat SMART data z disku - viz
http://forum.ubuntu.cz/index.php/topic,43533.msg318155.html

Pokud je disk v pořádku, zkusil bych najet do recovery mode (možnost netroot) a opravit tu knihovnu - viz
/sbin/ldconfig.real: /usr/lib/libdb-4.6.so is not an ELF file - it has the wrong magic bytes at the start.
takto
Kód: [Vybrat]
apt-get install --reinstall libdb4.6
Když už v tom recovery budeš, zvol ještě volbu clean a nakonec dpkg.

Pokud nedává žádné chyby, zkus restartovat. Pokud ti jde starý kernel, to stejné se dá udělat v něm.
Pak nainstaluj zpět všechny balíky, kterés' odinstalovala.
http://www.openstreetmap.org - mapy celého světa "wiki style"

eva

  • Návštěvník
  • Příspěvků: 23
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #14 kdy: 27 Ledna 2010, 08:17:46 »
Gparted neukazuje ziadne chyby,
Pri instalacii v recovery mode mi vypisalo "Couldnt find package libd4.6"
clean - no command find ....   
Doplnene: bolo treba "apt-get clean"... Začiatočníčka, čo už...

Išla som znovu od začiatku, až po "apt-get dist-upgrade" všetko bez chýb, ale posledný riadok zase
Kód: [Vybrat]
/sbin/ldconfig.real: /usr/lib/libdb-4.6.so is not an ELF file - it has the wrong magic bytes at the start.
Ale aspoň to už nevypisuje more chýb...   :-)
« Poslední změna: 27 Ledna 2010, 08:50:22 od eva »
Acer Aspire 5310, Ubuntu 9.10

arrange

  • Závislák
  • ***
  • Příspěvků: 4031
  • "jdu s hlavou vztyčenou..."
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #15 kdy: 27 Ledna 2010, 09:05:11 »
Tím clean jsem nemyslel příkaz, ale jednu z těch voleb v recovery mode. Nakonec jsi to ale vyřešila líp, než jsem to vymyslel.

V tom apt-get příkaze máš chybu, proto ti to nejde přeinstalovat, má to být
Kód: [Vybrat]
sudo apt-get install --reinstall libdb4.6ne
Kód: [Vybrat]
sudo apt-get install --reinstall libd4.6(piš bez sudo pokud jsi v recovery mode).
http://www.openstreetmap.org - mapy celého světa "wiki style"

eva

  • Návštěvník
  • Příspěvků: 23
Re: Aktualizacie vypisujú chyby, ako to opravím ?
« Odpověď #16 kdy: 27 Ledna 2010, 09:15:45 »
Supeeeer, ďakujem, urobilo to bez chyby... Síce som 2 minuty pozerala na ten príkaz, čo tam mám zle...
Tak snáď už to bude dobre.
Ďakujem veeeeeeľmi pekne za nezištnú pomoc.
Acer Aspire 5310, Ubuntu 9.10

 

Provoz zaštiťuje spolek OpenAlt.