Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Novinky: Školení nejen k OS Ubuntu pro širokou veřejnost, více informací zde.

Autor Téma: implicitní italské rozložení klávesnice (VYŘEŠENO)  (Přečteno 2302 krát)

ritchey

  • Návštěvník
  • *
  • Příspěvků: 20
  • Karma: +1/-0
    • Zobrazit profil
Ahoj,

mám takovýhle problém: po instalaci Ubuntu 9.10 Karmic Koala (32-bit verze, stažená z torrentu dle linku na www.ubuntu.cz) se mi jako implicitní rozložení klávesnice nastavila italská verze (i když bylo při instalaci zvolena české rozložení). Musím si teď po startu vždy manuálně přidat české a USA rozložení klávesnice, ale i když italské smažu a nastavím české jako default, tak se vše při dalším startu počítače opakuje. Nevíte někdo, co s tím? Jak jsem pochopil, tak ve starších verzích by to možná šlo ošetřit v Xorg.conf, ale ten už Koala nemá.

Díky za radu.

Ritchey
« Poslední změna: 05 Únor 2010, 21:15:42 od ritchey »

arrange

  • Závislák
  • ****
  • Příspěvků: 4031
  • Karma: +473/-15
  • "jdu s hlavou vztyčenou..."
    • Zobrazit profil
Re: implicitní italské rozložení klávesnice
« Odpověď #1 kdy: 28 Leden 2010, 19:23:23 »
?Dáš tady prosím výstup z Terminálu
Kód: [Vybrat]
grep XKB /etc/default/console-setup
gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

Soubor xorg.conf tedy nemáš nebo ho máš prázdný, je-li to tak?
http://www.openstreetmap.org - mapy celého světa "wiki style"

josef_m

  • Host
Re: implicitní italské rozložení klávesnice
« Odpověď #2 kdy: 28 Leden 2010, 20:10:20 »
Zdravím,
měl jsem stejný problém. Po odhlášení se ze svého účtu si na úvodní obrazovce (tam kde se vybírá účet a zadává heslo) si zadejte českou klávesnici. Mně to pomohlo.

ritchey

  • Návštěvník
  • *
  • Příspěvků: 20
  • Karma: +1/-0
    • Zobrazit profil
Re: implicitní italské rozložení klávesnice
« Odpověď #3 kdy: 05 Únor 2010, 15:17:06 »
Omlouvam se za zpozdeni, byl jsem nejakou chvili mimo dosah compu.

Tady je ten vypis z terminalu:
Kód: [Vybrat]
ritchey@ritchey-laptop:~$ grep XKB /etc/default/console-setup
XKBMODEL="pc105"
XKBLAYOUT="it"
XKBVARIANT=""
XKBOPTIONS=""
ritchey@ritchey-laptop:~$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [cz,us,it]
 options = [grp grp:alts_toggle,grp grp:alt_shift_toggle]
 model = acer_laptop
ritchey@ritchey-laptop:~$

Navod podle josefa_m uz jsem taky vyzkousel, funguje to aspon na to, ze po zapnuti a nalogovani mam jako prvni navolenou ceskou klavesnici, ale stejne mi tam mezi volbama visi italska, takze kdykoli chci pomoci Alt-Shift prehodit klavesnci, tak to musim kliknout jedenkrat vic, abych preskocil az na anglicke rozlozeni.  :-\

ritchey

  • Návštěvník
  • *
  • Příspěvků: 20
  • Karma: +1/-0
    • Zobrazit profil
Re: implicitní italské rozložení klávesnice
« Odpověď #4 kdy: 05 Únor 2010, 15:18:51 »
Jo a xorg.conf nemam vubec.  :(

arrange

  • Závislák
  • ****
  • Příspěvků: 4031
  • Karma: +473/-15
  • "jdu s hlavou vztyčenou..."
    • Zobrazit profil
Re: implicitní italské rozložení klávesnice
« Odpověď #5 kdy: 05 Únor 2010, 15:53:17 »
Zálohuj soubor /etc/default/console-setup. Potom v Terminálu zadej
Kód: [Vybrat]
sudo dpkg-reconfigure console-setupObjeví se obrazovky s nastavením, vyber tam jinou klávesnici, bude se tě to ptát na více věcí, buď vyber výchozí hodnoty, nebo se inspiruj u mne
Kód: [Vybrat]
ACTIVE_CONSOLES="/dev/tty[1-6]"
CHARMAP="UTF-8"
CODESET="Lat15"
FONTFACE="VGA"
FONTSIZE="16"

Pak otevři gconf-editor a najdi klíč /desktop/gnome/peripherals/keyboard/kbd, v něm odstraň řádek it. Pak restart.

Pokud jsi něco špatně nastavil a po restartu narazíš na velké problémy, vrať zálohu /etc/default/console-setup zpět na své místo. Proto je důležitá :)
http://www.openstreetmap.org - mapy celého světa "wiki style"

ritchey

  • Návštěvník
  • *
  • Příspěvků: 20
  • Karma: +1/-0
    • Zobrazit profil
Re: implicitní italské rozložení klávesnice
« Odpověď #6 kdy: 05 Únor 2010, 20:48:20 »
MOckrat diky, jdu to zkusit...  :P

ritchey

  • Návštěvník
  • *
  • Příspěvků: 20
  • Karma: +1/-0
    • Zobrazit profil
Re: implicitní italské rozložení klávesnice
« Odpověď #7 kdy: 05 Únor 2010, 21:14:40 »
Funguje, super. Diky.