Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Spuštění BIND9 po startu!  (Přečteno 1567 krát)

lick

  • Návštěvník
  • Příspěvků: 6
Spuštění BIND9 po startu!
« kdy: 17 Února 2010, 15:05:59 »
Dobrý den, mam menší problém, před někou dobou nahodil jsem si BIND9, všechno šlape a je to ok, ale teď jsem zjístil, že BIND9 se nespouští po startu Ubunta, tak jak by měl, ve Webminu se tváří jakože by měl, i spolu s lighttpd serverem, ftp serverem, kteří se normálně po startu spustí, ale BIND9 ne. Tak kdyby měl někdo nějakou radu uvítal bych jí už vážně nevím co s tím. A jeětš bych chtěl podoktnou, že vše nasvědčuje tomu, že by se spustit měl, ale nedělá to. Musí se vždy spustit manuálně přes konzoli nebo Webmin.
« Poslední změna: 17 Února 2010, 15:25:59 od lick »

lick

  • Návštěvník
  • Příspěvků: 6
Re: Spuštění BIND9 po startu!
« Odpověď #1 kdy: 19 Února 2010, 01:36:29 »
No tak jsem trochu patrál, koukl do logu daemonů... a našel stejný problém zde: https://bugs.launchpad.net/ubuntu/+source/bind9/+bug/510587
Asi to bude poNěkud závážnější než jsem myslel. Error log daemona BINDU9 toho člověka tam vypadá naprosto stejně jako můj. Problém je, že sem se tam řešení nedočet. Asi to bude mou slabou angličtinou. Vaše případné připomínky rád uvítám.

AD.: (Takže je trošku jinný ten můj log)
a zní:

Kód: [Vybrat]
Feb 17 11:54:15 uniTEK named[5183]: starting BIND 9.6.1-P2 -u bind
Feb 17 11:54:15 uniTEK named[5183]: built with '--prefix=/usr' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc/bind' '--localstatedir=/var' '--enable-threads' '--enable-largefile' '--with-libtool' '--enable-shared' '--enable-static' '--with-openssl=/usr' '--with-gssapi=/usr' '--with-gnu-ld' '--with-dlz-postgres=no' '--with-dlz-mysql=no' '--with-dlz-bdb=yes' '--with-dlz-filesystem=yes' '--with-dlz-ldap=yes' '--with-dlz-stub=yes' '--with-geoip=/usr' '--enable-ipv6' 'CFLAGS=-fno-strict-aliasing -DDIG_SIGCHASE -O2' 'LDFLAGS=-Wl,-Bsymbolic-functions' 'CPPFLAGS=' 'CXXFLAGS=-g -O2' 'FFLAGS=-g -O2'
Feb 17 11:54:15 uniTEK named[5183]: adjusted limit on open files from 1024 to 1048576
Feb 17 11:54:15 uniTEK named[5183]: found 1 CPU, using 1 worker thread
Feb 17 11:54:15 uniTEK named[5183]: using up to 4096 sockets
Feb 17 11:54:15 uniTEK named[5183]: loading configuration from '/etc/bind/named.conf'
Feb 17 11:54:15 uniTEK named[5183]: /etc/bind/named.conf:15: unknown key 'rndc-key'
Feb 17 11:54:15 uniTEK named[5183]: loading configuration: failure
Feb 17 11:54:15 uniTEK named[5183]: exiting (due to fatal error)
Feb 17 11:54:25 uniTEK named[5238]: starting BIND 9.6.1-P2 -u bind
Feb 17 11:54:25 uniTEK named[5238]: built with '--prefix=/usr' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc/bind' '--localstatedir=/var' '--enable-threads' '--enable-largefile' '--with-libtool' '--enable-shared' '--enable-static' '--with-openssl=/usr' '--with-gssapi=/usr' '--with-gnu-ld' '--with-dlz-postgres=no' '--with-dlz-mysql=no' '--with-dlz-bdb=yes' '--with-dlz-filesystem=yes' '--with-dlz-ldap=yes' '--with-dlz-stub=yes' '--with-geoip=/usr' '--enable-ipv6' 'CFLAGS=-fno-strict-aliasing -DDIG_SIGCHASE -O2' 'LDFLAGS=-Wl,-Bsymbolic-functions' 'CPPFLAGS=' 'CXXFLAGS=-g -O2' 'FFLAGS=-g -O2'
Feb 17 11:54:25 uniTEK named[5238]: adjusted limit on open files from 1024 to 1048576
Feb 17 11:54:25 uniTEK named[5238]: found 1 CPU, using 1 worker thread
Feb 17 11:54:25 uniTEK named[5238]: using up to 4096 sockets
Feb 17 11:54:25 uniTEK named[5238]: loading configuration from '/etc/bind/named.conf'
Feb 17 11:54:25 uniTEK named[5238]: /etc/bind/named.conf:15: unknown key 'rndc-key'
Feb 17 11:54:25 uniTEK named[5238]: loading configuration: failure
Feb 17 11:54:25 uniTEK named[5238]: exiting (due to fatal error)

Je tam toho víc, někdy se error v logu opakuje stejně někdy s malým změnami.. někdy se snaží načíst víc atd... važně nevím co s tím

Kód: [Vybrat]
Feb 19 01:52:12 uniTEK named[1707]: starting BIND 9.6.1-P2 -u bind
Feb 19 01:52:12 uniTEK named[1707]: built with '--prefix=/usr' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc/bind' '--localstatedir=/var' '--enable-threads' '--enable-largefile' '--with-libtool' '--enable-shared' '--enable-static' '--with-openssl=/usr' '--with-gssapi=/usr' '--with-gnu-ld' '--with-dlz-postgres=no' '--with-dlz-mysql=no' '--with-dlz-bdb=yes' '--with-dlz-filesystem=yes' '--with-dlz-ldap=yes' '--with-dlz-stub=yes' '--with-geoip=/usr' '--enable-ipv6' 'CFLAGS=-fno-strict-aliasing -DDIG_SIGCHASE -O2' 'LDFLAGS=-Wl,-Bsymbolic-functions' 'CPPFLAGS=' 'CXXFLAGS=-g -O2' 'FFLAGS=-g -O2'
Feb 19 01:52:12 uniTEK named[1707]: adjusted limit on open files from 1024 to 1048576
Feb 19 01:52:12 uniTEK named[1707]: found 1 CPU, using 1 worker thread
Feb 19 01:52:12 uniTEK named[1707]: using up to 4096 sockets
Feb 19 01:52:12 uniTEK named[1707]: loading configuration from '/etc/bind/named.conf'
Feb 19 01:52:12 uniTEK named[1707]: using default UDP/IPv4 port range: [1024, 65535]
Feb 19 01:52:12 uniTEK named[1707]: using default UDP/IPv6 port range: [1024, 65535]
Feb 19 01:52:12 uniTEK named[1707]: listening on IPv6 interfaces, port 53
Feb 19 01:52:12 uniTEK named[1707]: listening on IPv4 interface lo, 127.0.0.1#53
Feb 19 01:52:12 uniTEK named[1707]: /etc/bind/named.conf.options:18: using specific query-source port suppresses port randomization and can be insecure.
Feb 19 01:52:12 uniTEK named[1707]: could not get query source dispatcher (10.0.0.1#53)
Feb 19 01:52:12 uniTEK named[1707]: loading configuration: address not available
Feb 19 01:52:12 uniTEK named[1707]: exiting (due to fatal error)

Tohle je aktuální poslední vypsaný errorr v logu u BIND9.
« Poslední změna: 19 Února 2010, 01:57:43 od lick »

lick

  • Návštěvník
  • Příspěvků: 6
Re: Spuštění BIND9 po startu!
« Odpověď #2 kdy: 19 Února 2010, 02:14:32 »
Omlouvám se za to že sem zatím tedy píšu jen já...

Takže přišel jsem na závadu, jenže co s ní ?.... v configu BINDU v části options {} řádek: query-source address 10.0.0.1 port 53; kde ip 10.0.0.1 je adresa serveru BINDU v místní síti... bylo tohle nastavení vůbec správné ? Po odstranění celého řádku server po bootu už naběhl...


AD: Jo aha, tady de vidět že mi některé fce BINDU byli velice utajeny, moje blbost na kterou se tedy už přišel a asi se může lock.... Zatim nazdar....
« Poslední změna: 19 Února 2010, 02:36:28 od lick »

 

Provoz zaštiťuje spolek OpenAlt.