Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: [VYŘEŠENO] GRUB2 - Změna rozlišení konzole při bootu  (Přečteno 5665 krát)

jidash

  • Návštěvník
  • Příspěvků: 48
[VYŘEŠENO] GRUB2 - Změna rozlišení konzole při bootu
« kdy: 17 Prosince 2009, 14:19:42 »
Ahoj,
předem se omlouvám jestli se tohle už řešilo, ale grub2 mi prostě nedá spát. Pokud jsem stejné vlákno tady na fóru pouze přehlédl prosím hoďte link a já to uzavřu.

Nedávno jsem nainstaloval Ubuntu 9.10 KK a s ním přišel i grub2. Osobně je mi jedno co používám, protože jsem před pár lety začína s lilem a proto jsem přistoupil ke klasickému postupu vypnout quiet splash a těšit se z výpisu do konzole při startu systému.
Odstranění quiet splash nebyl žádný problém a po sudo update-grub jsem dostal to co jsem chtěl. Co mi ovšem nejde je změna rozlišení konzole při bootu.

Starý dobrý vga=791 už nefunguje a GRUB_GFXMODE="1024x768" (v /etc/default/grub) zatím asi taky ne. Zkoušel jsem i laborovat s set gfxpayload=1024x768 v /etc/grub.d/00_header, ale nemůžu se dobrat ani malé změny.

Pokud Vám to někomu funguje, budu vděčný za každou radu.

Díky.

Ubuntu 9.10 Karmic Koala
Grub 1.97~beta4
« Poslední změna: 29 Dubna 2011, 20:36:04 od jidash »

Roman Vacho

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 6046
Re: GRUB2 - Změna rozlišení konzole při bootu
« Odpověď #1 kdy: 17 Prosince 2009, 15:13:49 »
Spouštěl si po změne sudo update-grub?
QUIET nesouvisí se splashem. Ten nemaž.
Vyřešená vlákna je vhodné uzavřít "Topic Solved" dole pod vláknem.
Dlouhé výpisy prosím dávat při psaní příspěvku do bloku funkcí Vložit kód.
Děkujeme.

jidash

  • Návštěvník
  • Příspěvků: 48
Re: GRUB2 - Změna rozlišení konzole při bootu
« Odpověď #2 kdy: 17 Prosince 2009, 15:25:52 »
update-grub jsem pouštěl.
quiet má přímý vliv na množství vypisovaných hlášek při bootu. Proto když chci vidět všechno musím ho odstranit. Nicméně ani když tak je tak to nemá žádný vliv na rozlišení.

Roman Vacho

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 6046
Re: GRUB2 - Změna rozlišení konzole při bootu
« Odpověď #3 kdy: 17 Prosince 2009, 20:32:56 »
update-grub jsem pouštěl.
quiet má přímý vliv na množství vypisovaných hlášek při bootu. Proto když chci vidět všechno musím ho odstranit. Nicméně ani když tak je tak to nemá žádný vliv na rozlišení.

Hm... podle mě má vliv i na něco jiného. Protože někdy se stane, že OS nechce nabootovat a odstranění quiet pomůže. Leda žeb y to zůstalo viset na ňákým procesu, co se uživatele dotazuje a s quiet není vidět.
Vyřešená vlákna je vhodné uzavřít "Topic Solved" dole pod vláknem.
Dlouhé výpisy prosím dávat při psaní příspěvku do bloku funkcí Vložit kód.
Děkujeme.

jidash

  • Návštěvník
  • Příspěvků: 48
Re: GRUB2 - Změna rozlišení konzole při bootu
« Odpověď #4 kdy: 18 Prosince 2009, 09:23:10 »
Hm... podle mě má vliv i na něco jiného. Protože někdy se stane, že OS nechce nabootovat a odstranění quiet pomůže. Leda žeb y to zůstalo viset na ňákým procesu, co se uživatele dotazuje a s quiet není vidět.

To už jsme ale někde jinde. Zpět k problému.

pepéé

  • Aktivní člen
  • *
  • Příspěvků: 466
Re: GRUB2 - Změna rozlišení konzole při bootu
« Odpověď #5 kdy: 18 Prosince 2009, 09:48:45 »
ted trochu střílím ale co skusit sturtup-manager?
Fire's in my soul, steel is on my side

Marek_

  • Aktivní člen
  • *
  • Příspěvků: 342
Re: GRUB2 - Změna rozlišení konzole při bootu
« Odpověď #6 kdy: 18 Prosince 2009, 10:07:39 »
A co máš za monitor? Já třeba u jednoho počítače připojeného k velké plazmové televizi taky nemohu dosáhnout, aby byl start vidět, dokonce ani ten textový režim. Televize píše "Nepodporovaný režim" a je modrá :). Asi je to rozlišení příliš malé. Režimy se  dají vypsat pomocí vbeinfo (nebo tak nějak, už nevím), ale žádný mi nejde od té doby, kdy změnili systém startu (v této sestavě).
openSUSE 13.1
Opera 12 - ano, stale

jidash

  • Návštěvník
  • Příspěvků: 48
Re: GRUB2 - Změna rozlišení konzole při bootu
« Odpověď #7 kdy: 18 Prosince 2009, 10:34:51 »
ted trochu střílím ale co skusit sturtup-manager?

Ten nefunguje. Zkoušel jsem ho jako jednu z prvních možností, ale díky za nápad

A co máš za monitor? Já třeba u jednoho počítače připojeného k velké plazmové televizi taky nemohu dosáhnout, aby byl start vidět, dokonce ani ten textový režim. Televize píše "Nepodporovaný režim" a je modrá :). Asi je to rozlišení příliš malé. Režimy se  dají vypsat pomocí vbeinfo (nebo tak nějak, už nevím), ale žádný mi nejde od té doby, kdy změnili systém startu (v této sestavě).

Mám CRT monitor LG F700P, ale v tom problém nebude. Já ty hlášky normálně vidím, akorát je rozlišení konzole pořád 640x480.
vbeinfo jsem taky zkoumal, ale můžu se snažit sebevíc a rozlišení prostě nezměním.

compaq

  • Závislák
  • ***
  • Příspěvků: 2472
  • Díky všem za rady a tipy.
Re: GRUB2 - Změna rozlišení konzole při bootu
« Odpověď #8 kdy: 01 Července 2010, 21:49:09 »
Mě se také na NB nedaří změnit rozlišení textové nabídky GRUBu2. Dle vánodu zde jsem soubor grub změnil na:

Citace
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
#tohle jsem pridal ja 1.7.2010
GRUB_GFXMODE=1280x800

updatnul a nic, nabídka je stále roztažená do šířky a rozmazaná...
Pokud vám vaše holka či manželka funguje jak má, neměňte jí za mladší, zaděláte si na problém. Stejně to dělejte i s Ubuntu.

piwko

  • Návštěvník
  • Příspěvků: 1
Re: GRUB2 - Změna rozlišení konzole při bootu
« Odpověď #9 kdy: 29 Dubna 2011, 08:59:14 »
dlouho jse resil podobny problem, pomohlo mi:

zmenit/pridat do /etc/grub.d/00_header
Kód: [Vybrat]
set gfxmode=1280x800 #pozadovane rozliseni
set gfxpayload=keep
insmod gfxterm
insmod vbe

nezapomenout na:
Kód: [Vybrat]
sudo update-grubprikladam originalni clanek, ze ktereho jsem cerpal

Kód: [Vybrat]
http://harrison3001.blogspot.com/2009/09/grub-2-graphical-boot-tips-to-set.html

jidash

  • Návštěvník
  • Příspěvků: 48
Re: GRUB2 - Změna rozlišení konzole při bootu
« Odpověď #10 kdy: 29 Dubna 2011, 20:34:55 »
Trochu si sypu popel na hlavu, že jsem tohle téma neuzavřel už dávno. Je to tak, že když jsem tenhle dotaz psal měl jsem ještě crunchbang-linux a v tamější verzi grubu2 to prostě nešlo nastavit ať jsem se stavěl na hlavu sebevíc. Pak jsem přešel na Lubuntu a ejhle s tím samým nastavením to najednou šlo.

Každopádně díky PIWKO i všem ostatním.

Můj současný konfigurák /etc/default/grub (funguje dobře):

Kód: [Vybrat]
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=8
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX="nopat"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1280x1024x32
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


 

Provoz zaštiťuje spolek OpenAlt.