Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Kdenlive - nemohu vyrenderovat videa (vyřešeno)  (Přečteno 2647 krát)

funk

  • Člen
  • **
  • Příspěvků: 350
    • Zobrazit profil
Kdenlive - nemohu vyrenderovat videa (vyřešeno)
« kdy: 28 Listopad 2012, 10:07:44 »
Ahoj,

jako správný uživatel bych měl říct, že z ničeho nic mi začalo blbnout Kdenlive. :0) Provozuji verzi 9.2 od Sunaba z PPA v Xubuntu 12.04. Ještě před měsícem jsem renderoval bez problému. Nyní ale nejsem schopen v žádném kontejneru nebo kodeku video vyexportovat. Zdrojové soubory jsou .mts a při renderování jsem používal šablonu H.264+AAC (.mp4) se zástupnými (proxy) klipy. Bohužel od jisté doby se zobrazuje chybová hláška uvedená níže, která se zobrazí jakmile je video delší než cca. 20 s. Někde jsem se dočetl, že se může jednat o chybu ffmpegu, resp. MLT. Nedokázal by mne někdo postrčit dál. Už jsem kvůli tomu reinstaloval systém a nepomhlo to. Samozřejmostí bylo odebrání konf. souborů u Kdenlive a MLT. Jak resetovat ffmpeg nevím, tedy kromě toho, že ho v Synapticu odeberu i s kofn. souborem.

Dekuji

[wav @ 0x8469480] max_analyze_duration reached
[wav @ 0x8469c40] max_analyze_duration reached
[libx264 @ 0xb480cf60] [Eval @ 0xb51ef99c] Invalid chars '.6' at the end of expression '0.6' [libx264 @ 0xb480cf60] Unable to parse option value "0.6"
[wav @ 0xb3810580] max_analyze_duration reached
[wav @ 0xb38df2e0] max_analyze_duration reached
[h264 @ 0x961d89a0] reference picture missing during reorder [h264 @ 0x961d89a0] Missing reference picture [h264 @ 0x961d89a0] decode_slice_header error
[h264 @ 0xb36c5c80] reference picture missing during reorder [h264 @ 0xb36c5c80] Missing reference picture [h264 @ 0xb36c5c80] decode_slice_header error
[h264 @ 0xa56aa540] reference picture missing during reorder [h264 @ 0xa56aa540] Missing reference picture [h264 @ 0xa56aa540] decode_slice_header error
[h264 @ 0x961d89a0] reference picture missing during reorder [h264 @ 0x961d89a0] Missing reference picture [h264 @ 0x961d89a0] decode_slice_header error
[h264 @ 0xb36c5c80] Missing reference picture [h264 @ 0xb36c5c80] decode_slice_header error
[h264 @ 0x961d89a0] reference picture missing during reorder
[h264 @ 0x961d89a0] Missing reference picture
[h264 @ 0xa56aa540] reference picture missing during reorder
[h264 @ 0xa56aa540] Missing reference picture
[h264 @ 0x961d89a0] reference picture missing during reorder [h264 @ 0x961d89a0] Missing reference picture [h264
« Poslední změna: 28 Listopad 2012, 17:45:32 od funk »

Rover623

Re:Kdenlive - nemohu vyrenderovat videa
« Odpověď #1 kdy: 28 Listopad 2012, 13:08:53 »
FFmpeg má ve 12.04 pořád chybu která způsobuje už od verze 10.04 spoustu problémů, resetovat nemá cenu, asi by bylo lepší nasadit novější verzi která je ve 12.10. Buď můžeš povýšit systém nebo si do 12.04 překompilovat novější ručně

funk

  • Člen
  • **
  • Příspěvků: 350
    • Zobrazit profil
Re:Kdenlive - nemohu vyrenderovat videa (Vyřešeno)
« Odpověď #2 kdy: 28 Listopad 2012, 17:37:09 »
Ahoj,

no fakt ze jo. Na kompilaci FFMPEGu jsem si netroufl, ale nainstaloval jsem ho z repozitare: ppa:jon-severinsson/ffmpeg

https://launchpad.net/~jon-severinsson/+archive/ffmpeg?field.series_filter=

K+
« Poslední změna: 28 Listopad 2012, 17:41:48 od funk »

libor007

  • Stálý člen
  • ***
  • Příspěvků: 866
    • Zobrazit profil
Re:Kdenlive - nemohu vyrenderovat videa (vyřešeno)
« Odpověď #3 kdy: 10 Prosinec 2012, 18:16:26 »
ahoj,jake problemy miva ffmpeg u precise? je nekde neco blizsiho k cteni? pokud je znamo vice problemu, cekal bych spise opravu v aktualizacich...
Kubuntu 19.10

funk

  • Člen
  • **
  • Příspěvků: 350
    • Zobrazit profil
Re:Kdenlive - nemohu vyrenderovat videa (vyřešeno)
« Odpověď #4 kdy: 10 Prosinec 2012, 18:52:20 »
Priznam se, ze dalsi bugy jsem nesledoval, takze nevim. Pro mne bylo klicove, ze po jeho aktualizaci prestalo byt funkcni Kdenlive. Ted jede dobre.

libor007

  • Stálý člen
  • ***
  • Příspěvků: 866
    • Zobrazit profil
Re:Kdenlive - nemohu vyrenderovat videa (vyřešeno)
« Odpověď #5 kdy: 11 Prosinec 2012, 14:54:57 »
testnu, kdenlive sem nemel 2 mesice spusteny a mam v nem spoustu veci na prevod. uvidim, jak je to u mne.
Kubuntu 19.10

libor007

  • Stálý člen
  • ***
  • Příspěvků: 866
    • Zobrazit profil
Re:Kdenlive - nemohu vyrenderovat videa (vyřešeno)
« Odpověď #6 kdy: 12 Prosinec 2012, 20:25:18 »
Tak u mne zdá se ok. Mam ale kubuntu, ne xubuntu.  Prevadel jsem dv video z kamery. Jen mi to pripada strasne pomale, vzdy je 100% vytizene jen 1 jadro ze 4. Nejde nekde nastavit lepsi vyuziti cpu? Pocitat 3 minutove video 9 minut je humus...
Kubuntu 19.10

funk

  • Člen
  • **
  • Příspěvků: 350
    • Zobrazit profil
Re:Kdenlive - nemohu vyrenderovat videa (vyřešeno)
« Odpověď #7 kdy: 12 Prosinec 2012, 20:30:16 »
Neco o tom je tady, ale na mem dvoujadru mi prijde, ze funguju naplno. http://www.kdenlive.org/forum/only-1-cpu-being-used-render

libor007

  • Stálý člen
  • ***
  • Příspěvků: 866
    • Zobrazit profil
Re:Kdenlive - nemohu vyrenderovat videa (vyřešeno)
« Odpověď #8 kdy: 12 Prosinec 2012, 23:21:43 »
Tak nic, jako spravny slepys jsem prehlidl moznost vice threadu primo v okne s nastavenim renderovani. Po prepnuti na 4 jiz renderuje za 1/3 casu...
Kubuntu 19.10

David29

  • Návštěvník
  • *
  • Příspěvků: 41
    • Zobrazit profil
Re:Kdenlive - nemohu vyrenderovat videa (vyřešeno)
« Odpověď #9 kdy: 14 Červen 2020, 09:30:35 »
At nezakládám nové téma.
Mám Kdenlive  20.04.0 na Kubuntu 20.04 - chtěl jsem na tomto novém OS s novým Kdenlivem poprvé renderovat...
A nespustí se. Zobrazí se úvodní hláška "Čeká se...", a to je vše. Počítač se nijak neseká, není nijak zpomalen a zjistil jsem, že v místě kam se má video renderovat, nevznikne žádný výstupní soubor

Zkoušel jsem napřed .mp4, posléze i .avi i .webm - a výsledek stejnej

juwa2

  • Závislák
  • ****
  • Příspěvků: 3717
    • Zobrazit profil
Re:Kdenlive - nemohu vyrenderovat videa (vyřešeno)
« Odpověď #10 kdy: 14 Červen 2020, 10:38:49 »
Pokud máš kdenlive snap, zkus verzi z PPA, nebo naopak....

David29

  • Návštěvník
  • *
  • Příspěvků: 41
    • Zobrazit profil
Re:Kdenlive - nemohu vyrenderovat videa (vyřešeno)
« Odpověď #11 kdy: 14 Červen 2020, 10:51:53 »
Ehm, co? :-D

Zkusil jsem ted verzi 19.12.3 a ta jde normálně...