Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: [Vyřešeno] ImageMagick chybějící libmagickcore4  (Přečteno 1761 krát)

Kedrigern

[Vyřešeno] ImageMagick chybějící libmagickcore4
« kdy: 14 Prosince 2012, 14:42:49 »
Někdy, asi během povýšení z 12.04 na 12.10 mi přestal chodit imagemagick, tak jsem ho odinstaloval:
Kód: [Vybrat]
sudo aptitude purge imagemagick imagemagick-common libmagickcore5 libmagickcore5-extra libmagickwand5 A opět nainstaloval:
Kód: [Vybrat]
sudo aptitude install imagemagickcož nainstalovalo balíky:
Kód: [Vybrat]
imagemagick imagemagick-common{a} libmagickcore5{a} libmagickcore5-extra{a} libmagickwand5{a}Nicméně stejně se mi stane toto:
Kód: [Vybrat]
$ convert -v
convert: error while loading shared libraries: libMagickCore.so.4: cannot open shared object file: No such file or directory

Věděl by někdo, co s tím? Chápu, že to nemá sdílenou knihovnu, ale proč to chce knihovnu, která není v repo (tam je verze 5). Když jsem hledal, tak jsem skoro nic nenašel, čili to je nějaká chyba u mě. Ale kde se vzala? Jak se jí zbavit?
« Poslední změna: 14 Prosince 2012, 16:24:37 od Kedrigern »

beer

  • Host
Re:ImageMagick
« Odpověď #1 kdy: 14 Prosince 2012, 15:22:18 »
Jeden dotaz do google a je zde odpověď :), hned na první pozici:

Kód: [Vybrat]
ldconfig /usr/local/lib
Snad to pomůže ;)

//edit
ověř si ještě, zdali ten soubor skutečně existuje v tomto umístění:
/usr/local/lib/libMagickCore.so.4

Pokud tam není, tak určitě půjde vypreparovat z balíku, nebo stáhnout ručně.
« Poslední změna: 14 Prosince 2012, 15:26:45 od beer »

Kedrigern

Re:ImageMagick
« Odpověď #2 kdy: 14 Prosince 2012, 16:09:22 »
ldconfig jsem zkoušel. Ano, danou knihovnu nemám.

Mám to chápat tak, že imagemagick z repozitářů vyžaduje knihovnu, která v repozitářích není? (a jsem víceméně jediný, kdo se s tím setkal)

Kedrigern

Re:ImageMagick
« Odpověď #3 kdy: 14 Prosince 2012, 16:17:52 »
Tak odtud šla verze 4 stáhnout: http://packages.ubuntu.com/precise/amd64/libmagickcore4/download a vše funguje.

Ale spokojen nejsem :). Proč můj imagemagick nepoužívá verzi 5? To nebude správně.
« Poslední změna: 14 Prosince 2012, 16:25:17 od Kedrigern »

beer

  • Host
Re:[Vyřešeno] ImageMagick chybějící libmagickcore4
« Odpověď #4 kdy: 14 Prosince 2012, 17:03:45 »
Mám to chápat tak, že imagemagick z repozitářů vyžaduje knihovnu, která v repozitářích není? (a jsem víceméně jediný, kdo se s tím setkal)

No, dle toho odkazu je problém spíše v tom balíčku imagemagick jako takovém, protože jestli jsem to pochopil správně (nečetl jsem, jen prolétl očima, tak zde http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=17059 to instalovali ze zdrojových kódů a měli podobný problém. Takže se to týká i zdrojových kódů. Akorát tam ta knihovna zřejmě byla, když ldconfig pomohlo.

Pokud existuje knihovna libMagickCore.so.5 a tu máš (jestli jsem tě pochopil správně), tak je zde možnost udělat simlink na libMagickCore.so.4 a zkusit to, jestli to poběží... Pokud jí nemáš taky, tak bych to neřešil. Ubuntu nemá programy v posledních verzích, ani jejich knihovny. Jestli se nepletu, tak stále třeba N2N v ubuntu neumí verzi 2, přesto, že je už dost stará. Tak prostě používám verzi 1.
« Poslední změna: 14 Prosince 2012, 17:05:16 od beer »

Kedrigern

Re:[Vyřešeno] ImageMagick chybějící libmagickcore4
« Odpověď #5 kdy: 14 Prosince 2012, 19:48:34 »
Jde o to, že mám v repozitářích ImageMagick, který chce libmagickcore4 a v repos mám libmagickcore5...

 

Provoz zaštiťuje spolek OpenAlt.