Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Desura client a Desurium - problém s instalací a spuštěním  (Přečteno 953 krát)

Hakito

  • Člen
  • **
  • Příspěvků: 272
    • Zobrazit profil
    • Japonština.yukata.cz
Zdravíčko.
Mám problémy s přihlášením do klienta Desury. Po stažení všech komponent spustím spouštěcí soubor a vyskočí hláška, že chybí desura.png ve složce data. Ten tam ovšem je.. Po odkliknutí se zobrazí okénko se zadáním přihlašovacích údajů. Když je vyplním, okno zmizí a nic se neděje.

Tuhle chybu jsem zatím nikde nenašel, ale našel jsem alternativní instalaci Desury přes Desurium https://github.com/desura/Desurium

Tady mám ovšem problémy s instalací. Po několika chybějících a ručně doinstalovaných balících jsem dostal hlášku se kterou si neumím poradit.

Kód: [Vybrat]
hakito@MS-7309:~/Stažené/Desurium-master (2)$ ./build_desura.sh pack_deb
Make sure to run sudo ./install_deps.sh before compiling!

Building DEB package...
-- The C compiler identification is GNU 4.7.3
-- The CXX compiler identification is GNU 4.7.3
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- using GCC
-- Detected 64bit
-- Not working multilib, disable 32bit support
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.26")
-- Could NOT find Boost
-- Found Freetype: /usr/lib/x86_64-linux-gnu/libfreetype.so (found version "2.4.11")
-- Found GTK2_GTK: /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so 
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- checking for module 'gthread-2.0'
--   found gthread-2.0, version 2.36.0
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE 
-- checking for one of the modules 'glib-2.0'
-- Found GLib2: glib-2.0 /usr/include/glib-2.0;/usr/lib/x86_64-linux-gnu/glib-2.0/include
-- Looking for include file glib/gregex.h
-- Looking for include file glib/gregex.h - not found
-- Performing Test LIBNOTIFY_VERSION_04
-- Performing Test LIBNOTIFY_VERSION_04 - Failed
-- Performing Test LIBNOTIFY_VERSION_07
-- Performing Test LIBNOTIFY_VERSION_07 - Success
-- Found libnotify: '/usr/lib/x86_64-linux-gnu/libnotify.so' and header in '/usr/include/libnotify' version => 0.7
-- Could NOT find BZip2 (missing:  BZIP2_LIBRARIES BZIP2_INCLUDE_DIR)
-- Optional package Sqlite3 was not found
-- Could NOT find TINYXML (missing:  TINYXML_LIB TINYXML_H_PATH)
tinyxml >= 2.6 is required. Using builtin
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:97 (message):
  Could NOT find v8 (missing: V8_INCLUDE_DIR V8_LIBRARIES)
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:291 (_FPHSA_FAILURE_MESSAGE)
  cmake/modules/Findv8.cmake:22 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:171 (find_package)


-- Configuring incomplete, errors occurred!

Kdybyste mohl kdokoli pomoct, budu moc vděčen.

Edit: Doinstaloval jsem balíky lib32bz2-dev a bzip2, ale pořád vypisuje hlášku

Kód: [Vybrat]
./build_desura.sh pack_deb
Make sure to run sudo ./install_deps.sh before compiling!

Building DEB package...
-- using GCC
-- Detected 64bit
-- Working multilib, enable 32bit support
-- Could NOT find Boost
-- Found libnotify: '/usr/lib/x86_64-linux-gnu/libnotify.so' and header in '/usr/include/libnotify' version => 0.7
-- Found BZip2: /usr/lib/x86_64-linux-gnu/libbz2.so (found version "1.0.6")
-- Looking for BZ2_bzCompressInit in /usr/lib/x86_64-linux-gnu/libbz2.so
-- Looking for BZ2_bzCompressInit in /usr/lib/x86_64-linux-gnu/libbz2.so - found
-- Optional package Sqlite3 was not found
-- Found TINYXML: /usr/lib/libtinyxml.so 
-- Performing Test TINYXML_API_TEST
-- Performing Test TINYXML_API_TEST - Success
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:97 (message):
  Could NOT find v8 (missing: V8_INCLUDE_DIR V8_LIBRARIES)
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:291 (_FPHSA_FAILURE_MESSAGE)
  cmake/modules/Findv8.cmake:22 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:171 (find_package)


-- Configuring incomplete, errors occurred!
« Poslední změna: 25 Červen 2013, 11:30:09 od Hakito »
Generování náhodných čísel je příliš důležité, než aby se nechalo na náhodě.
PC - ATI Radeon HD 2600 PRO, AMD 64 - 2GHz, 2Gb RAM, 80Gb HDD, 40Gb HDD + Xubuntu 12.10

beer

  • Host
Re:Desura client a Desurium - problém s instalací a spuštěním
« Odpověď #1 kdy: 25 Červen 2013, 12:34:59 »
Vždyť to tam máš napsané, máš nejprve nainstalovat závislosti
Kód: [Vybrat]
cd ~/Stažené/Desurium-master
sudo ./install_deps.sh
./build_desura.sh

Chybí ti asi Boost, Sqlite3, TINYXML, v8.
« Poslední změna: 25 Červen 2013, 12:57:37 od beer »

Hakito

  • Člen
  • **
  • Příspěvků: 272
    • Zobrazit profil
    • Japonština.yukata.cz
Re:Desura client a Desurium - problém s instalací a spuštěním
« Odpověď #2 kdy: 25 Červen 2013, 13:20:06 »
Dobře, s pomocí launchpadu, kde jsou názvy všech potřebných knihoven jsem chybějící balíky doinstaloval.

A objevil jsem jiný problém, který nevím, co znamená..

Kód: [Vybrat]
$ sudo ./build_desura.sh
Make sure to run sudo ./install_deps.sh before compiling!

Compiling cef...
-- using GCC
-- Detected 64bit
-- Working multilib, enable 32bit support
-- the value of env CFLAGS:
-- the value of env CXXFLAGS:
-- the value of env LDFLAGS:
-- Configuring done
-- Generating done
-- Build files have been written to: /home/hakito/Stažené/Desurium-master (2)/build_cef
[ 22%] Built target fetch_cef
[ 42%] Built target depot_tools
[ 65%] Built target chromium
[ 67%] Performing build_cef step for 'cef'
ln: target ‘(2)/build_cef/external/depot_tools/src/depot_tools/python’ is not a directory
/home/hakito/Stažené/Desurium-master (2)/cmake/scripts/depot_tools_wrapper.sh: 9: [: /home/hakito/Stažené/Desurium-master: unexpected operator
  export LD_LIBRARY_PATH=/home/hakito/Stažené/Desurium-master (2)/build_cef/chromium-prefix/src/chromium/src/out/Release/lib.host:/home/hakito/Stažené/Desurium-master (2)/build_cef/chromium-prefix/src/chromium/src/out/Release/lib.target:$LD_LIBRARY_PATH; cd build/util; mkdir -p /home/hakito/Stažené/Desurium-master (2)/build_cef/chromium-prefix/src/chromium/src/out/Release/obj/gen/build; python ./lastchange.py -o "/home/hakito/Stažené/Desurium-master (2)/build_cef/chromium-prefix/src/chromium/src/out/Release/obj/gen/build/LASTCHANGE" -d ../LASTCHANGE.in
/bin/sh: 1: Syntax error: "(" unexpected
make[3]: *** [out/Release/obj/gen/build/LASTCHANGE.always] Error 2
make[2]: *** [cef-prefix/src/cef-stamp/cef-build_cef] Error 2
make[1]: *** [CMakeFiles/cef.dir/all] Error 2
make: *** [all] Error 2

Compiling desurium...
-- using GCC
-- Detected 64bit
-- Working multilib, enable 32bit support
-- Boost version: 1.49.0
-- Found the following Boost libraries:
--   date_time
--   filesystem
--   thread
--   system
--   unit_test_framework
-- Found libnotify: '/usr/lib/x86_64-linux-gnu/libnotify.so' and header in '/usr/include/libnotify' version => 0.7
-- Configuring done
-- Generating done
-- Build files have been written to: /home/hakito/Stažené/Desurium-master (2)/build
[  0%] Performing configure step for 'breakpad'
configure: WARNING: unrecognized options: --enable-shared, --enable-static
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... configure: error: unsafe srcdir value: `/home/hakito/Stažené/Desurium-master (2)/build/breakpad-prefix/src/breakpad'
make[2]: *** [breakpad-prefix/src/breakpad-stamp/breakpad-configure] Error 1
make[1]: *** [CMakeFiles/breakpad.dir/all] Error 2
make: *** [all] Error 2
Generování náhodných čísel je příliš důležité, než aby se nechalo na náhodě.
PC - ATI Radeon HD 2600 PRO, AMD 64 - 2GHz, 2Gb RAM, 80Gb HDD, 40Gb HDD + Xubuntu 12.10