Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Aktualizace - Chyba: Nesprávný součet > 0  (Přečteno 1123 krát)

Krux

  • Návštěvník
  • *
  • Příspěvků: 15
    • Zobrazit profil
Aktualizace - Chyba: Nesprávný součet > 0
« kdy: 20 Února 2014, 20:34:16 »
Zdravím. Mám problém se závislostma balíků po instalaci. Ano, zkoušel jsem to nejdřív opravit pomocí příkazu apt-get, ale marně. Prosím o radu, jak to opravit.

sudo apt-get check

Kód: [Vybrat]
Čtu seznamy balíků… Hotovo
Vytváří se strom závislostí       
Čtu stavové informace… Hotovo
Pro opravení můžete spustit „apt-get -f install“.
Následující balíky mají nesplněné závislosti:
 gcc-4.8 : Závisí na: cpp-4.8 (= 4.8.1-10ubuntu8) ale 4.8.1-10ubuntu9 je nainstalován
           Závisí na: gcc-4.8-base (= 4.8.1-10ubuntu8) ale 4.8.1-10ubuntu9 je nainstalován
           Závisí na: libgcc-4.8-dev (= 4.8.1-10ubuntu8) ale 4.8.1-10ubuntu9 je nainstalován
E: Nesplněné závislosti. Zkuste použít -f


sudo apt-get -f install

Kód: [Vybrat]
Čtu seznamy balíků… Hotovo
Vytváří se strom závislostí       
Čtu stavové informace… Hotovo
Opravuji závislosti… Hotovo
Následující extra balíky budou instalovány:
  gcc-4.8
Navrhované balíky:
  gcc-4.8-multilib libmudflap0-4.8-dev gcc-4.8-doc gcc-4.8-locales libgcc1-dbg libgomp1-dbg libitm1-dbg libatomic1-dbg libasan0-dbg
  libtsan0-dbg libbacktrace1-dbg libquadmath0-dbg libmudflap0-dbg
Následující balíky budou aktualizovány:
  gcc-4.8
1 aktualizováno, 0 nově instalováno, 0 k odstranění a 90 neaktualizováno.
161 instalováno nebo odstraněno pouze částečně.
Potřebuji stáhnout 0 B/6 639 kB archivů.
Po této operaci bude na disku použito dalších 0 B.
Chcete pokračovat [Y/n]? y
(Čtu databázi … nyní je nainstalováno 166145 souborů a adresářů.)
Připravuji nahrazení gcc-4.8 4.8.1-10ubuntu8 (pomocí …/gcc-4.8_4.8.1-10ubuntu9_amd64.deb) …
Rozbaluji náhradu gcc-4.8 …
dpkg-deb (podproces): rozbaluje se část archivu: vnitřní chyba gzipu při čtení: „<fd:4>: incorrect data check“
dpkg-deb: chyba: podproces <dekomprese> vrátil chybový status 2
dpkg: chyba při zpracovávání /var/cache/apt/archives/gcc-4.8_4.8.1-10ubuntu9_amd64.deb (--unpack):
 podproces dpkg-deb --fsys-tarfile vrátil chybový status 2
Při zpracování nastaly chyby:
 /var/cache/apt/archives/gcc-4.8_4.8.1-10ubuntu9_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

marun

  • Stálý člen
  • ***
  • Příspěvků: 601
    • Zobrazit profil
Re:Aktualizace - Chyba: Nesprávný součet > 0
« Odpověď #1 kdy: 20 Února 2014, 21:01:47 »
Kód: [Vybrat]
sudo apt-get clean
sudo apt-get -f install

Krux

  • Návštěvník
  • *
  • Příspěvků: 15
    • Zobrazit profil
Re:Aktualizace - Chyba: Nesprávný součet > 0
« Odpověď #2 kdy: 20 Února 2014, 21:16:51 »
aha, díky moc.pomohlo to

 


Provoz zaštiťuje spolek OpenAlt.