Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Include v Apache  (Přečteno 3114 krát)

p.dohny

  • Aktivní člen
  • *
  • Příspěvků: 327
Include v Apache
« kdy: 26 Května 2014, 22:18:43 »
Ahoj nainstaloval jsem Apache v 14.4 a nedaří se mi zprovoznit iclude

V /etc/apache2/apache2.conf mám toto
Kód: [Vybrat]
<Directory /home/pavel/Plocha/testovaci>
Options Indexes FollowSymLinks
AllowOverride None
Require all granted
</Directory>

Našel jsem nápovědu zde:
http://wiki.ubuntu.cz/servery/apache_s_mysql_a_php

Ale nepomohlo - řešil jste to už někdo?
Ubuntu 20.10.
Nachystej mi uzenáče, na snídani jsem zpátky :)

jmp

  • Host
Re:Include v Apache
« Odpověď #1 kdy: 27 Května 2014, 06:56:19 »
já tomu prd rozumím, ale pokud vám jde o server side includes, tak tu  v té ukázce konfigurace nic relevantního nevidím...

http://httpd.apache.org/docs/current/mod/mod_include.html

p.dohny

  • Aktivní člen
  • *
  • Příspěvků: 327
Re:Include v Apache
« Odpověď #2 kdy: 27 Května 2014, 10:50:43 »
Tak jsem zkusil update ještě na druhém PC a úplně bez problémů je tam verze 2.4.6 na tom co mi to nejde je 2.4.7 - nevím proč to vzalo pro instalaci jinou verzi.

Dá se to nějak jednoduše přehodit na tu starší verzi?
Ubuntu 20.10.
Nachystej mi uzenáče, na snídani jsem zpátky :)

p.dohny

  • Aktivní člen
  • *
  • Příspěvků: 327
Re:Include v Apache
« Odpověď #3 kdy: 27 Května 2014, 19:38:31 »
Tak nakonec vyřešeno přechodem na nižší verzi Apache.
Ubuntu 20.10.
Nachystej mi uzenáče, na snídani jsem zpátky :)

Petr Merlin Vaněček

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 5057
    • Lomítkáři
Re:Include v Apache
« Odpověď #4 kdy: 27 Května 2014, 22:05:15 »
Nějak se vůbec nechytám, co mělo či nemělo fungovat?
Include conf souborů v apache2? Nebo fce include() v php?
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

p.dohny

  • Aktivní člen
  • *
  • Příspěvků: 327
Re:Include v Apache
« Odpověď #5 kdy: 27 Května 2014, 22:42:35 »
Nefungovala fce include v php (či-li na localhost vše mimo toho co bylo v include). Stejná verze php, kde jsem si myslel, že to bude prvně, ale nakonec to bylo asi někde v apache - možná jen nějaká chybka ve verzi 2.4.7 - downgrade to vyřešil.

Ubuntu 20.10.
Nachystej mi uzenáče, na snídani jsem zpátky :)

Petr Merlin Vaněček

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 5057
    • Lomítkáři
Re:Include v Apache
« Odpověď #6 kdy: 28 Května 2014, 08:19:28 »
To se mi úplně nezdá, protože apache nezpracovává php.
Ten jen předá požadavek ke zpracování buď modulu (který není součást apache, instaluje se s php), nebo jej předá CGI, což je zase jen php interpret, který vše zpracuje a výsledek předá apache, který to naservíruje klientovi.

Tedy spíše bych si tipl, že někde v konfigu apache (to lze direktivou) byla explicitně fce include() zakázaná.
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

p.dohny

  • Aktivní člen
  • *
  • Příspěvků: 327
Re:Include v Apache
« Odpověď #7 kdy: 28 Května 2014, 08:22:58 »
Nevím, potřeboval jsem vyřešit hned, či-li jsem si s tím přes noc hrál a když to neklaplo přešel jsem na jinou verzi. Nic zakázaného jsem v konfiguračních souborech nenašel oproti druhému PC, kde to šlo. A hlavně jsem také nepochopil, proč by to mělo být zakázané už po instalaci?
Ubuntu 20.10.
Nachystej mi uzenáče, na snídani jsem zpátky :)

Petr Merlin Vaněček

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 5057
    • Lomítkáři
Re:Include v Apache
« Odpověď #8 kdy: 28 Května 2014, 08:25:32 »
To nevím ani já, nicméně bych si tipl, že by se ledacos dalo dohledat v logu.
A pokud ne, tak zvýšit log level.
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

 

Provoz zaštiťuje spolek OpenAlt.