Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Přepínání grafických karet Integrované intel a AMD  (Přečteno 3699 krát)

whiterabbit

  • Návštěvník
  • *
  • Příspěvků: 6
    • Zobrazit profil
Přepínání grafických karet Integrované intel a AMD
« kdy: 12 Květen 2015, 15:58:28 »
Dobrý den, mám dvě grafické karty Jednu Integrovanou od Intelu .. A druhou Ati Readon HD 7550M/75570M/7650M .. Problém je, že to bere pořád integrovanou.. Ve vláknu
http://forum.ubuntu.cz/index.php?topic=74150.msg533818
Jsem první řešil spuštění battle.netu a World of Warcraft se sputí .. Ale ty FPS.. Hned mi bylo jasné, že to bere tu integrovanou a nikde jsem nenašel, kde přepnout na tu moji Ati Readonku, pouze nVidie to podporují celkem bezproblémově.. Takže se ptám, jak to přepnout, aby mi aspoň wow jelo na mojí Ati grafické kartě. Děkuji. Popřípadě omluvte za špatnou sekci, pokud jsem tohle téma vložil špatně a za občasné otázky, které asi nejsou tak dobře směřované, ale neorientuji se v oblasti Linuxu takovou dobu. Děkuji ještě jednou za všechny odpovědi.

František Zatloukal

  • Závislák
  • ****
  • Příspěvků: 1802
    • Zobrazit profil
    • frantisek.zatloukalu.eu
Re:Přepínání grafických karet Integrované intel a AMD
« Odpověď #1 kdy: 12 Květen 2015, 16:23:59 »
Tady bude potřeba zkoušet, protože sám takovou sestavu nemám a ani nevím o nikom, kdo by ji měl.

První na co jsem narazil vypadá poměrně jednoduše:
Kód: [Vybrat]
sudo apt-get install fglrx fglrx-pxpress

A restartuj.

Po spuštění otevři aplikaci AMD Catalyst Control Center (Administrator), kde by měla být sekce Switchable Graphics / Přepínatelné grafiky , po přepnutí bude patrně potřeba odhlásit se a znovu přihlásit.

Co se týče problému s Battle.net, je už to OK a funguje to bez toho LIBGL_ALWAYS_SOFTWARE=1 ? Jestliže ne, tak se FPS přepnutím na Radeon nezvýší.
First they ignore you, then they laugh at you,
then they fight you, then you win.
Powered by Fedora 22 | Ubuntu 15.10

whiterabbit

  • Návštěvník
  • *
  • Příspěvků: 6
    • Zobrazit profil
Re:Přepínání grafických karet Integrované intel a AMD
« Odpověď #2 kdy: 12 Květen 2015, 16:35:29 »
Odzkouším to.. A Battle.Net musím spouštět příkazem
Kód: [Vybrat]
LIBGL_ALWAYS_SOFTWARE=1 wine ~/.wine/drive_c/Program*/Battle.net/"Battle.net Launcher.exe"

František Zatloukal

  • Závislák
  • ****
  • Příspěvků: 1802
    • Zobrazit profil
    • frantisek.zatloukalu.eu
Re:Přepínání grafických karet Integrované intel a AMD
« Odpověď #3 kdy: 12 Květen 2015, 16:43:16 »
Odzkouším to.. A Battle.Net musím spouštět příkazem
Kód: [Vybrat]
LIBGL_ALWAYS_SOFTWARE=1 wine ~/.wine/drive_c/Program*/Battle.net/"Battle.net Launcher.exe"

Takže FPS budou nízké pořád, WoW bez battle.netu si nezkoušel?
First they ignore you, then they laugh at you,
then they fight you, then you win.
Powered by Fedora 22 | Ubuntu 15.10

whiterabbit

  • Návštěvník
  • *
  • Příspěvků: 6
    • Zobrazit profil
Re:Přepínání grafických karet Integrované intel a AMD
« Odpověď #4 kdy: 12 Květen 2015, 16:47:00 »
Ihned vyzkouším, jen dostahuji poslední kousek wowka.. jsem to zapínal předtím, když to bylo v hodnotě Optimal.. Ale i tak si myslím, že to nemělo na FPS vliv, jen chvilku trvalo vždycky klasicky vykreslení,.. Ihned odzkouším jen to raději dostahuji.

whiterabbit

  • Návštěvník
  • *
  • Příspěvků: 6
    • Zobrazit profil
Re:Přepínání grafických karet Integrované intel a AMD
« Odpověď #5 kdy: 12 Květen 2015, 17:39:19 »
Takže když zadám příkaz
Kód: [Vybrat]
sudo apt-get install fglrx fglrx-pxpress
Vypíše to následující
Kód: [Vybrat]
reini@reini-HP-ProBook-4540s:~$ sudo apt-get install fglrx fglrx-pxpress[sudo] password for reini:Čtu seznamy balíků… HotovoVytváří se strom závislostíČtu stavové informace… HotovoNěkteré balíky nemohly být instalovány. To může znamenat, že požadujetenemožnou situaci, nebo, pokud používáte nestabilní distribuci, ževyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.Následující informace vám mohou pomoci vyřešit tuto situaci:Následující balíky mají nesplněné závislosti:fglrx : Závisí na: xorg-video-abi-11 ale nedá se nainstalovat neboxorg-video-abi-12 ale nedá se nainstalovat neboxorg-video-abi-13 ale nedá se nainstalovat neboxorg-video-abi-14 ale nedá se nainstalovat neboxorg-video-abi-15E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.
« Poslední změna: 12 Květen 2015, 17:42:29 od whiterabbit »

František Zatloukal

  • Závislák
  • ****
  • Příspěvků: 1802
    • Zobrazit profil
    • frantisek.zatloukalu.eu
Re:Přepínání grafických karet Integrované intel a AMD
« Odpověď #6 kdy: 12 Květen 2015, 23:28:41 »
No, je to tahle chyba.

Předpokládám, že máš Ubuntu 14.04 - bude potřeba povolit repozitář trusty-proposed - anglický návod je tady. Pokud se nepletu, tak stačí do vyhledávání zadat "zdroje softwaru" a potom jen zatrhnout proposed (v české verzi asi "nevydané aktualizace").

Poté do terminálu:
Kód: [Vybrat]
sudo apt-get update
a znovu:
Kód: [Vybrat]
sudo apt-get install fglrx fglrx-pxpress
First they ignore you, then they laugh at you,
then they fight you, then you win.
Powered by Fedora 22 | Ubuntu 15.10