Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Apache chyba  (Přečteno 2128 krát)

Jameees

  • Návštěvník
  • *
  • Příspěvků: 1
  • Karma: +0/-0
    • Zobrazit profil
Apache chyba
« kdy: 18 Prosinec 2018, 17:01:18 »
Dobrý den,
Nainstaloval jsem si na svoje VPS s linuxem php a apache2, vše funguje, ale když pustím apache, tak na port 80 už něco listenuje. A když dám do složky /var/www/html nějaký html tak na x.x.x.x:80 se to html zobrazí, ale php ne. To funguje pouze, když pustím apache, který jsem si nastavil na port 90 a to je pak na x.x.x.x:90. Jak docílím toho, abych měl html a apache s php na portu 80? Když to nastavím s apache, tak mi to hodí chybu apache 98, kde to teda nejde na 80, protože to už je listenutý.

Děkuji.

NZM23

  • Člen
  • **
  • Příspěvků: 163
  • Karma: +4/-0
    • Zobrazit profil
Re:Apache chyba
« Odpověď #1 kdy: 18 Prosinec 2018, 19:06:25 »
a máš nastaven localhost?
Kód: [Vybrat]
ydra@hydra-Aspire-5750ZG:/opt/lampp/apache2/conf$ pwd
/opt/lampp/apache2/conf
hydra@hydra-Aspire-5750ZG:/opt/lampp/apache2/conf$ more httpd.conf
Alias /bitnami/ "/opt/lampp/apache2/htdocs/"
Alias /bitnami "/opt/lampp/apache2/htdocs"

<Directory "/opt/lampp/apache2/htdocs"> # TOHLE JE CESTA K LOCALHOST
    Options Indexes FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

V prohlížeči pak jen zadávám //locallhost/mujprojekt

a apache mám normálně nastaven na port 80