Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Lubuntu 18.04 a synaptik AUTHENTICATION FAILED  (Přečteno 170 krát)

HonzaD

  • Člen
  • **
  • Příspěvků: 496
    • Zobrazit profil
    • VoIP a internetová komunikace
Lubuntu 18.04 a synaptik AUTHENTICATION FAILED
« kdy: 14 Únor 2020, 21:36:18 »
Když zapnu synpatik z GUI tak nenaběhne
Když z konzole dám tohle, tak viz výpis (helso dávám správně)


:~$ synaptic-pkexec
==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic ===
Authentication is required to run the Synaptic Package Manager
Authenticating as: hatompc,,, (hatompc)
Password:
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.

Ventero

  • Závislák
  • ****
  • Příspěvků: 1716
    • Zobrazit profil
Re:Lubuntu 18.04 a synaptik AUTHENTICATION FAILED
« Odpověď #1 kdy: 15 Únor 2020, 07:31:48 »
Zaznam v policykit je?
Zvuky jsou mantrami a myšlenky moudrostí, prostě proto, že se mohou objevovat ...

juwa2

  • Závislák
  • ****
  • Příspěvků: 3343
    • Zobrazit profil
Re:Lubuntu 18.04 a synaptik AUTHENTICATION FAILED
« Odpověď #2 kdy: 15 Únor 2020, 08:52:40 »
Podívej se, jestli máš soubor
Kód: [Vybrat]
/usr/share/polkit-1/actions/com.ubuntu.pkexec.synaptic.policy
Pokud ne, vytvoř ho. Jeho obsah je:
Kód: [Vybrat]
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE policyconfig PUBLIC
 "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
<policyconfig>

  <action id="com.ubuntu.pkexec.synaptic">
    <message>Pro spuštění Synaptic Package Manageru je třeba zadat heslo.</message>
    <icon_name>synaptic</icon_name>
    <defaults>
      <allow_any>auth_admin</allow_any>
      <allow_inactive>auth_admin</allow_inactive>
      <allow_active>auth_admin</allow_active>
    </defaults>
    <annotate key="org.freedesktop.policykit.exec.path">/usr/sbin/synaptic</annotate>
    <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
  </action>

</policyconfig>

Jinak Synaptic můžeš ještě spustit příkazem
Kód: [Vybrat]
sudo synaptic

HonzaD

  • Člen
  • **
  • Příspěvků: 496
    • Zobrazit profil
    • VoIP a internetová komunikace
Re:Lubuntu 18.04 a synaptik AUTHENTICATION FAILED
« Odpověď #3 kdy: 16 Únor 2020, 18:44:45 »
Měl jsem tan tohle:
cat /usr/share/polkit-1/actions/com.ubuntu.pkexec.synaptic.policy
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE policyconfig PUBLIC
 "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
<policyconfig>

  <action id="com.ubuntu.pkexec.synaptic">
    <message>Authentication is required to run the Synaptic Package Manager</message>
    <message xml:lang="ar">الاستيثاق مطلوب لتشغيل مدير الحزم التشابكي</message>
    <message xml:lang="bg">Нужно е да се идентифицирате, преди да стартирате пакетния мениджър</message>
    <message xml:lang="br">Dilesa azgoulennet evit erounit an ardoer pakadoù synaptic</message>
    <message xml:lang="bs">Za pokretanje programa Synaptic Package Manager potrebna je autentifikacija</message>
    <message xml:lang="ca@valencia">Es requereix autenticació per a executar el gestor de paquets Synaptic</message>
    <message xml:lang="cs">Pro běh Správce balíčků Synaptic je vyžadováno ověření</message>
    <message xml:lang="de">Um die Synaptic-Paketverwaltung zu benutzen, ist eine Legitimation notwendig</message>
    <message xml:lang="en_AU">Authentication is required to run the Synaptic Package Manager</message>
    <message xml:lang="en_GB">Authentication is required to run the Synaptic Package Manager</message>
    <message xml:lang="eo">Aŭtentigo estas postulata por ruli la pakaĵmastrumilon Sinaptiko</message>
    <message xml:lang="es">Para ejecutar el gestor de paquetes Synaptic necesita autenticarse</message>
    <message xml:lang="et">Autentimine on vajalik paketihalduri Synaptic käivitamiseks</message>
    <message xml:lang="fi">Synaptic-pakettihallinnan käynnistäminen vaatii tunnistautumisen</message>
    <message xml:lang="fr">Une authentification est requise pour exécuter le gestionnaire de paquets Synaptic</message>
    <message xml:lang="gl">Para executar o xestor de paquetes Synaptic necesita autenticarse</message>
    <message xml:lang="he">נדרש אימות כדי להריץ את מנהל החבילות Synaptic</message>
    <message xml:lang="hr">Potrebna je ovjera za pokretanje Synaptic upravitelja paketima</message>
    <message xml:lang="hu">Hitelesítés szükséges a Synaptic csomagkezelő futtatásához</message>
    <message xml:lang="ms">Pengesahihan diperlukan untuk menjalankan Pengurus Pakej Synaptic</message>
    <message xml:lang="nl">Authenticatie is vereist om Synaptic pakketbeheer uit te voeren</message>
    <message xml:lang="pl">W celu uruchomienia programu Synaptic Package Manager wymagane jest dodatkowe uwierzytelnianie</message>
    <message xml:lang="pt_BR">Autenticação é exigida para executar o Gerenciador de Pacotes Synaptic</message>
    <message xml:lang="ro">Este necesară autentificarea pentru a rula administratorul de pachete Synaptic.</message>
    <message xml:lang="ru">Для запуска менеджера пакетов Synaptic требуется аутентификация</message>
    <message xml:lang="sk">Spustenie správcu balíkov Synaptiuc vyžaduje overenie totožnosti</message>
    <message xml:lang="sl">Za zagon upravljalnika paketov Synaptic je zahtevana skrbniška overitev.</message>
    <message xml:lang="sr">Потребно је потврђивање идентитета за покретање Синаптика упраника пакета</message>
    <message xml:lang="sv">Autentisering krävs för att köra Synaptic pakethanterare</message>
    <message xml:lang="te">సినాప్టిక్ ప్యాకేజీ నిర్వాహకం నడుపుటకు ధృవీకరణ అవసరం</message>
    <message xml:lang="tr">Synaptic Paket Yöneticisi'ni çalıştırmak için yetkilendirme gerekiyor</message>
    <message xml:lang="zh_HK">執行 Synaptic 套件管理員前要先認證</message>
    <message xml:lang="zh_TW">需要驗證以執行Synaptic 套件管理程式</message>
    <icon_name>synaptic</icon_name>
    <defaults>
      <allow_any>auth_admin</allow_any>
      <allow_inactive>auth_admin</allow_inactive>
      <allow_active>auth_admin</allow_active>
    </defaults>
    <annotate key="org.freedesktop.policykit.exec.path">/usr/sbin/synaptic</annotate>
    <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
  </action>


Přepsal jsem to na to cos posílala  výsledek z GUI nic a konzole i když jsem dal správné heslo tak:
synaptic-pkexec
==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic ===
Pro spuštění Synaptic Package Manageru je třeba zadat heslo.
Authenticating as: hatompc,,, (hatompc)
Password:
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.
« Poslední změna: 16 Únor 2020, 18:47:19 od HonzaD »

juwa2

  • Závislák
  • ****
  • Příspěvků: 3343
    • Zobrazit profil
Re:Lubuntu 18.04 a synaptik AUTHENTICATION FAILED
« Odpověď #4 kdy: 16 Únor 2020, 19:42:34 »
Ten soubor je OK, tos přepisovat nemusel (jsou tam jen ty cizí lang. navíc..)
Co vyhodí příkaz
Kód: [Vybrat]
sudo synaptic
?? Potřetí už se ptát nemíním...