Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Python, idle  (Přečteno 1213 krát)

vollponi

  • Návštěvník
  • *
  • Příspěvků: 55
    • Zobrazit profil
Python, idle
« kdy: 09 Listopad 2020, 21:23:32 »
Zdravím,
používám Ubuntu 16.04 LTS. Z terminálu můžu spustit Python 2.7.12 (příkaz python) a python 3.5.2 (příkaz python3.5).

Když spustím idle, tak mi automaticky naběhne python 2.7.12.

Jak docílím toho abych v idle spustil python 3.5.2?

Díky.


GdH

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 3053
    • Zobrazit profil
    • GdH-Notes
Re:Python, idle
« Odpověď #1 kdy: 09 Listopad 2020, 22:48:20 »
Nainstalovat a spustit IDLE3?

juwa2

  • Závislák
  • ****
  • Příspěvků: 3911
    • Zobrazit profil
Re:Python, idle
« Odpověď #2 kdy: 09 Listopad 2020, 23:44:12 »
Zdravím,
používám Ubuntu 16.04 LTS. Z terminálu můžu spustit Python 2.7.12 (příkaz python) a python 3.5.2 (příkaz python3.5).

Když spustím idle, tak mi automaticky naběhne python 2.7.12.

Jak docílím toho abych v idle spustil python 3.5.2?

Díky.

V prvé řadě se podívej jakou (jaké) verzi(e) pythonu máš vůbec nainstalovanou.
Přitom platí pravidlo, že pokud zadáš příkaz
Kód: [Vybrat]
python /skript.py
Tak se skript/příkaz spustí s nejvyšší momentálně dostupnou  (momentálně nainstalovanou) verzí (pythonu).

Pokud zadáš příkaz:
Kód: [Vybrat]
python3 /skript.py
Tak se příkaz/skript spustí s nejvyšší trojkovou verzí pythonu jež je aktuálně v systému dostupná..
Domnívám se, že toto vysvětlení je plně dostatečné, snad se moc nepletu...

vollponi

  • Návštěvník
  • *
  • Příspěvků: 55
    • Zobrazit profil
Re:Python, idle
« Odpověď #3 kdy: 10 Listopad 2020, 15:06:17 »
Chápu, že moje otázky někomu mohu připadat hloupé... nicméně naistaloval jsem idle3 a když chci spustit, tak se objeví hláška:

** IDLE can't import Tkinter.
Your Python may not be configured for Tk. **

Věděl by někdo co s tím?

GdH

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 3053
    • Zobrazit profil
    • GdH-Notes
Re:Python, idle
« Odpověď #4 kdy: 10 Listopad 2020, 16:16:53 »
Instaloval jsi normálně přes apt? Evidentně mu chybí modul tk, který má idle3 v závislostech a měl by se automaticky nainstalovat. Pokud z nějakého důvodu nemáš, doinstaluj  balík python3-tk, modul by se měl objevit zhruba tady:
/usr/lib/python3.5/lib-dynload/_tkinter.cpython-35m-x86_64-linux-gnu.so

vollponi

  • Návštěvník
  • *
  • Příspěvků: 55
    • Zobrazit profil
Re:Python, idle
« Odpověď #5 kdy: 10 Listopad 2020, 21:11:31 »
Díky, vyřešeno.