Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: instalace PlatformIO do Visual Studio Code  (Přečteno 4267 krát)

Diego

  • Aktivní člen
  • *
  • Příspěvků: 79
    • Arze
instalace PlatformIO do Visual Studio Code
« kdy: 21 Května 2023, 14:03:57 »
Ahoj všem,
Snažím se nainstalovat vývojové IDE PlatformIO (https://platformio.org/. Povedlo se mi nainstalovat potřebné Visual Studio Code ale při instalaci PlatformIO mi to hází chybu.
Pro opravu chyby mi to nabízí odkaz(https://github.com/platformio/platformio-core-installer/issues/85
Když se ale snažím nainstalovat opravu
Kód: [Vybrat]
sudo apt-get install python3-venvTak mi to vyhodí chybu:
Kód: [Vybrat]
python3-venv : Závisí na: python3.10-venv (>= 3.10.6-1~) ale nebude se instalovat
                Závisí na: python3-distutils (>= 3.10.6-1~) ale nebude se instalovat
E: Nesplněné závislosti. Zkuste spustit „apt --fix-broken install“ bez balíků (nebo navrhněte řešení).

Fix taky nepomůže:
Kód: [Vybrat]
diego@diego-nb:~$ sudo apt --fix-broken install
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí… Hotovo
Načítají se stavové informace… Hotovo
Opravují se závislosti… Hotovo
Následující balíky byly nainstalovány automaticky a již nejsou potřeba:
  libflashrom1 libftdi1-2 libirrlicht1.8 libjsoncpp25 libllvm13 libllvm13:i386 libmlt7-data
  libspatialindex6 libwxgtk-webview3.0-gtk3-0v5 melt-7
Pro jejich odstranění použijte „sudo apt autoremove“.
Následující dodatečné balíky budou instalovány:
  libmlt-data melt
Následující NOVÉ balíky budou nainstalovány:
  libmlt-data melt
0 aktualizováno, 2 nově instalováno, 0 k odstranění a 43 neaktualizováno.
4 instalováno nebo odstraněno pouze částečně.
Nutno stáhnout 0 B/128 kB archivů.
Po této operaci bude na disku použito dalších 826 kB.
Chcete pokračovat? [Y/n]
(Načítá se databáze … nyní je nainstalováno 297903 souborů a adresářů.)
Připravuje se nahrazení …/libmlt-data_7.16.0-1~ubuntu22.04.1_all.deb …
Rozbaluje se libmlt-data (7.16.0-1~ubuntu22.04.1) …
dpkg: chyba při zpracovávání archivu /var/cache/apt/archives/libmlt-data_7.16.0-1~ubuntu22.04.1_all.deb (--
unpack):
 zkouším přepsat soubor „/usr/share/mlt-7/avformat/blacklist.txt“, který je také v balíku libmlt7-data 7.14
.0-1~ubuntu22.04.1
Připravuje se nahrazení …/melt_7.16.0-1~ubuntu22.04.1_amd64.deb …
Rozbaluje se melt (7.16.0-1~ubuntu22.04.1) …
dpkg: chyba při zpracovávání archivu /var/cache/apt/archives/melt_7.16.0-1~ubuntu22.04.1_amd64.deb (--unpac
k):
 zkouším přepsat soubor „/usr/bin/melt-7“, který je také v balíku melt-7 7.14.0-1~ubuntu22.04.1
Při zpracování nastaly chyby:
 /var/cache/apt/archives/libmlt-data_7.16.0-1~ubuntu22.04.1_all.deb
 /var/cache/apt/archives/melt_7.16.0-1~ubuntu22.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Poradíte?
Díky

Roman Vacho

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 5993
Vyřešená vlákna je vhodné uzavřít "Topic Solved" dole pod vláknem. Děkujeme.

Diego

  • Aktivní člen
  • *
  • Příspěvků: 79
    • Arze
Re:instalace PlatformIO do Visual Studio Code
« Odpověď #2 kdy: 21 Května 2023, 18:08:13 »
Beze změny :(

 

Provoz zaštiťuje spolek OpenAlt.