Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: systémový čas-automatický přesun (vyřešeno)  (Přečteno 4595 krát)

haid

  • Návštěvník
  • *
  • Příspěvků: 27
    • Zobrazit profil
systémový čas-automatický přesun (vyřešeno)
« kdy: 05 Dubna 2008, 11:41:02 »
Od přechodu na letní čas mi blbne systémový čas. V průběhu noci se mi vždy automaticky sníží o 1 hodinu (v BIOSU).
v jiné diskusi (http://usenet.jyxo.cz/cz.comp.linux/0407/posun-systemoveho-casu.html) jsem objevil něco málo rad, ale nikam mně to neposunulo.
Zatím jsem jen udělal toto:

v /etc/rc0.d/@K25hwclock.sh
řádku: # hwclock --adjust $GMT $BADYEAR
jsem dle textu nad ním poslušně odkomentoval a taktéž poslušně smazal (respektive přesunul do /home/zaloha -co kdyby, že) soubor /etc/adjtime.

Nicméně /etc/adjitime se automaticky obnovilo a já jsem, kde jsem byl.

nevím, nakolik je to relevantní informace, ale mám notebook toshibu satelite L35.
pro moderátory:nepřišel jsem na to, kam dotaz zařadit (a atk je tady), když tak prosím o přesunutí. Díky

Díky za rady


přidávám výpis /etc/rc0.d/@K25hwclock.sh
#!/bin/sh
# hwclock.sh   Set and adjust the CMOS clock, according to the UTC
#      setting in /etc/default/rcS (see also rcS(5)).
#
# Version:   @(#)hwclock.sh  2.00  14-Dec-1998  miquels@cistron.nl
#
# Patches:
#      2000-01-30 Henrique M. Holschuh <hmh@rcm.org.br>
#       - Minor cosmetic changes in an attempt to help new
#         users notice something IS changing their clocks
#         during startup/shutdown.
#       - Added comments to alert users of hwclock issues
#         and discourage tampering without proper doc reading.

# WARNING:   Please read /usr/share/doc/util-linux/README.Debian.hwclock
#      or /usr/share/doc/util-linux/README.Debian.hwclock
#      before changing this file. You risk serious clock
#      misbehaviour otherwise.

### BEGIN INIT INFO
# Provides:          hwclock
# Required-Start:    mountdevsubfs
# Required-Stop:     $local_fs
# Default-Start:     S
# Default-Stop:      0 6
### END INIT INFO

FIRST=no   # debian/rules sets this to 'yes' when creating hwclockfirst.sh

# Set this to any options you might need to give to hwclock, such
# as machine hardware clock type for Alphas.
HWCLOCKPARS=

hwclocksh()
{
    [ ! -x /sbin/hwclock ] && return 0
    . /etc/default/rcS

    . /lib/lsb/init-functions
    verbose_log_action_msg() { [ "$VERBOSE" = no ] || log_action_msg "$@"; }

    [ "$GMT" = "-u" ] && UTC="yes"
    case "$UTC" in
       no|"")   GMT="--localtime"
      UTC=""
      if [ "X$FIRST" = "Xyes" ] && [ ! -r /etc/localtime ]; then
          if [ -z "$TZ" ]; then
         log_action_msg "System clock was not updated at this time"
         return 1
          fi
      fi
      ;;
       yes)   GMT="--utc"
      UTC="--utc"
      ;;
       *)   log_action_msg "Unknown UTC setting: \"$UTC\""; return 1 ;;
    esac

    case "$BADYEAR" in
       no|"")   BADYEAR="" ;;
       yes)   BADYEAR="--badyear" ;;
       *)   log_action_msg "unknown BADYEAR setting: \"$BADYEAR\""; return 1 ;;
    esac

    case "$1" in
   start)
       if [ -w /etc ] && [ ! -f /etc/adjtime ] && [ ! -e /etc/adjtime ]; then
      echo "0.0 0 0.0" > /etc/adjtime
       fi

       if [ ! -w /etc/adjtime ]; then
      NOADJ="--noadjfile"
       else
          NOADJ=""
       fi

       if [ "$FIRST" != yes ]; then
      # Uncomment the hwclock --adjust line below if you want
      # hwclock to try to correct systematic drift errors in the
      # Hardware Clock.
      #
      # WARNING: If you uncomment this option, you must either make
      # sure *nothing* changes the Hardware Clock other than
      # hwclock --systohc, or you must delete /etc/adjtime
      # every time someone else modifies the Hardware Clock.
      #[M V0
      # Common "vilains" are: ntp, MS Windows, the BIOS Setup
      # program.
      #
      # WARNING: You must remember to invalidate (delete)
      # /etc/adjtime if you ever need to set the system clock
      # to a very different value and hwclock --adjust is being
      # used.
      #
      # Please read /usr/share/doc/util-linux/README.Debian.hwclock
      # before enablig hwclock --adjust.

      #hwclock --adjust $GMT $BADYEAR
      :
       fi

       if [ "$HWCLOCKACCESS" != no ]; then
      log_action_msg "Setting the system clock"

      # Copies Hardware Clock time to System Clock using the correct
      # timezone for hardware clocks in local time, and sets kernel
      # timezone. DO NOT REMOVE.
      if /sbin/hwclock --hctosys $GMT $HWCLOCKPARS $BADYEAR $NOADJ; then
          #   Announce the local time.
          verbose_log_action_msg "System Clock set to: `date $UTC`"
      else
          log_warning_msg "Unable to set System Clock to: `date $UTC`"
      fi
       else
      verbose_log_action_msg "Not setting System Clock"
       fi
       ;;
   stop|restart|reload|force-reload)
       #
       # Updates the Hardware Clock with the System Clock time.
       # This will *override* any changes made to the Hardware Clock.
       #
       # WARNING: If you disable this, any changes to the system
       #          clock will not be carried across reboots.
       #
       if [ "$HWCLOCKACCESS" != no ]; then
      log_action_msg "Saving the system clock"
      if [ "$GMT" = "-u" ]; then
          GMT="--utc"
      fi
      if /sbin/hwclock --systohc $GMT $HWCLOCKPARS $BADYEAR; then
          verbose_log_action_msg "Hardware Clock updated to `date`"
      fi
       else
      verbose_log_action_msg "Not saving System Clock"
       fi
       ;;
   show)
       if [ "$HWCLOCKACCESS" != no ]; then
      /sbin/hwclock --show $GMT $HWCLOCKPARS $BADYEAR
       fi
       ;;
   *)
       log_success_msg "Usage: hwclock.sh {start|stop|reload|force-reload|show}"
       log_success_msg "       start sets kernel (system) clock from hardware (RTC) clock"
       log_success_msg "       stop and reload set hardware (RTC) clock from kernel (system) clock"
       return 1
       ;;
    esac
}

hwclocksh "$@"

 
« Poslední změna: 05 Dubna 2008, 19:56:29 od haid »

Pavelp

  • Host
Re: systémový čas-automatický přesun
« Odpověď #1 kdy: 05 Dubna 2008, 14:45:33 »
1. Nastavit v biosu aspon priblizne spravny SEC cas. Ted je to UTC + 1. System ho nemeni pri zmene letniho na zimni, jen pokud je nainstalovano NTP tak ho upravuje zmenou frekvence hodin, aby nebyly casove skoky.
2. Nainstalovat ntpdate (nebo ntptime), podle chuti. Ntpdate staci.
3. Spustit tzconfig a spravne nastavit casovou zonu / Europe-Prague. To pricte 1 hodinu navic.
A snad to pude.
 

haid

  • Návštěvník
  • *
  • Příspěvků: 27
    • Zobrazit profil
Re: systémový čas-automatický přesun
« Odpověď #2 kdy: 05 Dubna 2008, 19:12:47 »
díky, provedl jsem, ale výsledek není dobrý.
hodiny v biosu jsem nastavil a nejdřív mi mé xubuntu ukazovalo +1hod a po restartu nastavilo -1hod.

tož tak

haid

  • Návštěvník
  • *
  • Příspěvků: 27
    • Zobrazit profil
Re: systémový čas-automatický přesun (vyřešeno)
« Odpověď #3 kdy: 05 Dubna 2008, 19:58:17 »
tak bych se nejraději vyliskal. přišel jsem na to, že se snažím nastavit časovou zónu v kalendáři orage a ne tam, kde mám. tedy v:systém-datum a čas.
no i to se bohužel stává. děkuji ale za pomoc

 


Provoz zaštiťuje spolek OpenAlt.