Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)  (Přečteno 14194 krát)

henrichg

  • Člen
  • **
  • Příspěvků: 401
  • Karma: +34/-3
    • Zobrazit profil
POZOR!!! Nova verzia skriptu (upraveny 15.2.2009). Stiahnite si ho a reinstalujte compiz volbou "0 Install".

Zmeny v skripte:
- skript vychadza z verzie pre Ubuntu 8.10.
- pribudlo mnoho pluginov
- unsupported pluginy su vyradene - su presunute do users pluginov
- instaluju sa neoficialne ikony pre ccsm
- skript ponuka dalsie moznosti
   - len stiahnut zdrojove subory compiz-fusion
   - len instalovat z predtym stiahnutych zdrojovych suborov compiz-fusion

JAVA: Stiahnite si, nainstalujte a pouzivajte najnovsiu verziu SUN Java 6 update 11 priamo zo stranok SUNu.


Tento navod sa pokusa pomoct pri kompilacii a instalacii Compiz a Compiz-fusion priamo z GIT repozitara na git.compiz-fusion.org. Navod je urceny pre Ubuntu Hardy (8.04), pre 32 aj 64bit verziu. Skript co tu stiahnete sa sice snazi byt kompatibilny aj s Gutsy-m, ale mne prestali fungovat dekoracie. Mam za to, ze to sposobuje nova verzia patchu libx11 pre podporu xcb. Preto skript neodporucam na Gutsy-ho! A ani povodny navod na Gutsy-ho (z wiki ani z fora)!

Co nam to da?
1. mat stale najnovsiu verziu compiz a compiz-fusion
2. pluginy, ktore v repozitaroch Hardy-ho nenajdeme
3. moznost doinstalovat nove pluginy
4. compiz bude rychlejsi (kedze bude skopilovany na vas stroj)

Co mozeme zleho ocakavat?
POZOR!!! Tento sposob instalacie nie je pre uzivatela - zaciatocnika. Dobre si to rozmyslite, nez tento postup pouzijete. Samozrejme, ze sa budem snazit vam pomoct.
1. moze sa stat, ze po instalacii / upgrade vam compiz nepojde. Nastastie fusion-icon vam umozni prepnut sa do metacity, kym sa vam nepodari  compiz sprevadzkovat. Moje skusenosti su take, ze sa toto udeje vemi malo krat. A vzdy mi to vyriesilo odinstalovanie a znovunainstalovanie compiz a compiz-fusion cez tuto popisovany skript. Samozrejme mozete sktiptom odinstalovat to, co sa uz nainstalovalo a vratit sa ku compizu z repozitara Gutsyho.
2. Mozu vam chybat dake baliky, ktore je mozne nastastie doinstalovat cez apt-get alebo Synaptic. Skript co je tu popisany ponuka aj druhu moznost a to doinstalovanie zavislosti cez apt-get build-deps compiz, ale ta zasa nainstaluje aj kopu veci okolo KDE, takze budete mat napr. nainstalovany kwin, konsole.

Tu si stiahnite skript: http://disk.jabbim.cz/henrich.gron@jabbim.sk/bp-compiz_hardy.tar.gz

Odporucany postup?
POZOR!! Pred instalaciou vypnite compiz v System -> Predvolby -> Vzhlad -> Vizualne efekty
1. v Synapticu sa presvedcte, ci mate povolene repozitare main, restricted, universe, multiverse aj so zdrojovymi kodmi: Přidávání zdrojů
2 updatnut databazu zdrojov
Kód: [Vybrat]
sudo apt-get update
3 spustit upgrade Ubuntu, aby sme mali najnovsie baliky vsetkeho co uz mame v systeme
Kód: [Vybrat]
sudo apt-get upgrade
4. stiahnut skript bp-compiz na desktop.
5. otvorit Terminal
6. presunut skript do vasho home adresara (Desktop zmente na nazov vasho adresara napr. Plocha):
Kód: [Vybrat]
mv ~/Desktop/bp-compiz ~7. nastavit skript ako spustatelny:
Kód: [Vybrat]
chmod u+x ~/bp-compiz7.5. LEN PRE Kubuntu: vytvorit symbolic link na utilitu moc:
Kód: [Vybrat]
sudo ln -s /usr/bin/moc /bin/moc8. spustit skript z home adresara:
Kód: [Vybrat]
cd ~
./bp-compiz
9. ponukne vam prve volby, kde si vyberte, co chcete spravit. Vyberte 0 - Install
Kód: [Vybrat]
0. Install
1. Update
2. Uninstall 
3. Only download sources
4. Only install downloaded sources

10. dalsia volba bude, ake prostredie mate (KDE alebo GNOME). Vyberte to vase.
Kód: [Vybrat]
0. GNOME
1. KDE4
2. GNOME + KDE4

Which Desktop Environment are you currently using? [0-2]:

11. Potom vyberte sposob, akym chcete instalovat zavislosti, vyberte 0 - Individual packages (apt-get install libgtk2.0-dev autotools-d...)
Kód: [Vybrat]
0. Individual packages (apt-get install libgtk2.0-dev autotools-d...)
1. Use (apt-get build-dep compiz)

12. Nasleduje dlhy zoznam volieb, kde vyberte 0 - Full installation
Kód: [Vybrat]
Bulletproof CF Script       <Press [Enter] for Default>     Quit: [Ctrl-C]

  0. Full Installation (1-16)
  1. Uninstall all previous versions (compiz/beryl/emerald)
  2. Install Required Dependencies (git-core automake ...)
  3. Install Compiz Dependencies
  5. Install Compiz Core
  6. Install Option Code Generator
  7. Install Settings Library for Plugins
  8. Install CompizConfig-Python
  9. Install Settings Manager
 10. Install Main Plugins
 11. Install Extra Plugins
 12. Install Unofficial icons
 13. Install Users Plugins
 14. Install Emerald
 15. Install Emerald Themes
 16. Install Fusion-Icon
 17. Add argb-glx-visuals to xorg.conf (Skipping - for NVIDIA only)

Choose option [0-17]:

13. Bude kompilovat a instalovat
14. po skonceni vam zobrazi zoznam toho, co sa podarilo a co nie
Kód: [Vybrat]
* Installed Required Dependencies                            [OK]
 * Installed Compiz' Dependencies                             [OK]
 * Installed Compiz Fusion                                    [OK]
 * Installed Option Code Generator                            [OK]
 * Installed Settings Library for Plugins                     [OK]
 * Installed CompizConfig-Python                              [OK]
 * Installed Settings Manager                                 [OK]
 * Installed Main Plugins                                     [OK]
 * Installed Extra Plugins                                    [OK]
 * Installed Users Plugins                                    [OK]
 * Installed Unofficial icons                                 [OK]
 * Installed Emerald                                          [OK]
 * Installed Emerald Themes                                   [OK]
 * Installed Fusion-Icon                                      [OK]

Installation Completed!
15. nakoniec je nutne refresnut cache kniznic (aby sucasi compiz-fusion nasli svoje kniznice, ktore su v /usr/local/lib):
15.1. upravit konfiguracny subor:
Kód: [Vybrat]
sudo nano /etc/ld.so.conf15.2. pridat na koniec riadok (ak tam taka cesta este nie je):
Kód: [Vybrat]
/usr/local/lib15.3. ulozit zmeny
15.4. refreshnut cache:
Kód: [Vybrat]
sudo ldconfig
Zdrojove subory compiz a compiz-fusion sa vam nakopiruju do skriptom vytvoreneho adresara ~/.compiz-setup. Adresar sa da zmenit editaciou skritu - zmenou hodnoty parametra downdir (hned na zacatku skriptu).

Co skript nainstaluje?
1. git verziu compiz (>0.7.4)
2. git verziu compiz-fusion (>0.7.4)
2.1. plugins-main
2.2. plugins-extra
2.3. dalsie pluginy, ktore nie su zaradene do dvoch predchadzajucich balikov (tu nazyvane Users Plugins).
3. Emerald
4. Emerald themes
5. fusion-icon
6. compiz config system manager (ccsm)
7. neoficialne ikony pre ccsm
Vsetko okrem Users plugins sa nainstaluje do prislusnych podadresarov adresara /usr/local . Users plugins sa instaluju do vasho home adresara: ~/.compiz .

Ako spustit compiz-fusion po instalacii?
Kód: [Vybrat]
fusion-icon &Mala by sa vam v trayi objavit modra kocka - logo compizu. Pravim tl. mysi vyvolate menu.
1. Select Window manager -> Compiz = zapne compiz
2. Select Window manager -> Metacity = vypne compiz
3. Select Window decorator -> Emerald = zapne Emerald
4. Ak mate NVidia kartu, zakrtnite Compiz Options -> Loose Binding
5. Setting manager = spusti Compiz config setting manager na nastavenie compiz-fusion
6. Emerald Theme manager = spusti manager tem Emeraldu, mate tam kopu uz pripravenych tem

POZOR!! Uz nezapinajte / nevypinajte compiz cez System -> Predvolby -> Vzhlad -> Vizualne efekty! Na to mate fusion-icon.

Postinstalacne kroky?

Java
Problem, ktory maju vsetky java aplikacie spustane pri beziacom Compize ci Beryle. Niekedy sa to prejavuje tak, ze vsetky okna java aplikacii nemaju vo vnutri zobrazene ovladacie prvky alebo java aplikacia pada, ci sa vobec nespusti.

Odporucany postup: Stiahnite si, nainstalujte a pouzivajte najnovsiu verziu SUN Java 6 update 11 priamo zo stranok SUNu.

Starsi postup opravy:
1. upravte si subor /etc/environment
Kód: [Vybrat]
nano /etc/environment
2. na koniec suboru pridajte novy riadok a do neho nasledovne:
Kód: [Vybrat]
AWT_TOOLKIT=MToolkit
3. ulozte subor
4. odhlaste sa a prihlaste sa
Nastava ale iny problem, a to s zobrazovanim diakritiky a s klavesnicou. Napr. v Oracle SQL Developeri mi namiesto znakov s diakritikov pise stvorcek a makcen na velke pismena nejde napisat.
Sun robi na rieseni tohoto problemu. Oprava by mala byt zaclenena do buildu 6u10 build 24. Momentalne ale nie je k dispozicii. Zdroj: http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6632124

Plugin Screensaver
Parameter "Start automaticaly" funguje len ak nie je spusteny gnome-screensaver. Preto urobte nasledujuce kroky:
1.
Kód: [Vybrat]
killall gnome-screensaver2.
Kód: [Vybrat]
gconf-editor3. zrusit zaskrtnutie /apps/gnome_settings_deamon/screensaver/start_screensaver

Ako odinstalovat?
Ak chcete odinstalovat takto nainstalovany compiz a compiz-fusion, spustite script a vyberte volbu 2. Uninstall
Kód: [Vybrat]
cd ~
./bp-compiz
Kód: [Vybrat]
0. Install
1. Update
2. Uninstall
3. Only download sources
4. Only install downloaded sources


Ako updatovat, aby sme mali najnovsie zmeny?
Ak chcete updatovat, spustite script bp-compiz a vyberte volbu 1. Update
Kód: [Vybrat]
cd ~
./bp-compiz
Kód: [Vybrat]
0. Install
1. Update
2. Uninstall
3. Only download sources
4. Only install downloaded sources


Ako ziskat zdrojove kody compiz-fusion?
Spustite script bp-compiz a vyberte volbu 3. Only download sources
Kód: [Vybrat]
cd ~
./bp-compiz
Kód: [Vybrat]
0. Install
1. Update
2. Uninstall
3. Only download sources
4. Only install downloaded sources

Vytvori sa subor compiz-setup.tgz vo vasom home adresari.

Ako instalovat zo zdrojovych suborov compiz-fusion?
Musite mat vo vasom home adresari subor compiz-setup.tgz vytvoreny volbou 3. Only download sources.
Spustite script bp-compiz a vyberte volbu 4. Only install downloaded sources
Kód: [Vybrat]
cd ~
./bp-compiz
Kód: [Vybrat]
0. Install
1. Update
2. Uninstall
3. Only download sources
4. Only install downloaded sources


Uzitocne linky?
Hl stranka projektu: http://www.compiz-fusion.org/
Co je noveho? http://planet.compiz-fusion.org/
Wiki: http://wiki.compiz-fusion.org/
Forum: http://forum.compiz-fusion.org/
Mozem instalovat / upgradovat? http://status.compiz-fusion.org/
Co sa zmenilo v git? http://gitweb.compiz-fusion.org/?o=age
Nasiel som chybu, tak ju zahlasim. http://bugs.opencompositing.org/
Ako je na tom preklad do mojho jazyka? http://l10n.compiz-fusion.org/trunk/





« Poslední změna: 15 Únor 2009, 23:31:57 od henrichg »
Ubuntu 11.04 + Gnome Shell z Gnome 3 PPA ;-)

Yohann

  • Návštěvník
  • *
  • Příspěvků: 42
  • Karma: +2/-0
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #1 kdy: 08 Červenec 2008, 23:02:50 »
 ??? nějak se mi to nedaří, píše že nemůže najít balík....
prosím o radu, díky :)

Insalling Compiz Fusion 's dependencies...
Čtu seznamy balíků... Hotovo
Vytvářím strom závislostí       
Čtení stavových informací... Hotovo
autoconf je již nejnovější verze.
autoconf set to manually installed.
autotools-dev je již nejnovější verze.
autotools-dev set to manually installed.
build-essential je již nejnovější verze.
dpkg-dev je již nejnovější verze.
dpkg-dev set to manually installed.
g++ je již nejnovější verze.
g++ set to manually installed.
intltool je již nejnovější verze.
libc6-dev je již nejnovější verze.
libc6-dev set to manually installed.
E: Nemohu najít balík libopencdk8-dev
[Failed] The previous process exited with error 100

ThinkPad T61 Kubuntu 10.10 64
Nokia N900

qUAKER

  • Host
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #2 kdy: 09 Červenec 2008, 08:31:22 »
tenhle krok má být takhle(odzkoušeno)

starý:
Citace
11. Potom vyberte sposob, akym chcete instalovat zavislosti, vyberte 1 - Individual packages (apt-get install libgtk2.0-dev autotools-d...)
Kód: [Vybrat]
0. Use (apt-get build-dep compiz)
1. Individual packages (apt-get install libgtk2.0-dev autotools-d...)

nový:
Citace
11. Potom vyberte sposob, akym chcete instalovat zavislosti, vyberte 0 - Use (apt-get build-dep compiz)
Kód: [Vybrat]
0. Use (apt-get build-dep compiz)
1. Individual packages (apt-get install libgtk2.0-dev autotools-d...)
« Poslední změna: 09 Červenec 2008, 08:32:54 od qUAKER »

henrichg

  • Člen
  • **
  • Příspěvků: 401
  • Karma: +34/-3
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #3 kdy: 09 Červenec 2008, 09:42:26 »
Aha, Hardy uz ma  libopencdk10-dev. Doma opravim skript.
Ubuntu 11.04 + Gnome Shell z Gnome 3 PPA ;-)

Yohann

  • Návštěvník
  • *
  • Příspěvků: 42
  • Karma: +2/-0
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #4 kdy: 09 Červenec 2008, 18:27:44 »
tenhle krok má být takhle(odzkoušeno)

starý:
Citace
11. Potom vyberte sposob, akym chcete instalovat zavislosti, vyberte 1 - Individual packages (apt-get install libgtk2.0-dev autotools-d...)
Kód: [Vybrat]
0. Use (apt-get build-dep compiz)
1. Individual packages (apt-get install libgtk2.0-dev autotools-d...)

nový:
Citace
11. Potom vyberte sposob, akym chcete instalovat zavislosti, vyberte 0 - Use (apt-get build-dep compiz)
Kód: [Vybrat]
0. Use (apt-get build-dep compiz)
1. Individual packages (apt-get install libgtk2.0-dev autotools-d...)

Pokud tedy zadám :

0 Install, 0 Gnome, 0 Use (apt-get build-dep compiz), 0 Full installation


 tak mně to skončí na tomhle:

Insalling Compiz Fusion 's dependencies...
Čtu seznamy balíků... Hotovo
Vytvářím strom závislostí       
Čtení stavových informací... Hotovo
E: Do sources.list musíte zadat 'zdrojové' URI
[Failed] The previous process exited with error 100
yohann@yohann-laptop:~$
ThinkPad T61 Kubuntu 10.10 64
Nokia N900

qUAKER

  • Host
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #5 kdy: 09 Červenec 2008, 19:48:57 »
nemáš v sources.list řádky s deb-src

Roman Vacho

  • Člen placené komunitní podpory
  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5591
  • Karma: +218/-47
  • Jeden vykope studnu, tisíce z ní pijí tisíc let.
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #6 kdy: 07 Srpen 2008, 18:37:08 »
Přinese mi to neblikající Compiz x Ati? :)
Vyřešená vlákna je vhodné uzavřít dodáním znaků "[vyřešeno]" do názvu téma v editaci prvního příspěvku.

Olpraim

  • Návštěvník
  • *
  • Příspěvků: 56
  • Karma: +1/-0
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #7 kdy: 17 Září 2008, 21:47:22 »
Jak pridat Fusion icon aby se zapinala při spuštění? když jsem jí dal do sezení tk to udělalo bordel a stejně se nespustila...

Zelvuska

  • Návštěvník
  • *
  • Příspěvků: 85
  • Karma: +6/-0
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #8 kdy: 22 Říjen 2008, 20:09:42 »
Zdravím.
Až dovčera jsem fungoval na starém skriptu, protože jsem nepozoroval žádné problémy, ale včera mi aktualizace spadla, tak jsem compiz starým skriptem odinstaloval a novým nainstaloval, ale dostávám chybu. Nenainstaluje se položka "Users Plugins", dává to u nich Error 2. Těžko se z toho dostává chybová hláška, ale kdyby bylo potřeba něco víc informací, tak se pokusím je nějak získat.
Díky za rady.

eXt_r33m

  • Člen
  • **
  • Příspěvků: 129
  • Karma: +5/-5
  • skill :: aggressive-newbie
    • Zobrazit profil
    • qinta.php5.sk
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #9 kdy: 23 Říjen 2008, 19:16:34 »
Vyzkouseno... par erroru -> pri instalaci mi to pri users plugin vyhlasilo [error 2] a trochu to obcas lagne nebo zatuhne... jinak celkem dost vadi ty KDE aplikace co se mi nainstalovali a ted lezi v Applications->Other... :P  ??? ::)
AMD Opteron Processor 144 1.8 Ghz;2x512 MiB DDR1;ATI Radeon HD 2600 Pro 256 MiB DDR3;Atheros 802.11 WiFi;Boot: WinXP + (Ubuntu 9.04 64bit) + Archlinux s KDE 4.3 64bit
if ($She_loves_me) then wake_up() //checking if  i am dreaming :)

eXt_r33m

  • Člen
  • **
  • Příspěvků: 129
  • Karma: +5/-5
  • skill :: aggressive-newbie
    • Zobrazit profil
    • qinta.php5.sk
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #10 kdy: 31 Říjen 2008, 15:05:26 »
Zdravim, zkousel ste to nekdo i na 8.10??? Prave sem doinstaloval....
AMD Opteron Processor 144 1.8 Ghz;2x512 MiB DDR1;ATI Radeon HD 2600 Pro 256 MiB DDR3;Atheros 802.11 WiFi;Boot: WinXP + (Ubuntu 9.04 64bit) + Archlinux s KDE 4.3 64bit
if ($She_loves_me) then wake_up() //checking if  i am dreaming :)

Zdenek K. aka "djz88"

  • Člen
  • **
  • Příspěvků: 187
  • Karma: +12/-2
  • Join the Darkside
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #11 kdy: 31 Říjen 2008, 21:57:21 »
Zdravim, zkousel ste to nekdo i na 8.10??? Prave sem doinstaloval....

No ja zkousim... z pocatku to hazelo erorry vsude... kdyz sem si stim zacal hrat..tak pak uz jen u User plugins... potom zase nechteli najet ramy oken... ale po 3 hodinach mi to beha..resp se to chova, ze to beha. Jdu testovat :).

I <3 TRANCE mjuzik
__________________
Desktop UBUNTU 9.O4 AMD64 > Compal FL9O GF86OOGT, Core 2 duo @2.2Ghz, 4GiB RAM Server Debian-Lenny i386 > Ati X1600XT, Athlon 3200+,2GiB RAM GFMX44O, Celeron @ 5OOMhz, 384MiB RAM

henrichg

  • Člen
  • **
  • Příspěvků: 401
  • Karma: +34/-3
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #12 kdy: 01 Listopad 2008, 00:16:40 »
Robim na verzii pre Ibex-a  ;)
Pribudne kopa novych pluginov.
« Poslední změna: 01 Listopad 2008, 00:22:23 od henrichg »
Ubuntu 11.04 + Gnome Shell z Gnome 3 PPA ;-)

Wr41th

  • Člen
  • **
  • Příspěvků: 130
  • Karma: +11/-1
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #13 kdy: 01 Listopad 2008, 11:18:57 »
Super a kdy to asi bude?  :D
HP pavilion dv6580 - AMD Turion64 X2 2x1,8GHz, 2x1GB RAM 667MHz, Nvidia 8400M GS 128MB - Ubuntu 10.10

Have you tried turning it off and on again?

Erricco

  • Návštěvník
  • *
  • Příspěvků: 7
  • Karma: +0/-0
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #14 kdy: 01 Listopad 2008, 21:41:16 »
Mne to beži na 8.10 super,dokonca lepšie ako na 8.04

Tešim sa už na tie nove plug-iny   :P

henrichg

  • Člen
  • **
  • Příspěvků: 401
  • Karma: +34/-3
    • Zobrazit profil
Ubuntu 11.04 + Gnome Shell z Gnome 3 PPA ;-)

nezik

  • Stálý člen
  • ***
  • Příspěvků: 722
  • Karma: +51/-9
    • Zobrazit profil
    • Chalupa Himmelreich
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #16 kdy: 20 Listopad 2008, 17:50:29 »
Prosím o radu. V 8.04 proběhla kompilace, ale na konci o vyhodilo že users plugins Failed. Po spuštění se mi nezobrazují rámy oken. Zkusil sem i update Compizu, ale pořád ta samá chyba
Ubuntu 16.04
Kdesu není první slovo Hanáckeho opilce po probuzení, ale příkaz systému.
Ubuntu - nejlepší pařba od Diabla II. ;D

Roman Vacho

  • Člen placené komunitní podpory
  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5591
  • Karma: +218/-47
  • Jeden vykope studnu, tisíce z ní pijí tisíc let.
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #17 kdy: 23 Prosinec 2008, 04:18:50 »
Defaultně po kompilaci Compiz nemá zatržený zobrazení rámy oken :)
Vyřešená vlákna je vhodné uzavřít dodáním znaků "[vyřešeno]" do názvu téma v editaci prvního příspěvku.

henrichg

  • Člen
  • **
  • Příspěvků: 401
  • Karma: +34/-3
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #18 kdy: 23 Prosinec 2008, 11:33:30 »
Prosím o radu. V 8.04 proběhla kompilace, ale na konci o vyhodilo že users plugins Failed. Po spuštění se mi nezobrazují rámy oken. Zkusil sem i update Compizu, ale pořád ta samá chyba

S users pluginmi byva problem. Stava sa, ze sa daktory zrazu neda skompilovat. Kedysi som to riesil tak, ze som v skripte zapoznamkoval kompilaciu pluginov, ktore robia problem a spustil instalaciu znova. Dost blbe riesenie. Az raz som sa nastval a v Intrepid verzii skriptu som to spravil tak, ze  users plugins nezastavia skript ak vznikne chyba. Proste sa len chybny plugin nenainstaluje.
Mozem sa na to kunut, ked budem doma a upravit to tak aj v hardy verzii.
Ubuntu 11.04 + Gnome Shell z Gnome 3 PPA ;-)

Roman Vacho

  • Člen placené komunitní podpory
  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5591
  • Karma: +218/-47
  • Jeden vykope studnu, tisíce z ní pijí tisíc let.
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #19 kdy: 23 Prosinec 2008, 13:39:36 »
 * Installed Required Dependencies                               [OK]
 * Installed Compiz Dependencies                                 [OK]
 * Installed Compiz Core                                    [Error 1]
 * Installed Option Code Generator                               [OK]
 * Installed Settings Library for Plugins                   [Error 1]
 * Installed CompizConfig-Python                            [Error 1]
 * Installed Settings Manager                                    [OK]
 * Installed Main Plugins                                   [Error 1]
 * Installed Extra Plugins                                  [Error 1]
 * Installed Unsupported Plugins                            [Error 1]
 * Installed Users Plugins                                  [Error 2]
 * Installed Emerald                                        [Error 1]
 * Installed Emerald Themes                                      [OK]
 * Installed Fusion-Icon                                         [OK]
« Poslední změna: 23 Prosinec 2008, 13:51:34 od Rovano »
Vyřešená vlákna je vhodné uzavřít dodáním znaků "[vyřešeno]" do názvu téma v editaci prvního příspěvku.

henrichg

  • Člen
  • **
  • Příspěvků: 401
  • Karma: +34/-3
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #20 kdy: 23 Prosinec 2008, 18:25:04 »
* Installed Required Dependencies                               [OK]
 * Installed Compiz Dependencies                                 [OK]
 * Installed Compiz Core                                    [Error 1]
 * Installed Option Code Generator                               [OK]
 * Installed Settings Library for Plugins                   [Error 1]
 * Installed CompizConfig-Python                            [Error 1]
 * Installed Settings Manager                                    [OK]
 * Installed Main Plugins                                   [Error 1]
 * Installed Extra Plugins                                  [Error 1]
 * Installed Unsupported Plugins                            [Error 1]
 * Installed Users Plugins                                  [Error 2]
 * Installed Emerald                                        [Error 1]
 * Installed Emerald Themes                                      [OK]
 * Installed Fusion-Icon                                         [OK]


 ??? Skus mi sem dat vypis z terminalu, hned po tom, ako ti vypise, ze Compiz Core failed. Tento vyseldny sumar mi nic nenapovie.
Ubuntu 11.04 + Gnome Shell z Gnome 3 PPA ;-)

ETNyx

  • Člen
  • **
  • Příspěvků: 425
  • Karma: +37/-2
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #21 kdy: 19 Leden 2009, 22:51:58 »
* Installed Required Dependencies                               [OK]
 * Installed Compiz Dependencies                                 [OK]
 * Installed Compiz Core                                    [Error 1]
 * Installed Option Code Generator                               [OK]
 * Installed Settings Library for Plugins                   [Error 1]
 * Installed CompizConfig-Python                            [Error 1]
 * Installed Settings Manager                                    [OK]
 * Installed Main Plugins                                   [Error 1]
 * Installed Extra Plugins                                  [Error 1]
 * Installed Unsupported Plugins                            [Error 1]
 * Installed Users Plugins                                  [Error 2]
 * Installed Emerald                                        [Error 1]
 * Installed Emerald Themes                                      [OK]
 * Installed Fusion-Icon                                         [OK]


Zdravím, měl jsem úplně stejnou serii chyb jako máš ty :-), tak sem si řekl že pošlu ty vypisy chyb tak sem místo full instalce spouštěl každou zvlášť a instalace proběhla vpořádku :-D tak to zkus taky třeba to projde :-)

Ale mam jinej problém, instaloval jsem kolegovy ubuntu a hrozně chtěl ty pěkný gradický efekty :-D, ale zapnutý compiz "smaže" menu (soubor, úpravy,....) a vypadá to na Java aplikace, zatím jsem jej pozoroval v OpemOffice.org a v Amarok 1.4 (to si nejsem jist jestli je Java apliakce), každopádně v NetBeans 6.5 tento problém není, ono vzdy jen probliknou. V návodu jsou popsány opravy Javy (sekce poinstalačni kroky) avšak ty nepomohly. V diskuzi jsem našel, že nové ovladače to mohou vyřešit 180.06 avšak na PC je G MX4000 a verze ovladačů je 96.43.0x (teď si nejsem jist, na stránkách nvidia jsou pro tuto grafiku nejnovější 96.43.07), předpokládám, že se již ovladače nevyvýjí, nevíte jak to spravit?

edit: jop ještě mě napadlo, při instalaci je možnost (17) instalovat nějaké balíky pro nVidii, ale když zadám 17 tak se nic nestane (třeba by to pomohlo), je ot chyba nebo to nejde schválně?
« Poslední změna: 19 Leden 2009, 22:54:19 od ETNyx »
jabber: etnyx@jabbim.cz

azzan

  • Návštěvník
  • *
  • Příspěvků: 46
  • Karma: +3/-11
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #22 kdy: 08 Březen 2009, 13:38:32 »
Mne sa to tiež nedarí nainstalovat

Kód: [Vybrat]
Installing Compiz Fusion 's dependencies...
Načítavajú sa zoznamy balíkov... Hotovo
Vytvára sa strom závislostí             
Reading state information... Hotovo
subversion je už najnovšej verzie.
git-core je už najnovšej verzie.
automake je už najnovšej verzie.
intltool je už najnovšej verzie.
libtool je už najnovšej verzie.
python-pyrex je už najnovšej verzie.
build-essential je už najnovšej verzie.
dpkg-dev je už najnovšej verzie.
dpkg-dev ne nastavený na manuálnu inštaláciu.
g++ je už najnovšej verzie.
g++ ne nastavený na manuálnu inštaláciu.
g++-4.2 je už najnovšej verzie.
g++-4.2 ne nastavený na manuálnu inštaláciu.
libavahi-compat-libdnssd1 je už najnovšej verzie.
libpcre3 je už najnovšej verzie.
libstdc++6-4.2-dev je už najnovšej verzie.
libstdc++6-4.2-dev ne nastavený na manuálnu inštaláciu.
xsltproc je už najnovšej verzie.
libxss1 je už najnovšej verzie.
coreutils je už najnovšej verzie.
librsvg2-common je už najnovšej verzie.
libnotify1 je už najnovšej verzie.
libx11-xcb1 je už najnovšej verzie.
mesa-utils je už najnovšej verzie.
E: Balík libprotobuf0 sa nedá nájsť
[Failed] The previous process exited with error 100

Roman Vacho

  • Člen placené komunitní podpory
  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5591
  • Karma: +218/-47
  • Jeden vykope studnu, tisíce z ní pijí tisíc let.
    • Zobrazit profil
Re: Compiz a Compiz-fusion kompilace a instalace z git (Hardy - 8.04)
« Odpověď #23 kdy: 08 Březen 2009, 17:41:05 »
Až budu mít před instalací nového systému, tak to zkusím :)
Vyřešená vlákna je vhodné uzavřít dodáním znaků "[vyřešeno]" do názvu téma v editaci prvního příspěvku.