Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Jak zabránit aktualizaci balíčku  (Přečteno 1535 krát)

Tomáš Pikálek

  • Závislák
  • ****
  • Příspěvků: 1859
    • Zobrazit profil
    • Tomáš Pikálek
Jak zabránit aktualizaci balíčku
« kdy: 24 Července 2006, 11:51:12 »
Kvůli problémům se starší verzí Kopete obsaženou v repozitářích jsem si stáhl novější verzi jako deb balíček. Když ale nyní dám "apt-get upgrade", chce to aktualizovat i Kopete, i když mám novější verzi (je nějak jinak číslovaná). Proto musím nyní aktualizace provádět přes Adept a vždy aktualizaci kopete manuálně vypnout, což se mě zdá velmi nepraktické.
Jde nějak zabránit aktualizaci jednoho balíčku?

Milhouse

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5722
    • Zobrazit profil
Jak zabránit aktualizaci balíčku
« Odpověď #1 kdy: 24 Července 2006, 14:12:06 »
V Synapticu je funkce "zamknout verzy", nebo tak nejak. Najdes to v menu, kdyz budes najety primo na tom konkretnim balicku, ktery chces zmenit.
Jeste zkus menu "Uprednostnit jinou verzy".

N. Á. V. O. D. Y.
 "...naše práce není vidět, ale je důležitá!"

Tomáš Pikálek

  • Závislák
  • ****
  • Příspěvků: 1859
    • Zobrazit profil
    • Tomáš Pikálek
Jak zabránit aktualizaci balíčku
« Odpověď #2 kdy: 24 Července 2006, 14:57:55 »
V Synapticu to zamknout můžu, ale já raději používám apt-get a v něm se to nezamkne.

MarrLiss

  • Stálý člen
  • ***
  • Příspěvků: 901
    • Zobrazit profil
Jak zabránit aktualizaci balíčku
« Odpověď #3 kdy: 24 Července 2006, 15:07:28 »
Resenim by mohlo byt pouzivat misto apt-get aptitude, ktera ma prikaz hold, ktery by mel k tomuto slouzit.
Prestigio Nobile 1590: P-M 740, 1 GB RAM, NV 6600
Ubuntu FF

Petr Tomeš

  • Závislák
  • ****
  • Příspěvků: 1582
    • Zobrazit profil
    • http://www.phil.muni.cz/~ptomes/
Jak zabránit aktualizaci balíčku
« Odpověď #4 kdy: 24 Července 2006, 18:32:19 »
Řešením by mohl být také přechod na vyšší verzi KDE (z 3.5.2 na 3.5.3), kde by mohla být zmiňovaná chyba v Kopete: http://kubuntu.org/announcements/kde-353.php

Tomáš Pikálek

  • Závislák
  • ****
  • Příspěvků: 1859
    • Zobrazit profil
    • Tomáš Pikálek
Jak zabránit aktualizaci balíčku
« Odpověď #5 kdy: 25 Července 2006, 08:24:13 »
KDE 3.5.3 mám.
http://bugs.kde.org/show_bug.cgi?id=130630 - tam je ten bug popsaný a je tam i odkaz na stažení deb balíčku, který jsem si nainstaloval.

zigi

  • Člen
  • **
  • Příspěvků: 389
    • Zobrazit profil
Jak zabránit aktualizaci balíčku
« Odpověď #6 kdy: 02 Srpna 2006, 00:16:24 »
hi,
 v adeptu jsem nic podobneho nenasel, ale v dokumentaci k apt* sem nasel toto:

Citace
4.9 Keeping packages on hold
 As we saw on the previous section, aptitude will automatically mark packages for upgrade. If you want to keep the current version installed, though, you can ask it to put the package on hold.
 This is achieved by pressing the "=" key. Packages being held from upgrades will look like this:
     ih    alien                                                 8.41      8.41

 In this example, the alien package will be kept at version 8.41 even if a new version appears on an APT source -- notice the h character at the left. To have it upgraded/upgradable again just mark it for installation.
 You can put packages on hold using the command line interface, too, by running:
     # aptitude hold package1 package2 ...
..:: be free - use kubuntu ::..

zigi

  • Člen
  • **
  • Příspěvků: 389
    • Zobrazit profil
Jak zabránit aktualizaci balíčku
« Odpověď #7 kdy: 02 Srpna 2006, 00:17:23 »
hi,
 v adeptu jsem nic podobneho nenasel, ale v dokumentaci k apt* sem nasel toto:

Citace
4.9 Keeping packages on hold
 As we saw on the previous section, aptitude will automatically mark packages for upgrade. If you want to keep the current version installed, though, you can ask it to put the package on hold.
 This is achieved by pressing the "=" key. Packages being held from upgrades will look like this:
     ih    alien                                                 8.41      8.41

 In this example, the alien package will be kept at version 8.41 even if a new version appears on an APT source -- notice the h character at the left. To have it upgraded/upgradable again just mark it for installation.
 You can put packages on hold using the command line interface, too, by running:
     # aptitude hold package1 package2 ...
..:: be free - use kubuntu ::..

 


Provoz zaštiťuje spolek OpenAlt.