Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Jak nainstalovat MiniLainx? [skoro vyřešeno]  (Přečteno 5603 krát)

Tagy

  • Člen
  • **
  • Příspěvků: 189
    • Zobrazit profil
Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #25 kdy: 09 Října 2008, 14:25:04 »
Takže vše odznova, jsem po přeinstalaci celeho OS
Tedy instaluji libgdiplus-2.0:
Postupně to chce po mně tyto balíčky:
glib-2.2.3
gettext-0.16
zlib-1.2.3
libpng-1.2.32

U každého postupně dávám:
./configure
make
sudo make install
-> žádný error tam nevidím
Pokud už mám vše ok a jdu na balíček libgdiplus-2.0
Tak vyleze tahle hláška:
checking for libpng12... yes
checking for LIBEXIF... no
./configure: line 23277: test: too many arguments
configure: error: "Failed to compile with X11/Xlib.h include.  You must fix your compiler paths"

"Uff ty závislosti opravdu nemám rád..."
Nedá se někde sehnat *.deb balíček pro MONO? Nebo nedá se upravit instalační balíček pro jiné distro?
Takhle to instalovat je HRŮZA

Martin - ViPEr*CZ*

Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #26 kdy: 10 Října 2008, 12:58:36 »
Nejspíš chybí LIBEXIF a nebo Xlib development knihovny.

Jo jo je to děsný mít ty závyslosti. Hlavně když jich je třeba 10 a hledat co kde a jak. A další balík může závyset na dalších 10 a pak je to jak atomovka  :o
Deb balíček musíte hledat ;) Jinak nějak šlo rpm upravovat, ale není to 100% vždy funkční. (na wiki je tuším návod)
Open source is gold way... Mint 17.2, Debian 8.1 Jessie| Ubuntu Wiki (návody) | Google vyhledávač | Qt4 návody

Teyras

  • Člen
  • **
  • Příspěvků: 227
  • $life = "fight";
    • Zobrazit profil
Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #27 kdy: 10 Října 2008, 16:13:10 »
Nejspíš chybí LIBEXIF a nebo Xlib development knihovny.

Jo jo je to děsný mít ty závyslosti. Hlavně když jich je třeba 10 a hledat co kde a jak. A další balík může závyset na dalších 10 a pak je to jak atomovka  :o
Deb balíček musíte hledat ;) Jinak nějak šlo rpm upravovat, ale není to 100% vždy funkční. (na wiki je tuším návod)
*.rpm do *.deb jde převést programem Alien, je v repozitářích....
AMD Athlon X2 4400+, 2GB DDR2, Asus GeForce EN8600GT 512MB DDR3, Seagate Barracuda 7200.10 160GB SATAII, Seagate Barracuda 7200.10 120GB IDE
Arch Linux, KDEmod 4.2

 


Provoz zaštiťuje spolek OpenAlt.