Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Jak nainstalovat MiniLainx? [skoro vyřešeno]  (Přečteno 5605 krát)

Tagy

  • Člen
  • **
  • Příspěvků: 189
    • Zobrazit profil
Jak nainstalovat MiniLainx? [skoro vyřešeno]
« kdy: 05 Října 2008, 19:37:11 »
Ahoj všem jak lze nainstalovat tento http://ithil.ujep.cz/nfiser/index.php/download/2-software/5-minilainx program?
Stáhnul jsem si "MiniLainx-0.50.3-Ubuntu.bz2"
Přidal přes správce balíků "qdevelop"
Ale dále netuším, četl jsem něco na wiki ohledně instalace ze zdrojových kódů, ale nedaří se.
« Poslední změna: 06 Října 2008, 18:32:16 od Tagy »

Martin - ViPEr*CZ*

Re: Jak nainstalovat MiniLainx?
« Odpověď #1 kdy: 05 Října 2008, 19:45:02 »
No a co to dělá, když instalujete (kompilujete) ze zdrojů?
Open source is gold way... Mint 17.2, Debian 8.1 Jessie| Ubuntu Wiki (návody) | Google vyhledávač | Qt4 návody

Tomáš Pikálek

  • Závislák
  • ****
  • Příspěvků: 1859
    • Zobrazit profil
    • Tomáš Pikálek
Re: Jak nainstalovat MiniLainx?
« Odpověď #2 kdy: 05 Října 2008, 19:46:57 »
Stačí stáhnout tu verzi pro Ubuntu, rozbalit, přidat rozbalenému souboru Spustitelný příznak a spustit.
Bohužel to ale chce nějaké knihovny:
Kód: [Vybrat]
./MiniLainx-0.50.3-Ubuntu: error while loading shared libraries: libQt3Support.so.4: cannot open shared object file: No such file or directoryUrčitě ale někde najdete, co tomu přesně chybí.
Ale možná vám to pojede, já mám 64bitový systém.

Martin - ViPEr*CZ*

Re: Jak nainstalovat MiniLainx?
« Odpověď #3 kdy: 05 Října 2008, 19:49:11 »
Stačí stáhnout tu verzi pro Ubuntu, rozbalit, přidat rozbalenému souboru Spustitelný příznak a spustit.
Bohužel to ale chce nějaké knihovny:
Kód: [Vybrat]
./MiniLainx-0.50.3-Ubuntu: error while loading shared libraries: libQt3Support.so.4: cannot open shared object file: No such file or directoryUrčitě ale někde najdete, co tomu přesně chybí.
Ale možná vám to pojede, já mám 64bitový systém.
Určitě to chce knihovny pro Qt4 jak uvádí autor na stránkách ;) Bude to nejspíše problém kompilace i samotného spouštění ;)
Open source is gold way... Mint 17.2, Debian 8.1 Jessie| Ubuntu Wiki (návody) | Google vyhledávač | Qt4 návody

Tagy

  • Člen
  • **
  • Příspěvků: 189
    • Zobrazit profil
Re: Jak nainstalovat MiniLainx?
« Odpověď #4 kdy: 05 Října 2008, 20:56:01 »
Díky pánové!
Tedy, QT4 knihovny jsem nainstalovány měl, stáhnul, rozbalil, nastavil "spustitelný příznak"
Spustil terminál: vlezl přímo do složky a napsal:
./MiniLainx-0.50.3-Ubuntu
Spustí se program
-----------------------
Mám další otázky :-)
Zkoušel jsem to zpusit i takhle: ;D
Plocha/12/MiniLainx-0.50.3-Ubuntu
Funguje  :D
Udělal jsem si spuštěč, taky funguje.
Ještě mě napadá, lze nějakým jednoduchým způsobem nechat dopisovat v přík. řádku názvy souborů?
Např.: napsat jen Mini (a zbytek se doplní) ať to nemusím furt psát (zkoušel jsem TAB ale ten nic..., šipka "nahoru" funguje jen když to je v paměti...)

Martin - ViPEr*CZ*

Re: Jak nainstalovat MiniLainx?
« Odpověď #5 kdy: 05 Října 2008, 21:07:49 »
TAB funguje normálně v terminálu....

PS: pozor na velikosti písmen!
Open source is gold way... Mint 17.2, Debian 8.1 Jessie| Ubuntu Wiki (návody) | Google vyhledávač | Qt4 návody

Tagy

  • Člen
  • **
  • Příspěvků: 189
    • Zobrazit profil
Re: Jak nainstalovat MiniLainx?
« Odpověď #6 kdy: 06 Října 2008, 18:10:21 »
Díky, funguje  :)

Tagy

  • Člen
  • **
  • Příspěvků: 189
    • Zobrazit profil
Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #7 kdy: 06 Října 2008, 18:33:54 »
Ještě se objevila jedna věc:
Na pc vše funguje tak jak má.
Na laptopu jsem akorát přidával balíček monodevelop
Píše to:
tagy@tagy-laptop:~/Install$ ./MiniLainx-0.50.3-Ubuntu
./MiniLainx-0.50.3-Ubuntu: error while loading shared libraries: libQt3Support.so.4: cannot open shared object file: No such file or directory
« Poslední změna: 06 Října 2008, 18:44:12 od Tagy »

Martin - ViPEr*CZ*

Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #8 kdy: 06 Října 2008, 18:41:35 »
No chybí tam ta knihovna pro Qt rozhraní ;)
Open source is gold way... Mint 17.2, Debian 8.1 Jessie| Ubuntu Wiki (návody) | Google vyhledávač | Qt4 návody

Tagy

  • Člen
  • **
  • Příspěvků: 189
    • Zobrazit profil
Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #9 kdy: 06 Října 2008, 18:46:10 »
No chybí tam ta knihovna pro Qt rozhraní ;)
To jsem si přeložil také, ale kde ji najít, popř. pod jakým názvem?
Samozřejmě jsem si zadával: "libQt3Support.so.4" to nic nenajde, pokud dám "libQt3" tak toho najde víc, ale kterou?

Martin - ViPEr*CZ*

Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #10 kdy: 06 Října 2008, 18:53:33 »
Teď jsem nepochopil kde hledáte? Stačí nainstalovat z repozitářů a je to. Popřípadě pokud se nepřipojíte s laptopem, tak si to stáhněte z packages.ubuntu.com a nainstalujte pak jen deb balíček ;)
Open source is gold way... Mint 17.2, Debian 8.1 Jessie| Ubuntu Wiki (návody) | Google vyhledávač | Qt4 návody

Tagy

  • Člen
  • **
  • Příspěvků: 189
    • Zobrazit profil
Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #11 kdy: 06 Října 2008, 19:09:44 »
Vím že z repozitářů, ale jaký balíček
Hleda jsem tedy i na: packages.ubuntu.com
Výpis:
Sorry, your search gave no results
Jinak jsem hledal přes "Správce balíků Synaptic"
Pokud zadám jen "libQt3", tak se toho najde víc, ale který z balíčku vybrat?
http://translate.google.cz/translate?u=http%3A%2F%2Fpackages.ubuntu.com%2Fsearch%3Fsuite%3Dhardy%26section%3Dall%26arch%3Dany%26searchon%3Dnames%26keywords%3DlibQt3&hl=cs&ie=UTF-8&sl=en&tl=cs
---------------------------------------------
EDIT: porovnával jsem soubory v PC a v laptopu, do obou Synapticů jsem zadal "libQt3" oba mi našli že mají nainstalovány: "libqt3-mt"
« Poslední změna: 06 Října 2008, 19:14:44 od Tagy »

Martin - ViPEr*CZ*

Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #12 kdy: 06 Října 2008, 19:16:38 »
Tudle bych zkusil:

libqt4-gui

 ;)
Open source is gold way... Mint 17.2, Debian 8.1 Jessie| Ubuntu Wiki (návody) | Google vyhledávač | Qt4 návody

Tagy

  • Člen
  • **
  • Příspěvků: 189
    • Zobrazit profil
Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #13 kdy: 06 Října 2008, 19:30:13 »
Našel, byla již nainstalována, přeinstaloval.
To samé, poklikám-li na spouštěč -> nic, spustím-li v příkazové řádce, ta samá hláška jako předtím (tagy@tagy-laptop:~/Install$ ./MiniLainx-0.50.3-Ubuntu
./MiniLainx-0.50.3-Ubuntu: error while loading shared libraries: libQt3Support.so.4: cannot open shared object file: No such file or directory
)

Podotýkám, jediné co se liší pc/laptop -> na laptop jsem instaloval "monodevelop" (odinstalace nepomohla/nyní je zas nainstalovaný)
Koukal jsem ten "monodevelop" si žádné další balíčky nebere....

Martin - ViPEr*CZ*

Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #14 kdy: 06 Října 2008, 19:32:52 »
Tak chybí todle:

http://packages.ubuntu.com/hardy/libqt4-qt3support

asi 5. odkaz na google ;)
Open source is gold way... Mint 17.2, Debian 8.1 Jessie| Ubuntu Wiki (návody) | Google vyhledávač | Qt4 návody

Tagy

  • Člen
  • **
  • Příspěvků: 189
    • Zobrazit profil
Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #15 kdy: 06 Října 2008, 20:00:57 »
SUPR  :o maká to.
Mohu se zeptat co jste zadal do google? :-), /ať se příště nemusím ptát.
Přijde mi zvláštní proč to na pc funguje a na laptopu jen v případě pokud doinstaluji zpětnou podporu pro Qt3 (počítal bych s tím, že tam zpětná vazba bude nainstalována automaticky...)
Že by mododevelop něco přenastavilo (netuším vůbec jak to zjistit...)

Ještě se rovnou zeptám ať nemusím zakládat další dotaz:
Pokud chci nainstalovat Mono, (http://wiki.ubuntu.cz/V%C3%BDvoj%20v%20Mono)
Pokud zadám řádek:
sudo apt-get install mono mono-mcs libgtk-cil libgtksourceview-cil libgecko-cil monodevelop monodoc
Resp.:
tagy@tagy-laptop:~$ sudo apt-get install mono
Čtu seznamy balíků... Hotovo
Vytvářím strom závislostí       
Čtení stavových informací... Hotovo
Balík mono není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje
E: Balík mono nemá kandidáta pro instalaci
tagy@tagy-laptop:~$

Jak tedy nainstalovat mono? Sice se nějaký balík na něj odkazuje (jaký nevím) a v Synaptic mi na dotaz "mono" najde nepřeberné množství možností...
----------------------------------------------------
EDIT:
Zkusil jsem "monodevelop" doinstalovat i na PC a vše maká aniž bych musel nějakou knihovnu doinstalovávat, tak buď je to mezi židlí a klávesnicí a nebo...  :D
« Poslední změna: 06 Října 2008, 20:08:55 od Tagy »

Martin - ViPEr*CZ*

Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #16 kdy: 06 Října 2008, 20:09:35 »
No spíš jste něco na PC doinstaloval co si to vzalo sebou a na laptopu to chybí.

Do google jsem zadal tu knihovnu co to psalo, že chybí.

No zkuste Add/Programs (Přidat programy) jestli tam není přímo balík Mono. Jinak z ofiko stránek Mono si stáhnout balík ;)
Open source is gold way... Mint 17.2, Debian 8.1 Jessie| Ubuntu Wiki (návody) | Google vyhledávač | Qt4 návody

Tagy

  • Člen
  • **
  • Příspěvků: 189
    • Zobrazit profil
Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #17 kdy: 06 Října 2008, 20:15:56 »
Pokud stáhnu program:
http://www.go-mono.com/mono-downloads/download.html
Jaké distro zvolit, Debian/Ubuntu tam není.
Co si stáhnout rovnou sources?
http://ftp.novell.com/pub/mono/sources-stable/
Může být? (ještě jsem nic nekompiloval -> zdárně jsem se tomu vyhýbal)

Martin - ViPEr*CZ*

Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #18 kdy: 06 Října 2008, 20:26:47 »
Compile libgdiplus to support System.Drawing:

    $ tar xzf libgdiplus-2.0.tar.gz
    $ cd libgdiplus-2.0
    $ ./configure
    $ make
    $ make install

Then compile Mono itself:

    $ tar xzf mono-2.0.tar.gz
    $ cd mono-2.0
    $ ./configure
    $ make
    $ make install

Opsáno z webu Mono ;)
Open source is gold way... Mint 17.2, Debian 8.1 Jessie| Ubuntu Wiki (návody) | Google vyhledávač | Qt4 návody

Tagy

  • Člen
  • **
  • Příspěvků: 189
    • Zobrazit profil
Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #19 kdy: 07 Října 2008, 12:00:28 »
Compile libgdiplus to support System.Drawing:

    $ tar xzf libgdiplus-2.0.tar.gz
    $ cd libgdiplus-2.0
    $ ./configure
    $ make
    $ make install

U tohodle to chtělo glib 2.2.3
To zas vyskočilo hláškou že to chce: gettext-0.17
Tedy:
./configure gettext-0.17
-> vyskočí na mě hláška:

checking how to run the C++ preprocessor... /lib/cpp
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.

- kde najdu config.log?
Co tomu chybí? :-)

Martin - ViPEr*CZ*

Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #20 kdy: 07 Října 2008, 16:55:52 »
Máte nainstalováný kompilátor?

sudo apt-get install build-essential
Open source is gold way... Mint 17.2, Debian 8.1 Jessie| Ubuntu Wiki (návody) | Google vyhledávač | Qt4 návody

Tagy

  • Člen
  • **
  • Příspěvků: 189
    • Zobrazit profil
Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #21 kdy: 07 Října 2008, 20:44:21 »
Juj děkuji :-) (sypu si popel na hlavu)
viz: http://wiki.ubuntu.cz/Instalace%20program%C5%AF/Zdrojov%C3%A9%20k%C3%B3dy?action=show&redirect=Kompilace

Ještě dodám, že příkaz "make install" jsem musel dávat jako root (sudo make install)
Asi to tam je nainstalované, žádný error jsem nezpozoroval.
Jak vlastně poznám že se Mono korektně nainstalovalo? :-)

Martin - ViPEr*CZ*

Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #22 kdy: 07 Října 2008, 20:48:53 »
No pozná se to tak, že příkaz make nevykazuje žádnou chybu. A taky by to mělo jít spustit :D nejspíše zadáním mono do konzole.

PS: no každej zdroják nese nápovědu pro kompilaci, ale vždy autor udává make install... bohužel to na ubuntu a debianu jde jen se sudo. Takže je asi možné že na jiných systémech to jde jak udává autor. Nezkoušel jsem ;)
Open source is gold way... Mint 17.2, Debian 8.1 Jessie| Ubuntu Wiki (návody) | Google vyhledávač | Qt4 návody

Tagy

  • Člen
  • **
  • Příspěvků: 189
    • Zobrazit profil
Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #23 kdy: 07 Října 2008, 23:09:08 »
Tedy asi funguje, že:
tagy@tagy-laptop:~$ mono
Usage is: mono [options] program [program-options]

Development:
    --aot                  Compiles the assembly to native code
    --debug                Enable debugging support
    --profile[=profiler]   Runs in profiling mode with the specified profiler module
    --trace[=EXPR]         Enable tracing, use --help-trace for details
    --help-devel           Shows more options available to developers

Runtime:
    --config FILE          Loads FILE as the Mono config
    --verbose, -v          Increases the verbosity level
    --help, -h             Show usage information
    --version, -V          Show version information
    --runtime=VERSION      Use the VERSION runtime, instead of autodetecting
    --optimize=OPT         Turns on or off a specific optimization
                           Use --list-opt to get a list of optimizations
    --security[=mode]      Turns on the unsupported security manager (off by default)
                           mode is one of cas or core-clr
----------------------------------------------------------------------------------------------------------------------
EDIT:
možná tyhle linky někoho zaujmou
http://www.abclinuxu.cz/clanky/navody/nebojime-se-kompilace-i-teorie
http://www.abclinuxu.cz/clanky/navody/nebojime-se-kompilace-ii-praxe
http://www.abclinuxu.cz/clanky/navody/nebojime-se-kompilace-iii-ladime
« Poslední změna: 07 Října 2008, 23:10:51 od Tagy »

Martin - ViPEr*CZ*

Re: Jak nainstalovat MiniLainx? [skoro vyřešeno]
« Odpověď #24 kdy: 08 Října 2008, 14:40:53 »
Jj, ale mělo by to mít i GUI prostředí. ;)
Open source is gold way... Mint 17.2, Debian 8.1 Jessie| Ubuntu Wiki (návody) | Google vyhledávač | Qt4 návody

 


Provoz zaštiťuje spolek OpenAlt.