Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Vyskytla se chyba  (Přečteno 1414 krát)

zuzanka

  • Návštěvník
  • *
  • Příspěvků: 27
    • Zobrazit profil
Vyskytla se chyba
« kdy: 30 Ledna 2009, 18:05:38 »
Nejdou stáhnout aktualizace, píše mi to
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.
Napíšu-li do terminálu dpkg --configure -a, píše, že požadovaná operace vyžaduje superuživatelská práva.
Zavírají se mi okna (s Firefoxem atd.), některé aplikace vůbec nejedou (přidat,odstranit, open office atd.)
Mám Ubuntu 8.10.
Prosím pomozte, jsem začátečník.
Děkuji

Milhouse

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5722
    • Zobrazit profil
Re: Vyskytla se chyba
« Odpověď #1 kdy: 30 Ledna 2009, 18:08:20 »
Před příkaz napište sudo

N. Á. V. O. D. Y.
 "...naše práce není vidět, ale je důležitá!"

zuzanka

  • Návštěvník
  • *
  • Příspěvků: 27
    • Zobrazit profil
Re: Vyskytla se chyba
« Odpověď #2 kdy: 30 Ledna 2009, 18:20:56 »
zkusila jsem to sudo a hodilo mi to hlášku segmentation fault a stále nic nejde

zuzanka

  • Návštěvník
  • *
  • Příspěvků: 27
    • Zobrazit profil
Re: Vyskytla se chyba
« Odpověď #3 kdy: 30 Ledna 2009, 18:34:51 »
Navíc mi to v terminálu píše:
bash: /etc/bash_completion: line 3540: syntax error near unexpected token `;'
bash: /etc/bash_completion: line 3540: `            ;3'

arrange

  • Závislák
  • ****
  • Příspěvků: 4031
  • "jdu s hlavou vztyčenou..."
    • Zobrazit profil
Re: Vyskytla se chyba
« Odpověď #4 kdy: 30 Ledna 2009, 20:12:17 »
Ta chyba v bash_completion by neměl být problém... Zkus přemazat paměť apt-getu a aktualizovat znova. Postup (v Terminálu; bez těch poznámek za #)
Kód: [Vybrat]
sudo -i  #staň se rootem
cd /var/cache/apt
mv pkgcache.bin pkgcache.bin_zaloha
mv srcpkgcache.bin srcpkgcache.bin_zaloha #zálohovat ty dva soubory pro jistotu
Pak zkusit znovu aktualizovat. Pokud bude zase chyba, snaž se tu zkopírovat celý výstup z té chyby, příp. i výstup příkazu dpkg --configure -a.
« Poslední změna: 30 Ledna 2009, 20:19:23 od arrange »
http://www.openstreetmap.org - mapy celého světa "wiki style"

zuzanka

  • Návštěvník
  • *
  • Příspěvků: 27
    • Zobrazit profil
Re: Vyskytla se chyba
« Odpověď #5 kdy: 30 Ledna 2009, 20:39:03 »
ted to pise:
E: /var/cache/apt/archives/linux-headers-2.6.27-11-generic_2.6.27-11.27_i386.deb: poškozený systémový tar soubor - poškozený balík
E: /var/cache/apt/archives/linux-image-2.6.27-11-generic_2.6.27-11.27_i386.deb: podproces pre-installation script byl zabit signálem (Segmentation fault)

arrange

  • Závislák
  • ****
  • Příspěvků: 4031
  • "jdu s hlavou vztyčenou..."
    • Zobrazit profil
Re: Vyskytla se chyba
« Odpověď #6 kdy: 30 Ledna 2009, 21:51:48 »
zkus v Terminálu
Kód: [Vybrat]
sudo apt-get --reinstall install linux-headers-2.6.27-11 přeinstalovat ten vadný balík
http://www.openstreetmap.org - mapy celého světa "wiki style"

 


Provoz zaštiťuje spolek OpenAlt.