Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Pokud máte starší AMD Radeon(např. 4xxx series) dejte pozor při aktualizaci  (Přečteno 1920 krát)

Nemo7

  • Aktivní člen
  • *
  • Příspěvků: 160
Pokud máte starší AMD Radeon, např. 4xxx series apod, dejte pozor při aktualizaci - do Ubuntu precise-updates vložili nový driver 13.10, který už nepodporuje starší karty. Tady se o tom na Rootu baví :

http://forum.root.cz/index.php?topic=8407.msg86127;topicseen#new

Také jsem to zažil na Ubuntu 12.04 a hrozně jsem se divil, proč mi nefunguje zobrazení...  :) Navíc jsem nedokázal původní driver vrátit. Vyřešil jsem to až instalací legacy driverů z PPA od Tomasze Makarewicze.

http://www.ubuntuvibes.com/2013/01/how-to-install-new-amd-catalyst-131.html
https://launchpad.net/~makson96/+archive/fglrx

A volná diskuze může být o tom, PROČ SAKRA ROZBÍJÍ TAK BRZO KOMPATIBILITU V LTS ! ;)
« Poslední změna: 08 Února 2014, 11:47:59 od Nemo7 »

sabraq

  • Závislák
  • ***
  • Příspěvků: 3412
  • Bootloader-není téma k hovoru,ani zbytný prostor
Canonical těžko ví něco o tvém Radeonu, ten ti nic nerozbíjí. Musíš plakat na tom správném hrobě, tedy u AMD, proč podporují své karty jen po určitou dobu a potom šlus. Je to asi trochu daň za levnější hw oproti Nvidia - tam je tuším legacy driver až od gf 6xxx, což už je fakt hodně stará řada.
PP v kolečku - není licence,pouze upozornění na reklamu
"Dress code" - oblečení podle předpisu(ne kódované oblečení)
CC v kolečku - je licence,značí,že se někdo nesmírně snaží

Nemo7

  • Aktivní člen
  • *
  • Příspěvků: 160
Canonical těžko ví něco o tvém Radeonu, ten ti nic nerozbíjí.

Repo precise-updates nespravuje Canonical? Myslel jsem, že ano. Pokud ne, tak se Canonicalu omlouvám. Já byl naprosto spokojený s původním driverem. Fungoval.  ;)

Precise-updates - Updates to official packages.
http://ubuntuguide.org/wiki/Ubuntu_Precise_Repositories
« Poslední změna: 08 Února 2014, 14:21:55 od Nemo7 »

sabraq

  • Závislák
  • ***
  • Příspěvků: 3412
  • Bootloader-není téma k hovoru,ani zbytný prostor
Možná se ti uleví, když budeš ironický, budiž, ale Canonical v tomto případě za nic nemůže, ať to chceš pochopit, nebo ne. Tahle situace už tady jednou byla, prostě canonical udržuje ovladače aktuální, které se vážou na verzi xorgu a nemůže za to, že v amd mají takovou politiku podpory svých karet, jakou mají. Ono se to nezdá, ale HD 4xxx už tady bude 6 let. Mimo to, problém by měl nastat od Ubuntu 12.10, pravděpodobně kvůli jiné verzi xserveru, ne v 12.04.
PP v kolečku - není licence,pouze upozornění na reklamu
"Dress code" - oblečení podle předpisu(ne kódované oblečení)
CC v kolečku - je licence,značí,že se někdo nesmírně snaží

Nemo7

  • Aktivní člen
  • *
  • Příspěvků: 160
Možná se ti uleví, když budeš ironický, budiž, ale Canonical v tomto případě za nic nemůže, ať to chceš pochopit, nebo ne. Tahle situace už tady jednou byla, prostě canonical udržuje ovladače aktuální, které se vážou na verzi xorgu a nemůže za to, že v amd mají takovou politiku podpory svých karet, jakou mají. Ono se to nezdá, ale HD 4xxx už tady bude 6 let. Mimo to, problém by měl nastat od Ubuntu 12.10, pravděpodobně kvůli jiné verzi xserveru, ne v 12.04.
Nastal v 12.04, viz odkaz na Root. Nejsem sám. A proč bych měl být ironický?  Nebyl jsem naštvaný zn toho, že něco přestalo fungovat. Jenom z toho, že jsem v tu chvíli nevěděl, jak tam vrátit starý ovladač. Balík s názvem fglrx a verze by se moc hodil.  :)

geofre

Já už na to reagoval asi třikrát zde na fóru s jednoduchým řešením...

Taky se m ito stalo a jde to vyřešit velmi jednoduše... Stačí použít sled následujících příkazů
Kód: [Vybrat]
sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy
sudo reboot
Pak je důležité nechat to tak a NEhrát si s dodatečnými ovladači... Všechno pak funguje jak má, dokud nepřidáš dodatečný ovladač grafiky...
Ostatně, řešilo se to už tady: http://forum.ubuntu.cz/index.php?topic=70496.msg505936#msg505936
[/quote]
Ubuntu Mate 14.04 LTS / W7 64-bit

Nemo7

  • Aktivní člen
  • *
  • Příspěvků: 160
OK, návodů na zprovoznění jsem si nevšiml, moje chyba. Ve volné diskuzi můžeme teď řešit ten legrační update, který zneschopní urychlování grafiky. Proč je problém mít u ovladačů overzované balíky? Jak to má třeba VirtualBox? 

sabraq

  • Závislák
  • ***
  • Příspěvků: 3412
  • Bootloader-není téma k hovoru,ani zbytný prostor
Možná se ti uleví, když budeš ironický, budiž, ale Canonical v tomto případě za nic nemůže, ať to chceš pochopit, nebo ne. Tahle situace už tady jednou byla, prostě canonical udržuje ovladače aktuální, které se vážou na verzi xorgu a nemůže za to, že v amd mají takovou politiku podpory svých karet, jakou mají. Ono se to nezdá, ale HD 4xxx už tady bude 6 let. Mimo to, problém by měl nastat od Ubuntu 12.10, pravděpodobně kvůli jiné verzi xserveru, ne v 12.04.
Nastal v 12.04, viz odkaz na Root. Nejsem sám. A proč bych měl být ironický?  Nebyl jsem naštvaný zn toho, že něco přestalo fungovat. Jenom z toho, že jsem v tu chvíli nevěděl, jak tam vrátit starý ovladač. Balík s názvem fglrx a verze by se moc hodil.  :)
Problém bude asi trochu v tom, že 12.04 existují 4 verze, takže spíš by to chtělo sledovat verzi jádra a xserveru. Ale co jsem se díval, tak ta podpora ze strany amd skončila už před rokem (!) a na ubuntí wiki se tomu tehdy celkem solidně zavěnovali, čili nadávat na Ubunťáky není v tomto případě moc fér.
PP v kolečku - není licence,pouze upozornění na reklamu
"Dress code" - oblečení podle předpisu(ne kódované oblečení)
CC v kolečku - je licence,značí,že se někdo nesmírně snaží

Nemo7

  • Aktivní člen
  • *
  • Příspěvků: 160
Problém bude asi trochu v tom, že 12.04 existují 4 verze, takže spíš by to chtělo sledovat verzi jádra a xserveru. Ale co jsem se díval, tak ta podpora ze strany amd skončila už před rokem (!) a na ubuntí wiki se tomu tehdy celkem solidně zavěnovali, čili nadávat na Ubunťáky není v tomto případě moc fér.
Máš samozřejmě pravdu. Hned jsem si říkal, že té kartě už skončila podpora, ten NTB je celkem starý.  Na Ubunťáky nadávat nechci, opravdu nechci "prudit". S Ubuntu jsem celkem spokojený. Jenom mi nejvíc vadí, když přestane fungovat něco, co předtím bez problémů fungovalo. Proto mi vadilo, že jsem nemohl najít jak rychle vrátit předchozí funkční stav. Přitom jádro i xserver je na tom NTB úplně původní(jádro 3.2, xserver 1.11), nic se nepovyšovalo. Přidávání repa od nějakého autora není úplně systémové řešení. Přitom stačilo jenom nahrát původní balíky zpátky, dál se nic nedowngradovalo(ani jádro, ani xserver).
« Poslední změna: 08 Února 2014, 15:02:20 od Nemo7 »

 

Provoz zaštiťuje spolek OpenAlt.