Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Nastavení Apache2 -> VirtualHost [vyřešeno]  (Přečteno 3823 krát)

Lamin

  • Návštěvník
  • Příspěvků: 64
    • Lamin's web
Nastavení Apache2 -> VirtualHost [vyřešeno]
« kdy: 20 Května 2014, 14:31:12 »
Zdravím, řeším menší problém. Web mi běží pod různými porty (80 -> normál; 8000 -> správa)
Pod portem 80 funguje vše jak má, chyba je u portu 8000, tam není podpora htaccess a tu bych rád zapl, ale nedaří se mi.
Současný stav:
Kód: [Vybrat]
NameVirtualHost *:80
<VirtualHost *:80>
    DocumentRoot /srv/www/htdocs/www.example.cz/
    ServerName www.example.cz
    ServerAlias example.cz
    ServerAlias www1.example.cz
    ServerAlias www2.example.cz
    ErrorLog /var/log/apache2/www.example.cz_error_log
    CustomLog /var/log/apache2/www.example.cz_access_log common
    CustomLog /var/log/apache2/www.example.cz_agent_log agent
    ServerAdmin admin@example.cz
    Alias /hs/ "/srv/www/htdocs/hs/"
    Alias /objects/ "/srv/www/htdocs/hs/show.php3/"
    Alias /p/ "/srv/www/htdocs/www.example.cz/index.php3/"

    php_admin_value open_basedir /var/local/import/img/temp/:/usr/local/src/ares1/php:/svr/htdocs/www.example.cz:/usr/local/src/ares1/php/log

    <Directory /srv/www/htdocs/www.example.cz/>
      Options -Indexes
      AllowOverride All
      Order allow,deny
      Allow from all
    </Directory>
    <Directory /usr/local/src/ares1/php>
      Options -Indexes
      AllowOverride All
      Order allow,deny
      Allow from all
    </Directory>
   
</VirtualHost>

NameVirtualHost *:8003

<VirtualHost *:8003>
    DocumentRoot /srv/www/htdocs/www.example.cz/
    ServerName www1.example.cz
    ErrorLog /var/log/apache2/www.example.cz_error_log
    CustomLog /var/log/apache2/www.example.cz_access_log common
    ServerAdmin admin@example.cz
    Alias /hs/ "/srv/www/htdocs/hs/"
    Alias /objects/ "/srv/www/htdocs/hs/show.php3/"
    Alias /p/ "/srv/www/htdocs/www.example.cz/index.php3/"
    Alias /private/ "/srv/www/htdocs/www.example.cz_private/"
    Alias /applications "/usr/local/src/ares1/php/applications/"
    Alias /produkt/ "/srv/www/htdocs/www.example.cz/show_pretty.php3/"
   
    php_admin_value safe_mode Off
   
    php_admin_value file_uploads On
   
    php_admin_value memory_limit 70M
   
    <Directory /srv/www/htdocs/www.example.cz/>
      Options -Indexes
      AllowOverride All
      Order allow,deny
      Allow from all
    </Directory>
    <Directory /usr/local/src/ares1/php>
      Options -Indexes
      AllowOverride All
      Order allow,deny
      Allow from all
    </Directory>
   
</VirtualHost>


Vůbec nevím kde mám chybu.
Děkuji :)
« Poslední změna: 22 Května 2014, 09:26:48 od Petr Merlin Vaněček »

Petr Merlin Vaněček

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 5057
    • Lomítkáři
Re:Nastavení Apache2 -> VirtualHost
« Odpověď #1 kdy: 20 Května 2014, 14:53:30 »
Co konkrétně by ten .htaccess měl dělat?

On dost možná funguje, jen nefunguje jen jeho část :)
Mimochodem, co je v logu apache?
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

Lamin

  • Návštěvník
  • Příspěvků: 64
    • Lamin's web
Re:Nastavení Apache2 -> VirtualHost
« Odpověď #2 kdy: 20 Května 2014, 15:06:17 »
Nefunguje tam ani primitivní příkaz
Kód: [Vybrat]
RewriteEngine On

RewriteCond %{SERVER_PORT} 8000
RewriteRule   zkouska\.html   http://example.cz:8003/objects/1075967829.html   [R]

Do logu se bohužel nedostanu, protože je to firemní server a k němu nemám přístup.

jmp

  • Host
Re:Nastavení Apache2 -> VirtualHost
« Odpověď #3 kdy: 20 Května 2014, 16:20:48 »
nikde nevidím, že by to na tom portu 8000 poslouchalo
pokud to neposlouchá, tak to nic neudělá

Lamin

  • Návštěvník
  • Příspěvků: 64
    • Lamin's web
Re:Nastavení Apache2 -> VirtualHost
« Odpověď #4 kdy: 20 Května 2014, 16:32:32 »
Pokud myslíš to v prvním příspěvku 8003, tak to byl překlep, patří tam 8000 ...

Petr Merlin Vaněček

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 5057
    • Lomítkáři
Re:Nastavení Apache2 -> VirtualHost
« Odpověď #5 kdy: 20 Května 2014, 18:31:13 »
Nefunguje tam ani primitivní příkaz
Kód: [Vybrat]
RewriteEngine On

RewriteCond %{SERVER_PORT} 8000
RewriteRule   zkouska\.html   http://example.cz:8003/objects/1075967829.html   [R]

Do logu se bohužel nedostanu, protože je to firemní server a k němu nemám přístup.

Jop, to jsem si myslel :)
Předpokládám, že mod_rewrite je nahraný, protože to funguje na portu 80 ok.

Dle mého je špatně toto:
Kód: [Vybrat]
Options -Indexes

Zkus to doplnit:
Kód: [Vybrat]
Options -Indexes FollowSymLinks

Škoda těch logů, ale pokud se dostaneš do /etc, proč už ne do /var/log?
« Poslední změna: 22 Května 2014, 09:26:15 od Petr Merlin Vaněček »
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

ntz_reloaded

  • Lokaj
  • Závislák
  • ***
  • Příspěvků: 3735
  • skill :: ur home erly
Re:Nastavení Apache2 -> VirtualHost
« Odpověď #6 kdy: 20 Května 2014, 18:58:27 »
podle me to je spatne .. sleduju tuhle diskusi a neda mi to ..

a) kdyz mas Listen 80 tak proc si myslis, ze Virtualhost *:$nejake_nahodne_cislo bude fungovat ? ty tam mas i dalsi Listen ?
b) kdyz mas nejakej virtualhost s nejakym docrootem, tak proc i dalsi virtualhost ukazuje pod stejnym jmenom do stejneho docrootu ?
tikejte mi, taky Vam tikam ...
song of the day - openSUSE, openindiana, DuckDuckGo
The noise ain't noise anymore, who's to blame, WHO'S TO BLAME ??

Petr Merlin Vaněček

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 5057
    • Lomítkáři
Re:Nastavení Apache2 -> VirtualHost
« Odpověď #7 kdy: 20 Května 2014, 22:09:55 »
podle me to je spatne .. sleduju tuhle diskusi a neda mi to ..

a) kdyz mas Listen 80 tak proc si myslis, ze Virtualhost *:$nejake_nahodne_cislo bude fungovat ? ty tam mas i dalsi Listen ?
b) kdyz mas nejakej virtualhost s nejakym docrootem, tak proc i dalsi virtualhost ukazuje pod stejnym jmenom do stejneho docrootu ?

Tak předpokládám, že direktivu Listen tam má v ports.conf
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

Lamin

  • Návštěvník
  • Příspěvků: 64
    • Lamin's web
Re:Nastavení Apache2 -> VirtualHost
« Odpověď #8 kdy: 22 Května 2014, 08:50:36 »
# netstat -tulpn
tcp        0      0 :::8000                 :::*                    LISTEN

A jinak
Options -Indexes FollowSymLinks
pomohlo, takže děkuji za pomoc :)

 

Provoz zaštiťuje spolek OpenAlt.