Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: nefungující grafický výstup při bootování  (Přečteno 1963 krát)

HenrySkritek

  • Návštěvník
  • *
  • Příspěvků: 5
    • Zobrazit profil
nefungující grafický výstup při bootování
« kdy: 14 Července 2016, 18:33:51 »
Zdravím,
asi to je poprvé co se obracím na nějaké fórum, většinou jsem si vystačil hledáním, ale tentokrát se mě stala zase trochu kurioznější věc s linuxem a jen těžko něco najdu. Budu rád za jakýkoliv tip co by mohlo způsobit můj problém.
MŮJ PROBLÉM: mám lubuntu 14.04, které běží na htpc serveru (MB Q1900DC-ITX, SSD Intel 128 GB, zaplněn asi na 10%), po standartním update (apt-get update/upgrade/reboot) už systém nenajel, ale hlavně stalo se to, že monitor při bootování ukáže bílou obrazovku s pruhy a končí po 5 sekundách písmem typu rozsypaný čaj, jeden řádek ukáže něco co by mohl být nápis lubuntu 14.04. ale zrcadlově a smíchaný s oním rozypaným čajem, prostě nečitelné, druhý řádek spíše bílý pruh než něco čitelného... klávesnice nereaguje. Nešlo se dostat ani do BIOSu. Jako první jsem zkontroloval VGA kabel a monitor. Druhý a třetí monitor stejný výsledek, stejně tak připojení přes HDMI ukázalo stejný výsledek. Vyndal jsem vnitřní baterii žádná změna. Odpojil jsem systémový SSD disk a už se ukázalo grafické rozhraní a mohl mohl jsem se dostat do BIOSu, můžu tak nabootovat nějakou live distribuci. Když jsem systémový SSD disk zapojil zpět tak zase stejný nefunkční počítač jako předtím. Chápu, že kdybych něco takového nečetl tak tomu ani moc nevěřím, ale takto se mě to stalo. Je pro mě absolutně divné, že se zapojeným diskem je už výstup na monitor nefunkční a nejde se dostat do BIOSu, po odpojení disku to možné je a výstup je v pořádku. Celé se to stalo po update/rebootu systému. Doposud jsem neměl podobný problém.
Kdyby jste měl někdo nějaký nápad čím může toto být způsobeno tak budu velmi rád. Stále uvažuji spíše nad něčím jako je nějaký HW konflikt disku s něčím, ale... fakt divná věc.

Ventero

  • Závislák
  • ****
  • Příspěvků: 2784
    • Zobrazit profil
Re:nefungující grafický výstup při bootování
« Odpověď #1 kdy: 14 Července 2016, 19:49:20 »
Tak stát se to může - při prvotním bootu PC provádí BIOS detekci zařízení a na tom se to může zaseknout.

Může být rozsekán systém disku v low-levelu (třeba instalátor W10 to při určité kombinaci umí) -  to je ta lepší varianta a disk se dá celkem snadno zprovoznit. A nebo mohl odejít stran HW.

Také je velice malá, ale možná pravděpodobnost, že příčinou je zdroj.

Tj. - jestli najede Live-OS nějakého distra, tak SSD připoj via USB (možná i via eSATA by to mělo jít) a mrkni, jestli ho něco vidí - alespoň GParted, tak můžeš zkusit, jestli něco nezachrání důležitá data vytažením a přesunem jinam. To pravděpodobně nebude jednoduché a bude-li se jednat o variantu 1, tak způsobem zprovoznění, který znám, nejspíš o data na disku přijdeš.
« Poslední změna: 15 Července 2016, 19:13:07 od Ventero »
Zvuky jsou mantrami a myšlenky moudrostí, prostě proto, že se mohou objevovat ...

HenrySkritek

  • Návštěvník
  • *
  • Příspěvků: 5
    • Zobrazit profil
Re:nefungující grafický výstup při bootování
« Odpověď #2 kdy: 14 Července 2016, 20:28:40 »
díky moc za odpověď, jako přišlo mě fakt divné že po prostém udate pár balíků/rebootu se tak systém rozsekal, určitě jsem nepodnikal žádné experimenty s win10.
Zkusím ten disk připojit přes eSata a podívat se z nějaké live distribuce jak to tam vypadá. Jinak o data mě v zásadě nějak moc nejde, jen budu muset systém znovu přeinstalovat a nakonfigurovat, ale určitě mě to donutí si pak udělat rychleji nějaké backup/restore řešení pro přístě...
Docela mě tady zajímalo jestli se náhodu někdo nesetkal s něčím podobným, protože mě ten problém co mám přijde dost unikátní. Jinak sem ten server používal bez větších problémů cca půl roku

Ventero

  • Závislák
  • ****
  • Příspěvků: 2784
    • Zobrazit profil
Re:nefungující grafický výstup při bootování
« Odpověď #3 kdy: 15 Července 2016, 19:11:50 »
Napiš, jak jsi dopadl s těmi daty. Kdyžtak navedu dál na pokus o zprovoznění disku ...
Zvuky jsou mantrami a myšlenky moudrostí, prostě proto, že se mohou objevovat ...

HenrySkritek

  • Návštěvník
  • *
  • Příspěvků: 5
    • Zobrazit profil
Re:nefungující grafický výstup při bootování
« Odpověď #4 kdy: 15 Července 2016, 19:36:16 »
jako když jsem nabootoval z live tak jsem se dostal na disk/data, jak jsem psal nejsou tam nějaká důležitá data, snad jen pár skriptů a nějaké konfiguráky... Pak jsem si ještě hrál s "boot-repair-disk" distribucí a po pár zkouškách jako odinstalovat grub/nainstalovat znovu jsem se setkal zase s neúspěchem, asi není problém se zavaděčem, ale s něčím jiným. Pak jsem ještě zkusil přeinstalovat lubunutu stejnou verzí, ale nabídla mě jen "smazání celhého disku", neb tam jiný linux neobjevila (možná tím, že tam je LVM, nevím, to už nejsem zase takový znalec). Momentálně instaluji na nový SSD disk lubuntu 16.04... a pak chci těch pár dat zkopírovat ze starého disku na nový. Jako, mě spíše zajímá co se mohlo pokazit než že by to mělo nějaký dopad na ztrátu dat... a samozřejmě kdybych věděl co se pokazilo tak bych tomu snad mohl v budoucnu zabránit. Jinak jestli tě to zajímá tak bych mohl udělat pár fotek nebo video toho co vidím při bootu... to je asi nejzajimavější z toho všeho.

Ventero

  • Závislák
  • ****
  • Příspěvků: 2784
    • Zobrazit profil
Re:nefungující grafický výstup při bootování
« Odpověď #5 kdy: 16 Července 2016, 10:21:12 »
Zajima - dik.

Tak az si ty data okopirujes, tak nech ten disk pripojeny externe, jak mas a nainstaluj GParted a tam prehraj tabulku oddilu - predpokladam, ze MBR (v GParted myslim znaceno jako ms-dos) a zkus ho tamtez naformatovat dle sve potreby. Jestli to projde, tak je realna sance na to, ze ssd bude pouzitelny.
Zvuky jsou mantrami a myšlenky moudrostí, prostě proto, že se mohou objevovat ...

HenrySkritek

  • Návštěvník
  • *
  • Příspěvků: 5
    • Zobrazit profil
Re:nefungující grafický výstup při bootování
« Odpověď #6 kdy: 16 Července 2016, 11:07:36 »
tak jsem nahrál video toho bootu
dal jsem to na ulozto (asi neni idealni, ale staci)
https://ulozto.cz/!dNK3jaZzx/20160715-195018-mp4

tak kdyz tak muzes(te) mrknout

Jinak ja ten disk budu davat v blizke dobe do notebooku a na serveru uz mam jine ssd s tim lubuntu 16.04. Ja myslim, ze nebyl problem v MBR, ale pak az na systemu, ale opravdu netusim jak/cim vznikl. Jinak kdyz sem se snazil opravit ten boot/grub atd. tak jsem pres chroot z te live distribuce delal i nejake cisteni systemu.... nejakou reconfiguraci ... byla tam postupy co a jak delat, ale nic nepomohlo, stale to vypadalo jak na videu

Jakub Vaněk

  • Stálý člen
  • ***
  • Příspěvků: 752
    • Zobrazit profil
    • Web programátora a studenta Jakuba Vaňka
Re:nefungující grafický výstup při bootování
« Odpověď #7 kdy: 16 Července 2016, 11:53:35 »
Zkus zakázat framebuffer.
http://kb.digium.com/articles/FAQ/How-to-disable-the-Linux-frame-buffer-if-it-s-causing-problems
Z live média jdi do chrootu do původního systému, uprav /etc/default/grub a pak spusť update-grub.
Notebook: Lenovo Thinkpad X200, Xubuntu 16.04

Ventero

  • Závislák
  • ****
  • Příspěvků: 2784
    • Zobrazit profil
Re:nefungující grafický výstup při bootování
« Odpověď #8 kdy: 16 Července 2016, 13:19:43 »
Ja to vysvetleni chapal, jako ze k bootu OS se to vubec nedostane - ze se to zaseka behem inicializace bios a prote se nelze dostat do setupu nic ...
Zvuky jsou mantrami a myšlenky moudrostí, prostě proto, že se mohou objevovat ...

HenrySkritek

  • Návštěvník
  • *
  • Příspěvků: 5
    • Zobrazit profil
Re:nefungující grafický výstup při bootování
« Odpověď #9 kdy: 24 Července 2016, 16:15:24 »
Ten framebuffer jsem už se nepokoušel zakázat, je to škoda, ale potřeboval jsem to zprovoznit co nejrychleji a byla rychlejší varianta přeinstalace (chápu že né ideální). Uvidím jestli se bude situace někdy opakovat, pak bych zkusil ještě tuto variantu.
DĚKUJI každopádně všem za rady a za váš čas s tímto mým problémem!

 


Provoz zaštiťuje spolek OpenAlt.