Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Vyřešit problémové balíky [VYŘEŠENO]  (Přečteno 7240 krát)

roj

  • Člen
  • **
  • Příspěvků: 289
    • Zobrazit profil
    • ipsace i tiskace
Vyřešit problémové balíky [VYŘEŠENO]
« kdy: 13 Prosinec 2016, 14:22:09 »
Zdravím. Xubuntu 16.4. se mi samo od sebe rozbilo, aniž bych cokoliv dělal. Používám jen browser, GIMP a XnView multiplatform, nehraju hry.
Popis:

Zapnu komp, přihlásím se a vyskočí asi 3 alerty "Zjištěn problém se systémovým programem"
Pozavírám alerty a na liště mám velkou značku Zákaz vězdu všech vozidel (červenou s bílím pruhem)

Kliknu a vidím hlášku: "Došlo k chybě. Spusťte prosím správce balíků .. bla bla"
a pod tím volby, jedna je ten správce.
Spustím správce, dám heslo...

Alert: "Ve vašem systému máte 3 problémové balíky" (Jaxe tam asi dostaly, když jsem nic neinstaloval a systém běžel OK???)

Použiju filtr "problémové"

V seznamu balíků jsou 3 řádky:
Kód: [Vybrat]
linux-image-extra-4.4.0-53-generic
linux-image-generic
linux-signed-image-4.4.0-53-generic
Kliknu na aktualizovat vše
A dostane se mi této hodnotné informace:

"Nelze aktualizovat systém!
Nejprve vyřešte problémové balíky."


Prosil bych radu, jak se "vyřeší problémové balíky"
« Poslední změna: 16 Prosinec 2016, 15:27:15 od Marp »
Xubuntu 18.4.

Cuore

  • Závislák
  • ****
  • Příspěvků: 2534
    • Zobrazit profil
Re:Vyřešit problémové balíky
« Odpověď #1 kdy: 13 Prosinec 2016, 14:39:50 »
nejlepší jw dávat výpisy z terminálu, takhle se může jen hádat. Aktualizuj seznam balíčku
Kód: [Vybrat]
sudo apt-get updatevýpis sem a pak aktualizuj
Kód: [Vybrat]
sudo apt-get upgradeopět výpis

roj

  • Člen
  • **
  • Příspěvků: 289
    • Zobrazit profil
    • ipsace i tiskace
Re:Vyřešit problémové balíky
« Odpověď #2 kdy: 13 Prosinec 2016, 14:50:19 »
Dík za rychlost:
Kód: [Vybrat]
roman@mironet-i3:~$ sudo apt-get update
[sudo] heslo pro roman:
Mám:1 http://cz.archive.ubuntu.com/ubuntu xenial InRelease
Stahuje se:2 http://cz.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Stahuje se:3 http://cz.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Stahuje se:4 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Stahuje se:5 http://ppa.launchpad.net/dhor/myway/ubuntu xenial InRelease [17,5 kB]
Stahuje se:6 http://cz.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [440 kB]
Stahuje se:7 http://cz.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [433 kB]
Stahuje se:8 http://cz.archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [171 kB]
Stahuje se:9 http://cz.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [293 kB]
Stahuje se:10 http://cz.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [181 kB]
Stahuje se:11 http://cz.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [369 kB]
Stahuje se:12 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [68,1 kB]
Stahuje se:13 http://cz.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [366 kB]
Stahuje se:14 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [43,0 kB]
Stahuje se:15 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [19,4 kB]
Stahuje se:16 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 DEP-11 Metadata [212 B]
Stahuje se:17 http://cz.archive.ubuntu.com/ubuntu xenial-updates/universe Translation-en [134 kB]
Stahuje se:18 http://cz.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [121 kB]
Stahuje se:19 http://cz.archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [145 kB]
Stahuje se:20 http://cz.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [2 516 B]
Stahuje se:21 http://cz.archive.ubuntu.com/ubuntu xenial-backports/main amd64 DEP-11 Metadata [208 B]
Stahuje se:22 http://cz.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 DEP-11 Metadata [212 B]
Stahuje se:23 http://cz.archive.ubuntu.com/ubuntu xenial-backports/multiverse amd64 DEP-11 Metadata [212 B]
Staženo 3 111 kB za 0s (4 927 kB/s)                               
AppStream cache update completed, but some metadata was ignored due to errors.
Načítají se seznamy balíků… Hotovo
roman@mironet-i3:~$ ^C
roman@mironet-i3:~$ sudo apt-get upgrade
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Pro opravení můžete spustit „apt-get -f install“.
Následující balíky mají nesplněné závislosti:
 linux-image-extra-4.4.0-53-generic : Závisí na: linux-image-4.4.0-53-generic ale není nainstalovaný
 linux-image-generic : Závisí na: linux-image-4.4.0-53-generic ale není nainstalovaný
 linux-signed-image-4.4.0-53-generic : Závisí na: linux-image-4.4.0-53-generic (= 4.4.0-53.74) ale není nainstalovaný
E: Nesplněné závislosti. Zkuste použít -f.
roman@mironet-i3:~$ ^C
roman@mironet-i3:~$


Xubuntu 18.4.

Milhouse

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5722
    • Zobrazit profil
Re:Vyřešit problémové balíky
« Odpověď #3 kdy: 13 Prosinec 2016, 15:39:55 »
Vždyť to tam je zase napsaný!

apt-get -f install

N. Á. V. O. D. Y.
 "...naše práce není vidět, ale je důležitá!"

roj

  • Člen
  • **
  • Příspěvků: 289
    • Zobrazit profil
    • ipsace i tiskace
Re:Vyřešit problémové balíky
« Odpověď #4 kdy: 13 Prosinec 2016, 15:44:59 »
Tak jsem teda udělal tohle:
Kód: [Vybrat]
root@mironet-i3:/home/roman# apt-get -f install
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Opravují se závislosti… Hotovo
Následující balíky byly nainstalovány automaticky a již nejsou potřeba:
  kde-l10n-cs kde-l10n-engb linux-headers-4.4.0-21
  linux-headers-4.4.0-21-generic linux-headers-4.4.0-28
  linux-headers-4.4.0-28-generic linux-headers-4.4.0-31
  linux-headers-4.4.0-31-generic linux-headers-4.4.0-34
  linux-headers-4.4.0-34-generic linux-headers-4.4.0-36
  linux-headers-4.4.0-36-generic linux-headers-4.4.0-38
  linux-headers-4.4.0-38-generic linux-headers-4.4.0-42
  linux-headers-4.4.0-42-generic linux-image-4.4.0-21-generic
  linux-image-4.4.0-28-generic linux-image-4.4.0-31-generic
  linux-image-4.4.0-34-generic linux-image-4.4.0-36-generic
  linux-image-4.4.0-38-generic linux-image-4.4.0-42-generic
  linux-image-extra-4.4.0-21-generic linux-image-extra-4.4.0-28-generic
  linux-image-extra-4.4.0-31-generic linux-image-extra-4.4.0-34-generic
  linux-image-extra-4.4.0-36-generic linux-image-extra-4.4.0-38-generic
  linux-image-extra-4.4.0-42-generic linux-signed-image-4.4.0-28-generic
  linux-signed-image-4.4.0-31-generic linux-signed-image-4.4.0-34-generic
  linux-signed-image-4.4.0-36-generic linux-signed-image-4.4.0-38-generic
  linux-signed-image-4.4.0-42-generic
Pro jejich odstranění použijte „sudo apt autoremove“.
Následující dodatečné balíky budou instalovány:
  linux-image-4.4.0-53-generic
Navrhované balíky:
  fdutils linux-doc-4.4.0 | linux-source-4.4.0 linux-tools
Následující NOVÉ balíky budou nainstalovány:
  linux-image-4.4.0-53-generic
0 aktualizováno, 1 nově instalováno, 0 k odstranění a 52 neaktualizováno.
23 instalováno nebo odstraněno pouze částečně.
Nutno stáhnout 0 B/19,2 MB archivů.
Po této operaci bude na disku použito dalších 57,1 MB.
Chcete pokračovat? [Y/n] y
(Načítá se databáze … nyní je nainstalováno 525632 souborů a adresářů.)
Připravuje se nahrazení …/linux-image-4.4.0-53-generic_4.4.0-53.74_amd64.deb …
Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/intel-microcode 4.4.0-53-generic /boot/vmlinuz-4.4.0-53-generic
Done.
Rozbaluje se linux-image-4.4.0-53-generic (4.4.0-53.74) …
dpkg: chyba při zpracovávání archivu /var/cache/apt/archives/linux-image-4.4.0-53-generic_4.4.0-53.74_amd64.deb (--unpack):
 nelze zkopírovat rozbalená data „./boot/vmlinuz-4.4.0-53-generic“ do „/boot/vmlinuz-4.4.0-53-generic.dpkg-new“: selhal zápis (Na zařízení není volné místo)
Žádné apport hlášení nebylo vytvořeno, protože chybová hláška naznačuje, že je chyba způsobena zcela zaplněným diskem.
                                      dpkg-deb: chyba: podproces paste byl zabit signálem (Roura přerušena (SIGPIPE))
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-53-generic /boot/vmlinuz-4.4.0-53-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-53-generic /boot/vmlinuz-4.4.0-53-generic
Při zpracování nastaly chyby:
 /var/cache/apt/archives/linux-image-4.4.0-53-generic_4.4.0-53.74_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@mironet-i3:/home/roman#
Nevím, jestli je to OK, ale si ne, pač píšou cosi o erroru.  Mám něco restartovat?
Xubuntu 18.4.

roj

  • Člen
  • **
  • Příspěvků: 289
    • Zobrazit profil
    • ipsace i tiskace
Re:Vyřešit problémové balíky
« Odpověď #5 kdy: 13 Prosinec 2016, 15:47:15 »
Tak po restartu žádná změna. Ale aspoň půl roku to chodilo :-(
Xubuntu 18.4.

Milhouse

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5722
    • Zobrazit profil
Re:Vyřešit problémové balíky
« Odpověď #6 kdy: 13 Prosinec 2016, 15:54:31 »
Odstraň tuto chybu, tedy odinstaluj to jádro. Asi ti došlo místo na systémovém disku.

Kód: [Vybrat]
Rozbaluje se linux-image-4.4.0-53-generic (4.4.0-53.74) …
dpkg: chyba při zpracovávání archivu /var/cache/apt/archives/linux-image-4.4.0-53-generic_4.4.0-53.74_amd64.deb (--unpack):
 nelze zkopírovat rozbalená data „./boot/vmlinuz-4.4.0-53-generic“ do „/boot/vmlinuz-4.4.0-53-generic.dpkg-new“: selhal zápis (Na zařízení není volné místo)
Žádné apport hlášení nebylo vytvořeno, protože chybová hláška naznačuje, že je chyba způsobena zcela zaplněným diskem.
                                      dpkg-deb: chyba: podproces paste byl zabit signálem (Roura přerušena (SIGPIPE))
Kód: [Vybrat]

df -Th

N. Á. V. O. D. Y.
 "...naše práce není vidět, ale je důležitá!"

roj

  • Člen
  • **
  • Příspěvků: 289
    • Zobrazit profil
    • ipsace i tiskace
Re:Vyřešit problémové balíky
« Odpověď #7 kdy: 13 Prosinec 2016, 16:08:23 »
Ten systémový SSD disk má 480 GB a na veškerá data používám ten druhý, dvouterový. To je fakt divné, že se zaplnil. Dá se to nějak zjistit, čím?
480GB jsme na svých předchozích počítačích nikdy nezaplnil, ale tam jsem na widlích jasně viděl, že drive C: má 80 GB volných a třeba 40GB zaplněných.  A na data byl disk D:

A ten příkaz df -Th  fakt se nemám čeho bát? :-)
Xubuntu 18.4.

roj

  • Člen
  • **
  • Příspěvků: 289
    • Zobrazit profil
    • ipsace i tiskace
Re:Vyřešit problémové balíky
« Odpověď #8 kdy: 13 Prosinec 2016, 16:34:31 »
Aha, to nebylo na odistalování jádra, ale na výpis disku
Kód: [Vybrat]
roman@mironet-i3:~$ sudo df -Th
[sudo] heslo pro roman:
Souborový systém             Typ      Velikost Užito Volno Uži% Připojeno do
udev                         devtmpfs     7,8G     0  7,8G   0% /dev
tmpfs                        tmpfs        1,6G  9,7M  1,6G   1% /run
/dev/mapper/xubuntu--vg-root ext4         424G   27G  376G   7% /
tmpfs                        tmpfs        7,8G  224K  7,8G   1% /dev/shm
tmpfs                        tmpfs        5,0M  4,0K  5,0M   1% /run/lock
tmpfs                        tmpfs        7,8G     0  7,8G   0% /sys/fs/cgroup
/dev/sda2                    ext2         473M  464M     0 100% /boot
/dev/sda1                    vfat         511M  3,6M  508M   1% /boot/efi
/dev/sdb1                    ext4         1,8T  200G  1,6T  12% /data
tmpfs                        tmpfs        1,6G   36K  1,6G   1% /run/user/1000
/home/roman/.Private         ecryptfs     424G   27G  376G   7% /home/roman
roman@mironet-i3:~$ ^C
roman@mironet-i3:~$
 
Xubuntu 18.4.

Cuore

  • Závislák
  • ****
  • Příspěvků: 2534
    • Zobrazit profil
Re:Vyřešit problémové balíky
« Odpověď #9 kdy: 13 Prosinec 2016, 18:35:54 »
Opravdu nikdo nečte co to píše??????????????????
Citace
Pro jejich odstranění použijte „sudo apt autoremove“.
pak jelikož máš udělaný oddíl boot pro začátečníky absolutně nevhodné řešení a navíc má 430MB tak se nediv. Smaž komplet stará jádra
Kód: [Vybrat]
sudo apt-get remove --purge $(dpkg -l 'linux-*' | sed '/^ii/!d;/'"$(uname -r | sed "s/\(.*\)-\([^0-9]\+\)/\1/")"'/d;s/^[^ ]* [^ ]* \([^ ]*\).*/\1/;/[0-9]/!d')
a pak řádně aktualizuj pomocí update a upgrade.

Milhouse

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5722
    • Zobrazit profil
Re:Vyřešit problémové balíky
« Odpověď #10 kdy: 14 Prosinec 2016, 11:08:36 »
Je plný disk /boot , kde jsou uchována jádra.

Hlavně si tam nech jedno funkční jádro, jinak pak nenaběhne systém! Příště /boot nevytvářej zvlášť.

N. Á. V. O. D. Y.
 "...naše práce není vidět, ale je důležitá!"

roj

  • Člen
  • **
  • Příspěvků: 289
    • Zobrazit profil
    • ipsace i tiskace
Re:Vyřešit problémové balíky
« Odpověď #11 kdy: 14 Prosinec 2016, 11:10:57 »
Kód: [Vybrat]
roman@mironet-i3:~$ sudo apt-get remove --purge $(dpkg -l 'linux-*' | sed '/^ii/!d;/'"$(uname -r | sed "s/\(.*\)-\([^0-9]\+\)/\1/")"'/d;s/^[^ ]* [^ ]* \([^ ]*\).*/\1/;/[0-9]/!d')
[sudo] heslo pro roman:
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Pro opravení následujících můžete spustit „apt-get -f install“:
Následující balíky mají nesplněné závislosti:
 linux-image-extra-4.4.0-53-generic : Závisí na: linux-image-4.4.0-53-generic ale nebude se instalovat
 linux-image-generic : Závisí na: linux-image-4.4.0-53-generic ale nebude se instalovat
 linux-signed-image-4.4.0-53-generic : Závisí na: linux-image-4.4.0-53-generic (= 4.4.0-53.74) ale nebude se instalovat
E: Nesplněné závislosti. Zkuste spustit „apt-get -f install“ bez balíků (nebo navrhněte řešení).
roman@mironet-i3:~$
Fakt nevím, co dál.
Já jsem si oddíl boot o velikosti pětitisíciny diskové kapacity nevymyslel, to udělal asi instalátor,  já jen všechno odklikávám, když tomu nerozumím.
Xubuntu 18.4.

Milhouse

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5722
    • Zobrazit profil
Re:Vyřešit problémové balíky
« Odpověď #12 kdy: 14 Prosinec 2016, 11:14:29 »
Tak, jak to psal výpis výče, by mělo pomoci

Kód: [Vybrat]
sudo apt autoremove
Je nutné ty výpisy číst! Ne jen je sem bezduše vkládat... :/

N. Á. V. O. D. Y.
 "...naše práce není vidět, ale je důležitá!"

roj

  • Člen
  • **
  • Příspěvků: 289
    • Zobrazit profil
    • ipsace i tiskace
Re:Vyřešit problémové balíky
« Odpověď #13 kdy: 14 Prosinec 2016, 13:10:26 »
Kluci, když se to rozbilo samo od sebe, aniž bych cokoliv dělal, jaká je asi pravděpodobnost, že se to rozbije, když budu něco dělat bez vaší pomoci? To jsem dělal při instalaci, a vidíte, jak to dopadlo. Takže novinky:
Kód: [Vybrat]
roman@mironet-i3:~$ sudo apt autoremove
[sudo] heslo pro roman:
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Pro opravení můžete spustit „apt-get -f install“.
Následující balíky mají nesplněné závislosti:
 linux-image-extra-4.4.0-53-generic : Závisí na: linux-image-4.4.0-53-generic ale není nainstalovaný
 linux-image-generic : Závisí na: linux-image-4.4.0-53-generic ale není nainstalovaný
 linux-signed-image-4.4.0-53-generic : Závisí na: linux-image-4.4.0-53-generic (= 4.4.0-53.74) ale není nainstalovaný
E: Nesplněné závislosti. Zkuste použít -f.
roman@mironet-i3:~$
Xubuntu 18.4.

juwa2

  • Závislák
  • ****
  • Příspěvků: 4228
    • Zobrazit profil
Re:Vyřešit problémové balíky
« Odpověď #14 kdy: 14 Prosinec 2016, 13:53:38 »
Už ti bylo přece řečeno, že máš ty zprávy číst a dělat to, co ti doporučují - takže nyní:
Kód: [Vybrat]
sudo apt-get -f install

roj

  • Člen
  • **
  • Příspěvků: 289
    • Zobrazit profil
    • ipsace i tiskace
Re:Vyřešit problémové balíky
« Odpověď #15 kdy: 14 Prosinec 2016, 14:11:35 »
Kód: [Vybrat]
roman@mironet-i3:~$ sudo apt-get -f install
[sudo] heslo pro roman:
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Opravují se závislosti… Hotovo
Následující balíky byly nainstalovány automaticky a již nejsou potřeba:
  kde-l10n-cs kde-l10n-engb linux-headers-4.4.0-21
  linux-headers-4.4.0-21-generic linux-headers-4.4.0-28
  linux-headers-4.4.0-28-generic linux-headers-4.4.0-31
  linux-headers-4.4.0-31-generic linux-headers-4.4.0-34
  linux-headers-4.4.0-34-generic linux-headers-4.4.0-36
  linux-headers-4.4.0-36-generic linux-headers-4.4.0-38
  linux-headers-4.4.0-38-generic linux-headers-4.4.0-42
  linux-headers-4.4.0-42-generic linux-image-4.4.0-21-generic
  linux-image-4.4.0-28-generic linux-image-4.4.0-31-generic
  linux-image-4.4.0-34-generic linux-image-4.4.0-36-generic
  linux-image-4.4.0-38-generic linux-image-4.4.0-42-generic
  linux-image-extra-4.4.0-21-generic linux-image-extra-4.4.0-28-generic
  linux-image-extra-4.4.0-31-generic linux-image-extra-4.4.0-34-generic
  linux-image-extra-4.4.0-36-generic linux-image-extra-4.4.0-38-generic
  linux-image-extra-4.4.0-42-generic linux-signed-image-4.4.0-28-generic
  linux-signed-image-4.4.0-31-generic linux-signed-image-4.4.0-34-generic
  linux-signed-image-4.4.0-36-generic linux-signed-image-4.4.0-38-generic
  linux-signed-image-4.4.0-42-generic
Pro jejich odstranění použijte „sudo apt autoremove“.
Následující dodatečné balíky budou instalovány:
  linux-image-4.4.0-53-generic
Navrhované balíky:
  fdutils linux-doc-4.4.0 | linux-source-4.4.0 linux-tools
Následující NOVÉ balíky budou nainstalovány:
  linux-image-4.4.0-53-generic
0 aktualizováno, 1 nově instalováno, 0 k odstranění a 52 neaktualizováno.
23 instalováno nebo odstraněno pouze částečně.
Nutno stáhnout 0 B/19,2 MB archivů.
Po této operaci bude na disku použito dalších 57,1 MB.
Chcete pokračovat? [Y/n] Y
(Načítá se databáze … nyní je nainstalováno 525632 souborů a adresářů.)
Připravuje se nahrazení …/linux-image-4.4.0-53-generic_4.4.0-53.74_amd64.deb …
Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/intel-microcode 4.4.0-53-generic /boot/vmlinuz-4.4.0-53-generic
Done.
Rozbaluje se linux-image-4.4.0-53-generic (4.4.0-53.74) …
dpkg: chyba při zpracovávání archivu /var/cache/apt/archives/linux-image-4.4.0-53-generic_4.4.0-53.74_amd64.deb (--unpack):
 nelze zkopírovat rozbalená data „./boot/vmlinuz-4.4.0-53-generic“ do „/boot/vmlinuz-4.4.0-53-generic.dpkg-new“: selhal zápis (Na zařízení není volné místo)
Žádné apport hlášení nebylo vytvořeno, protože chybová hláška naznačuje, že je chyba způsobena zcela zaplněným diskem.
                                      dpkg-deb: chyba: podproces paste byl zabit signálem (Roura přerušena (SIGPIPE))
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-53-generic /boot/vmlinuz-4.4.0-53-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-53-generic /boot/vmlinuz-4.4.0-53-generic
Při zpracování nastaly chyby:
 /var/cache/apt/archives/linux-image-4.4.0-53-generic_4.4.0-53.74_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
roman@mironet-i3:~$
Naprostá marnost. Vymazat to z nějakého důvodu nešlo a nainstalovat taky ne. Píšu, co mi radíte a vždycky to na něco narazí. Nové a nové chyby. Dá se nějak zvětšít ten boot oddíl? Klidně na 100 Giga, mě je to jedno, ale ať to konečně funguje. Nebo to mám celé přeinstalovat? Nebo jiný systém, který vydrží dýl než půl roku? Fakt nevím.
Xubuntu 18.4.

Milhouse

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5722
    • Zobrazit profil
Re:Vyřešit problémové balíky
« Odpověď #16 kdy: 14 Prosinec 2016, 15:30:52 »
Za to poděkuj Microsoftu, ten protlačil UEFI a kůli tomu je /boot oddělený ve výchozí instalaci.

Odstraň stará jádra. Duď přes příkazovku, nebo přes Synaptic.

Něco odstraníme přes příkaz:

Kód: [Vybrat]
sudo apt purge linux-headers-4.4.0-3* linux-image-4.4.0-28-generic linux-image-4.4.0-3* linux-image-extra-4.4.0-3*  linux-signed-image-4.4.0-3*
Zbytek jader si promaž přes Synaptic, ať se to naučíš. POZOR, minimálně 1 jádro musí zůstat! Pak půjde normálně aktualizovat...
A nevím, proč tam máš verze extra a signed. Ví někdo?

N. Á. V. O. D. Y.
 "...naše práce není vidět, ale je důležitá!"

roj

  • Člen
  • **
  • Příspěvků: 289
    • Zobrazit profil
    • ipsace i tiskace
Re:Vyřešit problémové balíky
« Odpověď #17 kdy: 14 Prosinec 2016, 15:44:10 »
Kód: [Vybrat]
roman@mironet-i3:~$ sudo apt purge linux-headers-4.4.0-3* linux-image-4.4.0-28-generic linux-image-4.4.0-3* linux-image-extra-4.4.0-3*  linux-signed-image-4.4.0-3*
[sudo] heslo pro roman:
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Pozn: vybírám „linux-headers-4.4.0-31-generic“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-34-lowlatency“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-36-generic“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-34-generic“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-38-generic“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-36-lowlatency“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-38-lowlatency“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-31“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.roman@mironet-i3:~$ sudo apt purge linux-headers-4.4.0-3* linux-image-4.4.0-28-generic linux-image-4.4.0-3* linux-image-extra-4.4.0-3*  linux-signed-image-4.4.0-3*
[sudo] heslo pro roman:
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Pozn: vybírám „linux-headers-4.4.0-31-generic“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-34-lowlatency“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-36-generic“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-34-generic“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-38-generic“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-36-lowlatency“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-38-lowlatency“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-31“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-34“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-36“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-38“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-31-lowlatency“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-38-generic“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-34-lowlatency“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-36-lowlatency“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-36-generic“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-38-lowlatency“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-31-lowlatency“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-31-generic“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-34-generic“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-extra-4.4.0-34-generic“ pro masku „linux-image-extra-4.4.0-3*“
Pozn: vybírám „linux-image-extra-4.4.0-36-generic“ pro masku „linux-image-extra-4.4.0-3*“
Pozn: vybírám „linux-image-extra-4.4.0-38-generic“ pro masku „linux-image-extra-4.4.0-3*“
Pozn: vybírám „linux-image-extra-4.4.0-31-generic“ pro masku „linux-image-extra-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-31-lowlatency“ pro masku „linux-signed-image-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-31-generic“ pro masku „linux-signed-image-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-34-lowlatency“ pro masku „linux-signed-image-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-36-lowlatency“ pro masku „linux-signed-image-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-36-generic“ pro masku „linux-signed-image-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-34-generic“ pro masku „linux-signed-image-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-38-generic“ pro masku „linux-signed-image-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-38-lowlatency“ pro masku „linux-signed-image-4.4.0-3*“
Balík „linux-headers-4.4.0-31-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-headers-4.4.0-34-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-headers-4.4.0-36-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-headers-4.4.0-38-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-image-4.4.0-31-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-image-4.4.0-34-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-image-4.4.0-36-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-image-4.4.0-38-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-signed-image-4.4.0-31-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-signed-image-4.4.0-34-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-signed-image-4.4.0-36-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-signed-image-4.4.0-38-lowlatency“ není nainstalován, nelze tedy odstranit
Pro opravení následujících můžete spustit „apt-get -f install“:
Následující balíky mají nesplněné závislosti:
 linux-image-extra-4.4.0-28-generic : Závisí na: linux-image-4.4.0-28-generic ale nebude se instalovat
 linux-image-extra-4.4.0-53-generic : Závisí na: linux-image-4.4.0-53-generic ale nebude se instalovat
 linux-image-generic : Závisí na: linux-image-4.4.0-53-generic ale nebude se instalovat
 linux-signed-image-4.4.0-28-generic : Závisí na: linux-image-4.4.0-28-generic (= 4.4.0-28.47) ale nebude se instalovat
 linux-signed-image-4.4.0-53-generic : Závisí na: linux-image-4.4.0-53-generic (= 4.4.0-53.74) ale nebude se instalovat
E: Nesplněné závislosti. Zkuste spustit „apt-get -f install“ bez balíků (nebo navrhněte řešení).
0-34“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-36“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-38“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-headers-4.4.0-31-lowlatency“ pro masku „linux-headers-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-38-generic“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-34-lowlatency“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-36-lowlatency“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-36-generic“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-38-lowlatency“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-31-lowlatency“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-31-generic“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-4.4.0-34-generic“ pro masku „linux-image-4.4.0-3*“
Pozn: vybírám „linux-image-extra-4.4.0-34-generic“ pro masku „linux-image-extra-4.4.0-3*“
Pozn: vybírám „linux-image-extra-4.4.0-36-generic“ pro masku „linux-image-extra-4.4.0-3*“
Pozn: vybírám „linux-image-extra-4.4.0-38-generic“ pro masku „linux-image-extra-4.4.0-3*“
Pozn: vybírám „linux-image-extra-4.4.0-31-generic“ pro masku „linux-image-extra-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-31-lowlatency“ pro masku „linux-signed-image-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-31-generic“ pro masku „linux-signed-image-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-34-lowlatency“ pro masku „linux-signed-image-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-36-lowlatency“ pro masku „linux-signed-image-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-36-generic“ pro masku „linux-signed-image-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-34-generic“ pro masku „linux-signed-image-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-38-generic“ pro masku „linux-signed-image-4.4.0-3*“
Pozn: vybírám „linux-signed-image-4.4.0-38-lowlatency“ pro masku „linux-signed-image-4.4.0-3*“
Balík „linux-headers-4.4.0-31-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-headers-4.4.0-34-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-headers-4.4.0-36-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-headers-4.4.0-38-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-image-4.4.0-31-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-image-4.4.0-34-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-image-4.4.0-36-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-image-4.4.0-38-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-signed-image-4.4.0-31-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-signed-image-4.4.0-34-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-signed-image-4.4.0-36-lowlatency“ není nainstalován, nelze tedy odstranit
Balík „linux-signed-image-4.4.0-38-lowlatency“ není nainstalován, nelze tedy odstranit
Pro opravení následujících můžete spustit „apt-get -f install“:
Následující balíky mají nesplněné závislosti:
 linux-image-extra-4.4.0-28-generic : Závisí na: linux-image-4.4.0-28-generic ale nebude se instalovat
 linux-image-extra-4.4.0-53-generic : Závisí na: linux-image-4.4.0-53-generic ale nebude se instalovat
 linux-image-generic : Závisí na: linux-image-4.4.0-53-generic ale nebude se instalovat
 linux-signed-image-4.4.0-28-generic : Závisí na: linux-image-4.4.0-28-generic (= 4.4.0-28.47) ale nebude se instalovat
 linux-signed-image-4.4.0-53-generic : Závisí na: linux-image-4.4.0-53-generic (= 4.4.0-53.74) ale nebude se instalovat
E: Nesplněné závislosti. Zkuste spustit „apt-get -f install“ bez balíků (nebo navrhněte řešení).
A když jsem pustil synaptic, tam tam furt jsou ty problémové balíky, co jsem psal hned v prvním příspěvku. Čili vlastně jsme furt na začátku.
Xubuntu 18.4.

Milhouse

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5722
    • Zobrazit profil
Re:Vyřešit problémové balíky
« Odpověď #18 kdy: 14 Prosinec 2016, 15:58:18 »
Tak je smaž rovnou natvrdo z disku v adresáři /boot jako admin. Nejsem teď v Linuxu, strukturu snad poznáš.

N. Á. V. O. D. Y.
 "...naše práce není vidět, ale je důležitá!"

roj

  • Člen
  • **
  • Příspěvků: 289
    • Zobrazit profil
    • ipsace i tiskace
Re:Vyřešit problémové balíky
« Odpověď #19 kdy: 14 Prosinec 2016, 17:21:54 »
Píšu z jiného kompu s WXP. Tamten už nejde nastartovat, blikají ledky na klávesnici a neděje se nic.
Děkuji všem za návrat k widlím.
Xubuntu 18.4.

juwa2

  • Závislák
  • ****
  • Příspěvků: 4228
    • Zobrazit profil
Re:Vyřešit problémové balíky
« Odpověď #20 kdy: 14 Prosinec 2016, 22:32:05 »
Kdybys měl dostatek místa na oddíle /boot příkazy výše by evidentně problém opravily.
Editovat oddíly můžeš pomocí GParted z live media - i nyní, když systém neběží.
Nebo si prostuduj návody na instalaci - je jich všude dost a pak to nainstaluj znova.
Instalace pod UEFI se od instalace pod klasickýn biosem liší - včetně přípravy inst. boot media.
« Poslední změna: 14 Prosinec 2016, 22:36:24 od juwa2 »

roj

  • Člen
  • **
  • Příspěvků: 289
    • Zobrazit profil
    • ipsace i tiskace
Re:Vyřešit problémové balíky
« Odpověď #21 kdy: 14 Prosinec 2016, 23:01:01 »
Nikdy jsem velikost boot oddílu nezadával a kdybych mohl, nejsem idiot, abych jakémukoliv oddílu přidělil 0.0002 velikosti své diskové kapacity. Tohle vymysleli experti, co to distro dali ven.
Linux jsme si pořizoval, abych neřešil problémy s "aktualizací windows". Ještě jsem se smál, že linux tohle nikdy neudělá. Smích mě přešel, linux tohle dělá ještě tisíckrát debilnějc. A já jsem teď bez svého hlavního kompu úplně v prdeli, nemůžu pracovat, nemůžu nic.
Ještě tady mám tu starou šunku se spolehlivými, zlatými WXP, které jedou už 16 let bez problému. Jenže na tom nemůžu pracovat, všechna čerstvá data mám na hlavním kompu.
Xubuntu 18.4.

juwa2

  • Závislák
  • ****
  • Příspěvků: 4228
    • Zobrazit profil
Re:Vyřešit problémové balíky
« Odpověď #22 kdy: 15 Prosinec 2016, 00:10:47 »
Nikdy jsem velikost boot oddílu nezadával...
Ale to je právě chyba. Při instalaci si máš počet a velikosti oddílů zvolit. Rovněž, v závislosti na konfiguraci PC zvolíš kam se bude instalovat zavaděč. Potom bys nemohl takto dopadnout. A experti nic nevymysleli - instaluješ ty, nikoli experti.
Proč si raději nepřečteš nějaký návod jak instalovat? Je jich na webu bambilion. Dělají to tak všichni, nevím proč bys měl být výjimka...

« Poslední změna: 15 Prosinec 2016, 00:20:16 od juwa2 »

roj

  • Člen
  • **
  • Příspěvků: 289
    • Zobrazit profil
    • ipsace i tiskace
Re:Vyřešit problémové balíky
« Odpověď #23 kdy: 15 Prosinec 2016, 07:58:44 »
Návodů jsem si pár vyhledal a nikde nepsali, že existuje nějaký oddíl boot, který se časem naplní nade všechny meze, proto je dobré mu vyhradit celý disk. Dokonce ani v tom obrázku, cos sem poslal, nic takového není. Takže návodů je možná bambilion, ale (bambilion-1) jich je úplně k hovnu a ten jeden jsem teda asi přehlédl.
Když něčemu nerozumím, nechávám výchozí nastavení. U widlí to funguje, u všech appek na Androidu to funguje (bez návodu!), u DOSu to v roce 1990 fungovalo, jen v linuxu to vydrží fungovat půl roku.
Moje chyba. Snažil jsme se k vážné práci použít systém pro hračičky.
Xubuntu 18.4.

martyj

  • Závislák
  • ****
  • Příspěvků: 2276
  • Don't buy a new PC, download a better one !
    • Zobrazit profil
Re:Vyřešit problémové balíky
« Odpověď #24 kdy: 15 Prosinec 2016, 08:16:48 »
Být tebou, vrátím se k windows.

http://forum.ubuntu.cz/index.php?topic=64905.0
ASUS K50-IJ/Pentium Dual-Core CPU T4500@2.30GHz/RAM 4 GB/Intel GMA 4500M/Ubuntu 14.04 LTS (64-bit) - GNOME Flashback/puppy