Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Prosím o pomoc s přehráváním DVB-T2 po upgrade na Ubuntu 20.04  (Přečteno 1077 krát)

rene

  • Návštěvník
  • *
  • Příspěvků: 6
    • Zobrazit profil
Dobrý den,
prosím o pomoc. Ve starém Ubuntu jsem používal čínský USB Astrometa ve spolupráci s Kaffeine pro přehrávání DVB-T2. Po zahájení full hd vysílání v praze to na full hd kanálech přestalo chodit, ale nějak jsem to rozchodil, bohužel už nevím jak. Teď mám nově nainstalované Ubuntu 20.04 a ani bohovi, u většiny kanálů při naladění obraz vteřinu jde, pak se kousne a jde jenom zvuk. Stolní PC, Intel 5, amd rx 480. Tady je log z terminálu

ren@ren-PC:~$ kaffeine
03-05-20 10:41:01.543 [Info    ] kaffeine.dvb: Using built-in dvb device manager
03-05-20 10:41:02.167 [Info    ] kaffeine.dev: Found dvb device : Realtek RTL2832 (DVB-T)
03-05-20 10:41:02.847 [Info    ] kaffeine.dev: Found dvb device : Panasonic MN88473
03-05-20 10:41:02.881 [Warning ] Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/8x8/legacy/"
03-05-20 10:41:02.881 [Warning ] Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/16x16/legacy/"
03-05-20 10:41:02.882 [Warning ] Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/22x22/legacy/"
03-05-20 10:41:02.882 [Warning ] Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/24x24/legacy/"
03-05-20 10:41:02.882 [Warning ] Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/32x32/legacy/"
03-05-20 10:41:02.882 [Warning ] Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/48x48/legacy/"
03-05-20 10:41:02.882 [Warning ] Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/256x256/legacy/"
03-05-20 10:41:02.882 [Warning ] Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/512x512/legacy/"
03-05-20 10:41:02.882 [Warning ] Invalid Context= "Legacy" line for icon theme:  "/usr/share/icons/Adwaita/scalable/legacy/"
03-05-20 10:41:02.882 [Warning ] Invalid Context= "UI" line for icon theme:  "/usr/share/icons/Adwaita/scalable/ui/"
03-05-20 10:41:03.052 [Warning ] kf5.kservice.services: KServiceTypeTrader: serviceType "ThumbCreator" not found
03-05-20 10:41:03.053 [Warning ] kf5.kservice.services: KServiceTypeTrader: serviceType "ThumbCreator" not found
03-05-20 10:41:03.338 [Warning ] kf5.kservice.services: KServiceTypeTrader: serviceType "ThumbCreator" not found
03-05-20 10:41:03.338 [Warning ] kf5.kservice.services: KServiceTypeTrader: serviceType "ThumbCreator" not found
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
mesa: for the   --simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the   --global-isel-abort option: may only occur zero or one times!
[00007fb3d8002cf0] glconv_vaapi_x11 gl error: vaDeriveImage: operation failed
[00007fb3d406c350] main video output error: video output creation failed
[00007fb3f4036870] main decoder error: failed to create video output
[00007fb3f40b7420] mpeg4audio packetizer: AAC channels: 2 samplerate: 24000
mesa: for the   --simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the   --global-isel-abort option: may only occur zero or one times!
[00007fb3f4036870] avcodec decoder: Using G3DVL VDPAU Driver Shared Library version 1.0 for hardware decoding
[00007fb3f4036870] avcodec decoder error: hardware acceleration picture allocation failed
[hevc @ 0x7fb3dc03b840] get_buffer() failed
[hevc @ 0x7fb3dc03b840] thread_get_buffer() failed
[00007fb3f4036870] avcodec decoder error: avcodec_send_packet critical error

Ventero

  • Závislák
  • ****
  • Příspěvků: 2050
    • Zobrazit profil
Re:Prosím o pomoc s přehráváním DVB-T2 po upgrade na Ubuntu 20.04
« Odpověď #1 kdy: 03 Květen 2020, 11:25:02 »
Neco podobneho se resi na ted na Mint foru s docela drahym pcie tunnerem s tim, ze to dela jen u CT - tedy programu s 1080p - icka tam jedou.
Z chybovych vypisu jde vycist nejaky problem s kodeky. Tak jestli by nepomohla instalace ubuntu-restricted-extras. Ale spis si myslim, ze bude potiz s driverem, kdyz ve starsi verzi Ubu (nevime v ktere) to slo.
Zvuky jsou mantrami a myšlenky moudrostí, prostě proto, že se mohou objevovat ...

rene

  • Návštěvník
  • *
  • Příspěvků: 6
    • Zobrazit profil
Re:Prosím o pomoc s přehráváním DVB-T2 po upgrade na Ubuntu 20.04
« Odpověď #2 kdy: 03 Květen 2020, 15:03:23 »
ubuntu-restricted-extras je již nejnovější verze (67)
Předtím jsem měl ubuntu 18.04 a ta byla povýšená z 16.04.  Původně jsem to chtěl povýšit z těch 18.04 a to mě odmítalo právě kvůli kaffeine, respektive ppa mtron.

JirkaZ

  • Stálý člen
  • ***
  • Příspěvků: 683
    • Zobrazit profil
Re:Prosím o pomoc s přehráváním DVB-T2 po upgrade na Ubuntu 20.04
« Odpověď #3 kdy: 03 Květen 2020, 20:24:32 »
Ve VLC ta Astrometa funguje?

rene

  • Návštěvník
  • *
  • Příspěvků: 6
    • Zobrazit profil
Re:Prosím o pomoc s přehráváním DVB-T2 po upgrade na Ubuntu 20.04
« Odpověď #4 kdy: 03 Květen 2020, 21:37:09 »
Astrometu jsem ve VLC přestal používat když se u nás přešlo na DVB-T2. On ji totiž systém vidí jako dva frontendy, 0 a 1. Na jednom je DVB-T a na druhém DVB-T2. Wscan umé oboje a naladí všechny, ale VLC hraje jenom DVB-T. Nechtělo se mi to řešit a proto jsem začal používat Kaffeine, který mi stejně přišel jako lepší. Myslím si, že 20.04 jsou ještě nedopečné, už jsem přeinstaloval zpět na 18.04 a právě ladím Kaffeine.

miro_

  • Člen
  • **
  • Příspěvků: 132
    • Zobrazit profil
Re:Prosím o pomoc s přehráváním DVB-T2 po upgrade na Ubuntu 20.04
« Odpověď #5 kdy: 04 Květen 2020, 10:40:16 »
Od konce dubna mam USB AverMedia TD310.
Zkousel jsem jej pres VLC na U18.04-mate.
Tam je chovani na CT stejne jak popisuje autor tohoto vlakna.
Prijimam vysilac Kojal.
Zatim jsem se o reseni nezajimal, protoze jsem se domnival,
ze to muze byt relativne starym desktopem, ktery mam, ze na tento typ kodovani nestaci.
Kdyz se podivam na kodek CT, tak ma 'Rozlizeni videa/vyrovnavaci pamet 1920x1080/1088'.
Napriklad STV, Zoom a a ostatni 960x540/544, chodi bez problemu.
Pripada mi to, jako by pretekly po nacteni obrazu nejake buffery linuxovych ovladacu.

Mel jsem nyni moznost vyzkouset TD310 na W10 na nejlevnejsim desktopu 'Lenovo' (ram 4GB, I Core i5 3.7GHz)
a tam zadny problem neni. Bohuzel vzhledem k instalaci W10 - UEFI,  kterou jsem
znamemu na tomto novem PC provadel, jsem si netroufnul zkusit instalovat nejaky linux,
abych overil, zda to nemuze souviset s vykonem PC.     

rene

  • Návštěvník
  • *
  • Příspěvků: 6
    • Zobrazit profil
Re:Prosím o pomoc s přehráváním DVB-T2 po upgrade na Ubuntu 20.04
« Odpověď #6 kdy: 04 Květen 2020, 21:18:53 »
Bingo. Tady je zajímavá stránka o Kaffeine
https://fossies.org/dox/kaffeine-2.0.18/
A mimo jiné se tu píše, že
Citace
Setting VDPAU acceleration

By default, libVlc will try to use vdpau hardware acceleration in order to decode the video stream at GPU. However, sometimes it may not get the right acceleration module, trying to always use NVidia module, even when the hardware is AMD or Intel. That happens, for example on Fedora 25 and 26, as reported at:

    https://bugzilla.redhat.com/show_bug.cgi?id=1305699
    https://bugs.kde.org/show_bug.cgi?id=376893

For Radeon GPU, the vdpau driver can be forced with:

export VDPAU_DRIVER=r600

The VA-GL driver can be used for Intel GPUs. It can be forced with:

export VDPAU_DRIVER=va_gl

Note: you may need to install mesa-vdpau-drivers and/or libvdpau-va-gl packages for vdpau to work.

Please notice that, depending on your hardware, for example, if your GPU vdpau driver can't decode the compression standard used by the broadcasters, it could be better to disable VDPAU backend. That can be done by passing an invalid driver name, like:

export VDPAU_DRIVER=none

Vyzkoušeno, funguje. Když spustím Kaffeine přes terminál a začnu s export VDPAU_DRIVER=none, vše funguje. Stejný problém asi bude mít vlc.
« Poslední změna: 04 Květen 2020, 22:06:42 od rene »

JirkaZ

  • Stálý člen
  • ***
  • Příspěvků: 683
    • Zobrazit profil
Re:Prosím o pomoc s přehráváním DVB-T2 po upgrade na Ubuntu 20.04
« Odpověď #7 kdy: 04 Květen 2020, 21:57:41 »
Ten tuner jinde funguje? Myslím jiné PC, jiný OS...

Má k dispozici správný firmware (pravděpodobně soubor dvb-demod-mn88473-01.fw ve složce /lib/firmware)? Pokud ne, je ke stažení třeba na https://github.com/bas-t/dvbloopback/tree/master/tbs-tuner-firmwares_v1.0

Kaffeine má k dispozici správný definiční soubor českých vysílačů (channels.conf - buď všech, nebo regionálních) pro ladění? Dodávám, že soubor musí být aktuální, zejména proto, že CRA neustále šachují s kanály, multiplexy atd.

Zkusil bych opět VLC - už jen pro ujištění, že problém je v Kaffeine.
« Poslední změna: 04 Květen 2020, 22:00:29 od JirkaZ »