Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Ubuntu 20.04 - přidání architektury i368 - Vyřešeno  (Přečteno 3206 krát)

Jan Vrzala

  • Návštěvník
  • Příspěvků: 5
Dobrý den,
když jsem se snažil přidat k mé stávající architektuře (amd64) architekturu i386 pomocí příkazu:

" sudo dpkg --add-architecture i386 "

dostal jsem odpověď:

" dpkg: chyba: chyba konfigurace: /etc/dpkg/dpkg.cfg.d/multiarch:1: neznámá volba „foreign-architecture“ "

Co mám udělat pro to aby to, aby to fungovalo ? A co znamená ta chybová hláška ? Dokázal by mi někdo prosím poradit, s Ubuntu teprve začínám. Děkuji za pomoc.

« Poslední změna: 19 Dubna 2023, 16:33:09 od Jan Vrzala »

JirkaZ

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 1714
  • Dlouholetý uživatel Linuxu a open source obecně.
Re:Ubuntu 20.04 - přidání architektury i368
« Odpověď #1 kdy: 14 Dubna 2023, 23:31:07 »
Tady jsou odpovědi.

juwa2

  • Závislák
  • ***
  • Příspěvků: 4935
Re:Ubuntu 20.04 - přidání architektury i368
« Odpověď #2 kdy: 15 Dubna 2023, 03:12:54 »
Musíš si nejprve ve zdrojích SW povolit (zaškrtnout) multiverse. A potom
Kód: [Vybrat]
sudo apt-get update
sudo dpkg --add-architecture i386
sudo apt-get dist-upgrade
« Poslední změna: 15 Dubna 2023, 03:29:44 od juwa2 »

Jan Vrzala

  • Návštěvník
  • Příspěvků: 5
Re:Ubuntu 20.04 - přidání architektury i368
« Odpověď #3 kdy: 15 Dubna 2023, 21:05:56 »
Děkuji za radu,
když jsem přidal repozitář multiverse v software a aktualizace a dal použít tak na mě vyskočila chybová hláška viz. příloha. Co s tím mám udělat teď ?

Také jsem zkusil použít příkaz:

" sudo bash -c 'echo "foreign-architecture i386" >>/etc/dpkg/dpkg.cfg.d/multiarch' "

" sudo dpkg --add-architecture i386 "

a opět stejná chyba ...


JirkaZ

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 1714
  • Dlouholetý uživatel Linuxu a open source obecně.
Re:Ubuntu 20.04 - přidání architektury i368
« Odpověď #4 kdy: 15 Dubna 2023, 21:12:33 »
Tipoval bych, že máš totální chlívek v nastavených zdrojích (nevšiml sis, že to ve výpisu hlásí?)...

Výpisy sem dávej textově a formátuj jako kód, nebo (pokud jsou velké) jako *.zip do přílohy.

Jaký máš obsah souboru /etc/apt/sources.list?
« Poslední změna: 15 Dubna 2023, 21:14:14 od JirkaZ »

juwa2

  • Závislák
  • ***
  • Příspěvků: 4935
Re:Ubuntu 20.04 - přidání architektury i368
« Odpověď #5 kdy: 16 Dubna 2023, 02:34:58 »
1. Příkaz pro přidání toho výrazu do souboru multiarch
Kód: [Vybrat]
sudo bash -c 'echo "foreign-architecture i386" >> /etc/dpkg/dpkg.cfg.d/multiarch'
už se nepoužívá (používal se ve starších verzích ubu), krom toho tam určitě ani ten soubor
Kód: [Vybrat]
/etc/dpkg/dpkg.cfg.d/multiarchnemáš (schválně se podívej), takže ani není kam přidávat...

2. Ano, máš bordýlek v (tebou) přidaných repozitářích. Nejsnazší bude když je všechny odebereš (stačí zrušit zatržítka na kartě "Ostatní software").
Pak můžeš v přidání architektury pokračovat. Až se povede, můžeš zase zdroje opatrně, po jednom povolit - ale pouze ty nezbytně nutné a hlavně platné. Mrtvé zdroje ti tam budou dělat akorát neplechu...

Jan Vrzala

  • Návštěvník
  • Příspěvků: 5
Re:Ubuntu 20.04 - přidání architektury i368
« Odpověď #6 kdy: 16 Dubna 2023, 11:15:39 »
všechny repositáře jsem odebral a šel do terminálu.
Zadal jsem opět to stejné do terminálu:

" sudo dpkg --add-architecture i386 "

a zase stejná odověď

" dpkg: chyba: chyba konfigurace: /etc/dpkg/dpkg.cfg.d/multiarch:1: neznámá volba „foreign-architecture“ "

tak jsem zkusil ten dist update a vyskočila na mě tato chyba:

Kód: [Vybrat]
" Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Pro opravení můžete spustit „apt --fix-broken install“.
Následující balíky mají nesplněné závislosti:
 steam-installer : Závisí na: steam (= 1:1.0.0.61-2ubuntu3) ale nedá se nainstalovat
 wine-devel : Závisí na: wine-devel-i386 (= 8.5~focal-1) ale nedá se nainstalovat
 wine-stable : Závisí na: wine-stable-i386 (= 8.0.0.0~focal-1) ale nedá se nainstalovat
 wine-staging : Závisí na: wine-staging-i386 (= 8.5~focal-1) ale nedá se nainstalovat
E: Nesplněné závislosti. Zkuste spustit „apt --fix-broken install“ bez balíků (nebo navrhněte řešení). "

tak jsem postupoval dál:
 
Kód: [Vybrat]
" sudo apt --fix-broken install "

" Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Opravují se závislosti… Hotovo
Následující balíky byly nainstalovány automaticky a již nejsou potřeba:
  fuseiso glib-networking:i386 gstreamer1.0-plugins-base:i386 gstreamer1.0-plugins-good:i386
  gstreamer1.0-x:i386 i965-va-driver:i386 intel-media-va-driver:i386 libaa1:i386 libaom0:i386
  libasn1-8-heimdal:i386 libatk-bridge2.0-0:i386 libatk1.0-0:i386 libatomic1:i386 libatspi2.0-0:i386
  libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386 libavc1394-0:i386
  libavcodec58:i386 libavutil56:i386 libblkid1:i386 libbrotli1:i386 libbz2-1.0:i386 libcaca0:i386
  libcairo-gobject2:i386 libcairo2:i386 libcap2:i386 libcapi20-3:i386 libcdparanoia0:i386
  libcodec2-0.9:i386 libcolord2:i386 libcom-err2:i386 libcups2:i386 libcurl3-gnutls:i386 libdatrie1:i386
  libdb5.3:i386 libdrm-amdgpu1:i386 libdrm-intel1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386
  libdrm2:i386 libdv4:i386 libedit2:i386 libelf1:i386 libepoxy0:i386 libexif12:i386 libexpat1:i386
  libfaudio0:i386 libffi7:i386 libfontconfig1:i386 libfreetype6:i386 libfribidi0:i386 libgd3:i386
  libgdbm-compat4:i386 libgdbm6:i386 libgdk-pixbuf2.0-0:i386 libgl1:i386 libgl1-mesa-dri:i386
  libgl1-mesa-glx:i386 libglapi-mesa:i386 libglib2.0-0:i386 libglu1-mesa:i386 libglvnd0:i386
  libglx-mesa0:i386 libglx0:i386 libgmp10:i386 libgnutls30:i386 libgomp1:i386 libgphoto2-6:i386
  libgphoto2-port12:i386 libgraphite2-3:i386 libgsm1:i386 libgssapi-krb5-2:i386 libgssapi3-heimdal:i386
  libgstreamer-plugins-base1.0-0:i386 libgstreamer-plugins-good1.0-0:i386 libgstreamer1.0-0:i386
  libgtk-3-0:i386 libgudev-1.0-0:i386 libharfbuzz0b:i386 libhcrypto4-heimdal:i386
  libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386 libhogweed5:i386 libhx509-5-heimdal:i386
  libicu66:i386 libiec61883-0:i386 libieee1284-3:i386 libigdgmm11:i386 libjbig0:i386 libjpeg-turbo8:i386
  libjpeg8:i386 libjson-glib-1.0-0:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-26-heimdal:i386
  libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386 libldap-2.4-2:i386 libllvm12:i386 libltdl7:i386
  libmount1:i386 libmp3lame0:i386 libmpg123-0:i386 libmysqlclient21:i386 libncurses6:i386
  libncursesw6:i386 libnettle7:i386 libnghttp2-14:i386 libnuma1:i386 libodbc1:i386 libopenal1:i386
  libopenjp2-7:i386 libopus0:i386 liborc-0.4-0:i386 libosmesa6:i386 libp11-kit0:i386 libpango-1.0-0:i386
  libpangocairo-1.0-0:i386 libpangoft2-1.0-0:i386 libpcap0.8:i386 libpci3:i386 libpciaccess0:i386
  libpcre2-8-0:i386 libpcre3:i386 libperl5.30:i386 libpixman-1-0:i386 libpng16-16:i386 libproxy1v5:i386
  libpsl5:i386 libraw1394-11:i386 librest-0.7-0:i386 libroken18-heimdal:i386 librsvg2-2:i386
  librsvg2-common:i386 librtmp1:i386 libsane:i386 libsasl2-2:i386 libsasl2-modules:i386
  libsasl2-modules-db:i386 libsdl2-2.0-0:i386 libselinux1:i386 libsensors5:i386 libshine3:i386
  libshout3:i386 libslang2:i386 libsnappy1v5:i386 libsndio7.0:i386 libsnmp35:i386 libsoup-gnome2.4-1:i386
  libsoup2.4-1:i386 libsoxr0:i386 libspeex1:i386 libsqlite3-0:i386 libssh-4:i386 libssl1.1:i386
  libstb0:i386 libswresample3:i386 libtag1v5:i386 libtag1v5-vanilla:i386 libtasn1-6:i386 libthai0:i386
  libtheora0:i386 libtiff5:i386 libtinfo6:i386 libtwolame0:i386 libudev1:i386 libusb-1.0-0:i386
  libuuid1:i386 libv4l-0:i386 libv4lconvert0:i386 libva-drm2:i386 libva-x11-2:i386 libva2:i386
  libvdpau1:i386 libvisual-0.4-0:i386 libvkd3d-shader1:i386 libvkd3d1:i386 libvpx6:i386 libvulkan1:i386
  libwavpack1:i386 libwayland-client0:i386 libwayland-cursor0:i386 libwayland-egl1:i386 libwebp6:i386
  libwebpmux3:i386 libwind0-heimdal:i386 libwine:i386 libx11-6:i386 libx11-xcb1:i386 libx264-155:i386
  libx265-179:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386
  libxcb-randr0:i386 libxcb-render0:i386 libxcb-shm0:i386 libxcb-sync1:i386 libxcb-xfixes0:i386
  libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxext6:i386 libxfixes3:i386 libxi6:i386
  libxinerama1:i386 libxkbcommon0:i386 libxml2:i386 libxpm4:i386 libxrandr2:i386 libxrender1:i386
  libxshmfence1:i386 libxslt1.1:i386 libxss1:i386 libxv1:i386 libxvidcore4:i386 libxxf86vm1:i386
  libzstd1:i386 libzvbi0:i386 mesa-va-drivers:i386 mesa-vdpau-drivers:i386 mesa-vulkan-drivers:i386
  ocl-icd-libopencl1:i386 steam:i386 steam-devices va-driver-all:i386 vdpau-driver-all:i386
  vkd3d-compiler:i386 wine-devel-amd64 wine-devel-i386:i386 wine-stable-amd64 wine-stable-i386:i386
  wine-staging-amd64 wine-staging-i386:i386 wine32:i386 wine64
Pro jejich odstranění použijte „sudo apt autoremove“.
Následující balíky budou ODSTRANĚNY:
  steam-installer wine-devel wine-stable wine-staging winehq-staging winetricks
0 aktualizováno, 0 nově instalováno, 6 k odstranění a 8 neaktualizováno.
Po této operaci bude na disku uvolněno 47,2 MB.
Chcete pokračovat? [Y/n] y
dpkg: chyba: chyba konfigurace: /etc/dpkg/dpkg.cfg.d/multiarch:1: neznámá volba „foreign-architecture“
E: Podproces dpkg --set-selections vrátil chybový kód (2)
E: Couldn't record the approved state changes as dpkg selection states "

a nakonec když jsem zadal:

" sudo dpkg --set-selections "

tak na mě vyskočila opět známá chyba:

" dpkg: chyba: chyba konfigurace: /etc/dpkg/dpkg.cfg.d/multiarch:1: neznámá volba „foreign-architecture“ "


Co mám udělat a jak se zbavit těch balíků co nejdou naistalovat? Zkoušel jsem i autoremove a zase mě to upozornilo na ty balíčky že nejdou nainstalovat ... Mám pocit, že jsem v tom až moc zamotaný co bych měl udělat teď ? Děkuji moc za každou radu.






« Poslední změna: 17 Dubna 2023, 10:51:57 od Roman Vacho »

Ventero

  • Závislák
  • ***
  • Příspěvků: 3516
Re:Ubuntu 20.04 - přidání architektury i368
« Odpověď #7 kdy: 16 Dubna 2023, 11:28:55 »
A neni to nahodou tak, ze podpora 32arch uz od verze 19 neni - ze byla naposledy v 18.04?
Zvuky jsou mantrami a myšlenky moudrostí, prostě proto, že se mohou objevovat ...

JirkaZ

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 1714
  • Dlouholetý uživatel Linuxu a open source obecně.
Re:Ubuntu 20.04 - přidání architektury i368
« Odpověď #8 kdy: 16 Dubna 2023, 11:41:42 »
A neni to nahodou tak, ze podpora 32arch uz od verze 19 neni - ze byla naposledy v 18.04?

No nevím....

Nechci a nemůžu se v tom teď hlouběji vrtat, nicméně i na na Kubuntu 22.04 LTS lze stále úspěšně nainstalovat a provozovat Eagle 6.6.0, což je 32bit aplikace...

Edit: jestli jsi spíš nemyslel, že neexistuje 32bit verze celého OS - to je ale něco jiného, než podpora 32bit aplikací v 64bit OS.
« Poslední změna: 16 Dubna 2023, 14:59:10 od JirkaZ »

juwa2

  • Závislák
  • ***
  • Příspěvků: 4935
Re:Ubuntu 20.04 - přidání architektury i368
« Odpověď #9 kdy: 16 Dubna 2023, 13:27:33 »
Zkus
Kód: [Vybrat]
sudo apt-get install multiarch-support
Nicméně z toho výpisu je patrné, že tam spoustu 32b balíků máš --> nějak jsi je tam musel dostat --> podporu 32b jsi tam musel mít (nebo ještě možná máš). Zkontroluj to:
Kód: [Vybrat]
dpkg --print-architecture
dpkg --print-foreign-architectures
Tím jsi měl začít...
« Poslední změna: 16 Dubna 2023, 13:32:22 od juwa2 »

Jan Vrzala

  • Návštěvník
  • Příspěvků: 5
Re:Ubuntu 20.04 - přidání architektury i368
« Odpověď #10 kdy: 16 Dubna 2023, 21:50:37 »
objevil jsem, že dpkg odpovídá na každý příkaz chybovou hláškou :

" dpkg: chyba: chyba konfigurace: /etc/dpkg/dpkg.cfg.d/multiarch:1: neznámá volba „foreign-architecture“ "

tedy nemůžu zjistit jestli tam tu architekturu i386 mám

a na balík multiarch support jsem dostal odpověď :

" E: Nelze najít balík multiarch-support "

Napadlo mě jestli by nebylo nejjednodušší řešení zálohovat data a přeinstalovat Ubuntu protože mám pocit jako by mi nic nefungovalo tak jak má ... Nebo je něco jak by se dalo nějak přeinstalovat a opravit dpkg když furt vyhazuje ten error ? Děkuji moc.

Roman Vacho

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 5991
Re:Ubuntu 20.04 - přidání architektury i368
« Odpověď #11 kdy: 17 Dubna 2023, 11:15:37 »
Kód: [Vybrat]
cat /var/lib/dpkg/arch
Originál /etc/apt/sources.list
Kód: [Vybrat]
sources.list
deb http://archive.ubuntu.com/ubuntu/ focal main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ focal main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu/ focal-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ focal-updates main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse

deb http://archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse

deb http://archive.canonical.com/ubuntu focal partner
deb-src http://archive.canonical.com/ubuntu focal partner
« Poslední změna: 17 Dubna 2023, 11:30:55 od Roman Vacho »
Vyřešená vlákna je vhodné uzavřít "Topic Solved" dole pod vláknem. Děkujeme.

JirkaZ

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 1714
  • Dlouholetý uživatel Linuxu a open source obecně.
Re:Ubuntu 20.04 - přidání architektury i368
« Odpověď #12 kdy: 17 Dubna 2023, 12:16:35 »
Jan Vrzala:

Jo, přeinstalace je ve finále vždy nejlepší řešení, ale napřed bych se být tebou naučil se systémem pracovat. A to nejlépe pomocí apt, lépe řečeno Synapticu.

Ještě tip na "poslední záchranu", až si dáš do pořádku ty zdroje: zkus systém opravit pomocí aptitude, píšu o tom tady.

Stručné shrnutí aptitude: umí nabízet různé varianty řešení problémů s balíky, a to i tam, kde apt/Synaptic selhává.
« Poslední změna: 17 Dubna 2023, 12:19:26 od JirkaZ »

Jan Vrzala

  • Návštěvník
  • Příspěvků: 5
Re:Ubuntu 20.04 - přidání architektury i368
« Odpověď #13 kdy: 19 Dubna 2023, 16:32:59 »
Děkuji za příkaz

po zadání

"cat /var/lib/dpkg/arch"

jsem zjistil že mám obě architektury (AMD64 I368), teď jen musím udělat pořádek v repositářích

Ještě jednou děkuji všem za pomoc


 

Provoz zaštiťuje spolek OpenAlt.