Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Instal. balíček nelze nainstalovat  (Přečteno 5324 krát)

Kvido

  • Stálý člen
  • **
  • Příspěvků: 532
    • nekecamweb.cz
Instal. balíček nelze nainstalovat
« kdy: 21 Června 2023, 17:16:22 »
Ve verzi Ubuntu 22.04 LTS mně vyzývá ki nové instalaci.
Instaluje se, ale skončí zprávou (přibližně) "instalace, balíček nelze nainstalovat!".
Stalo se to také někomu. Co s tím? Díky!!!
OS: Ubuntu 23.04
PC: Intel® Celeron(R) J4005 CPU @ 2.00GHz × 2, grafika: Mesa Intel® UHD Graphics 600 (GLK 2), disk SSD, 450 GB, paměť DDR 4 - 3,7 GiB.

Roman Vacho

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 6085
Re:Instal. balíček nelze nainstalovat
« Odpověď #1 kdy: 21 Června 2023, 18:07:00 »
Kód: [Vybrat]
sudo apt dist-upgradepříkaz z příkazové řádky alias CLI poskytne lepší výstup
Vyřešená vlákna je vhodné uzavřít "Topic Solved" dole pod vláknem.
Dlouhé výpisy prosím dávat při psaní příspěvku do bloku funkcí Vložit kód.
Děkujeme.

Kvido

  • Stálý člen
  • **
  • Příspěvků: 532
    • nekecamweb.cz
Re:Instal. balíček nelze nainstalovat
« Odpověď #2 kdy: 26 Června 2023, 13:54:38 »
Díky mnohokrát. Po upgrade podle Tvého příkazu OK! Aktualizace Ubuntu 22.04 LTS proběhla úspešně.
Zdravím! Krásný den!!!

Upgrade tedy OK, ale předtím mně systém napsal, že balík mysql-server-8.0 není zlpmfigurován. Píše to při každé upgrade:
 
Kód: [Vybrat]
dpkg: nesplněné závislosti zamezily konfiguraci balíku mysql-server:
 mysql-server závisí na mysql-server-8.0; avšak:
  Balík mysql-server-8.0 zatím není zkonfigurován.

dpkg: chyba při zpracovávání balíku mysql-server (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Žádné apport hlášení nebylo vytvořeno, protože chybová hláška naznačuje, že se j
edná o chybu způsobenou předchozí chybou.
                                         Při zpracování nastaly chyby:
 mysql-server-8.0
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

« Poslední změna: 26 Června 2023, 14:29:49 od Kvido »
OS: Ubuntu 23.04
PC: Intel® Celeron(R) J4005 CPU @ 2.00GHz × 2, grafika: Mesa Intel® UHD Graphics 600 (GLK 2), disk SSD, 450 GB, paměť DDR 4 - 3,7 GiB.

ikx

  • Aktivní člen
  • *
  • Příspěvků: 479
Re:Instal. balíček nelze nainstalovat
« Odpověď #3 kdy: 26 Června 2023, 15:22:16 »
...preinstaluj balik...
Citace
sudo apt install --reinstall
... :o :o :o

Kvido

  • Stálý člen
  • **
  • Příspěvků: 532
    • nekecamweb.cz
Re:Instal. balíček nelze nainstalovat
« Odpověď #4 kdy: 28 Června 2023, 10:19:34 »
@ikx
Stále stejná hláška.
Kód: [Vybrat]
Při zpracování nastaly chyby:
 mysql-server-8.0
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
OS: Ubuntu 23.04
PC: Intel® Celeron(R) J4005 CPU @ 2.00GHz × 2, grafika: Mesa Intel® UHD Graphics 600 (GLK 2), disk SSD, 450 GB, paměť DDR 4 - 3,7 GiB.

jmp

  • Host
Re:Instal. balíček nelze nainstalovat
« Odpověď #5 kdy: 28 Června 2023, 10:27:50 »
tohle nepomůže?
Kód: [Vybrat]
dpkg --configure -a

Kvido

  • Stálý člen
  • **
  • Příspěvků: 532
    • nekecamweb.cz
Re:Instal. balíček nelze nainstalovat
« Odpověď #6 kdy: 28 Června 2023, 11:19:00 »
@jmp
Kód: [Vybrat]
kvetoslav@kvetoslav:~$ sudo su
[sudo] heslo pro kvetoslav:
root@kvetoslav:/home/kvetoslav# dpkg --configure -a
Nastavuje se balík mysql-server-8.0 (8.0.33-0ubuntu0.22.04.3) …
update-alternatives: chyba: alternativní cesta /etc/mysql/mysql.cnf neexistuje
dpkg: chyba při zpracovávání balíku mysql-server-8.0 (--configure):
 podproces skript z instalovaného balíku mysql-server-8.0: post-installation vrátil chybový návratový stav 2
dpkg: nesplněné závislosti zamezily konfiguraci balíku mysql-server:
 mysql-server závisí na mysql-server-8.0; avšak:
  Balík mysql-server-8.0 zatím není zkonfigurován.

dpkg: chyba při zpracovávání balíku mysql-server (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Při zpracování nastaly chyby:
 mysql-server-8.0
 mysql-server
root@kvetoslav:/home/kvetoslav#
OS: Ubuntu 23.04
PC: Intel® Celeron(R) J4005 CPU @ 2.00GHz × 2, grafika: Mesa Intel® UHD Graphics 600 (GLK 2), disk SSD, 450 GB, paměť DDR 4 - 3,7 GiB.

Kvido

  • Stálý člen
  • **
  • Příspěvků: 532
    • nekecamweb.cz
Re:Instal. balíček nelze nainstalovat
« Odpověď #7 kdy: 28 Června 2023, 11:22:36 »
Asi mám přeinstalovat balík mysql-server-8.0, která  zatím není zkonfigurován?
Tedy přeinstalovat celé mysql?
OS: Ubuntu 23.04
PC: Intel® Celeron(R) J4005 CPU @ 2.00GHz × 2, grafika: Mesa Intel® UHD Graphics 600 (GLK 2), disk SSD, 450 GB, paměť DDR 4 - 3,7 GiB.

Roman Vacho

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 6085
Re:Instal. balíček nelze nainstalovat
« Odpověď #8 kdy: 28 Června 2023, 11:36:55 »
Kód: [Vybrat]
ln -s /etc/mysql/mysql.cnf /etc/alternatives/mysql.cnf
Kód: [Vybrat]
dpkg --configure -a
https://askubuntu.com/questions/1004273/unable-to-update-nor-remove-mysql-after-updating-ubuntu
« Poslední změna: 28 Června 2023, 11:38:59 od Roman Vacho »
Vyřešená vlákna je vhodné uzavřít "Topic Solved" dole pod vláknem.
Dlouhé výpisy prosím dávat při psaní příspěvku do bloku funkcí Vložit kód.
Děkujeme.

ikx

  • Aktivní člen
  • *
  • Příspěvků: 479
Re:Instal. balíček nelze nainstalovat
« Odpověď #9 kdy: 28 Června 2023, 12:29:09 »
Citace
sudo apt-get install --reinstall
.skus s pridanim -get...... >:(

Roman Vacho

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 6085
Re:Instal. balíček nelze nainstalovat
« Odpověď #10 kdy: 28 Června 2023, 13:12:40 »
To mu nepomůže, protože už nástroj nad kterým staví apt-get, s tím má problém. Je to prý známá chyba mysql při instalaci.
V těch balíčcích je určité nastavení a to je špatně. Proto to háže chybu při instalaci.
Vyřešená vlákna je vhodné uzavřít "Topic Solved" dole pod vláknem.
Dlouhé výpisy prosím dávat při psaní příspěvku do bloku funkcí Vložit kód.
Děkujeme.

Kvido

  • Stálý člen
  • **
  • Příspěvků: 532
    • nekecamweb.cz
Re:Instal. balíček nelze nainstalovat
« Odpověď #11 kdy: 28 Června 2023, 14:13:57 »
@Roman Vacho
Co tedy s tímto problémem?
Už jsme to řešili před 2 roky, hm.
https://forum.ubuntu.cz/index.php?topic=85591.0
« Poslední změna: 28 Června 2023, 14:19:00 od Kvido »
OS: Ubuntu 23.04
PC: Intel® Celeron(R) J4005 CPU @ 2.00GHz × 2, grafika: Mesa Intel® UHD Graphics 600 (GLK 2), disk SSD, 450 GB, paměť DDR 4 - 3,7 GiB.

Ventero

  • Závislák
  • ***
  • Příspěvků: 3582
Re:Instal. balíček nelze nainstalovat
« Odpověď #12 kdy: 28 Června 2023, 15:29:01 »
Zkusit apt install -f a pak znovu?
Zvuky jsou mantrami a myšlenky moudrostí, prostě proto, že se mohou objevovat ...

ikx

  • Aktivní člen
  • *
  • Příspěvků: 479
Re:Instal. balíček nelze nainstalovat
« Odpověď #13 kdy: 28 Června 2023, 17:50:45 »
...ano...potom
Citace
sudo apt-get dist-upgrade
...potom kukkneme
Citace
apt-cache policy/nazov balika/

Roman Vacho

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 6085
Re:Instal. balíček nelze nainstalovat
« Odpověď #14 kdy: 29 Června 2023, 08:56:56 »
@Roman Vacho
Co tedy s tímto problémem?
Už jsme to řešili před 2 roky, hm.
https://forum.ubuntu.cz/index.php?topic=85591.0
A jaký je výstup na ty 2 příkazy, co jsem ti dával?
Vyřešená vlákna je vhodné uzavřít "Topic Solved" dole pod vláknem.
Dlouhé výpisy prosím dávat při psaní příspěvku do bloku funkcí Vložit kód.
Děkujeme.

Kvido

  • Stálý člen
  • **
  • Příspěvků: 532
    • nekecamweb.cz
Re:Instal. balíček nelze nainstalovat
« Odpověď #15 kdy: 29 Června 2023, 10:20:23 »
Venturo
figuraci balíku mysql-server:
 mysql-server závisí na mysql-server-8.0; avšak:
  Balík mysql-server-8.0 zatím není zkonfigurován.

dpkg: chyba při zpracovávání balíku mysql-server (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Při zpracování nastaly chyby:
 mysql-server-8.0
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@kvetoslav:/home/kvetoslav#
OS: Ubuntu 23.04
PC: Intel® Celeron(R) J4005 CPU @ 2.00GHz × 2, grafika: Mesa Intel® UHD Graphics 600 (GLK 2), disk SSD, 450 GB, paměť DDR 4 - 3,7 GiB.

Kvido

  • Stálý člen
  • **
  • Příspěvků: 532
    • nekecamweb.cz
Re:Instal. balíček nelze nainstalovat
« Odpověď #16 kdy: 29 Června 2023, 10:21:44 »
Venturo
Kód: [Vybrat]
figuraci balíku mysql-server:
 mysql-server závisí na mysql-server-8.0; avšak:
  Balík mysql-server-8.0 zatím není zkonfigurován.

dpkg: chyba při zpracovávání balíku mysql-server (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Při zpracování nastaly chyby:
 mysql-server-8.0
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@kvetoslav:/home/kvetoslav#
[/quote]
OS: Ubuntu 23.04
PC: Intel® Celeron(R) J4005 CPU @ 2.00GHz × 2, grafika: Mesa Intel® UHD Graphics 600 (GLK 2), disk SSD, 450 GB, paměť DDR 4 - 3,7 GiB.

Kvido

  • Stálý člen
  • **
  • Příspěvků: 532
    • nekecamweb.cz
Re:Instal. balíček nelze nainstalovat
« Odpověď #17 kdy: 29 Června 2023, 10:25:33 »
@Roman Vacho
Ty dva příkazy, výstup:

Kód: [Vybrat]
kvetoslav@kvetoslav:~$ sudo su
[sudo] heslo pro kvetoslav:
root@kvetoslav:/home/kvetoslav# ln -s /etc/mysql/mysql.cnf /etc/alternatives/mysql.cnf
root@kvetoslav:/home/kvetoslav# dpkg --configure -a
Nastavuje se balík mysql-server-8.0 (8.0.33-0ubuntu0.22.04.3) …
update-alternatives: chyba: alternativní cesta /etc/mysql/mysql.cnf neexistuje
dpkg: chyba při zpracovávání balíku mysql-server-8.0 (--configure):
 podproces skript z instalovaného balíku mysql-server-8.0: post-installation vrátil chybový návratový stav 2
dpkg: nesplněné závislosti zamezily konfiguraci balíku mysql-server:
 mysql-server závisí na mysql-server-8.0; avšak:
  Balík mysql-server-8.0 zatím není zkonfigurován.

dpkg: chyba při zpracovávání balíku mysql-server (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Při zpracování nastaly chyby:
 mysql-server-8.0
 mysql-server
root@kvetoslav:/home/kvetoslav#

OS: Ubuntu 23.04
PC: Intel® Celeron(R) J4005 CPU @ 2.00GHz × 2, grafika: Mesa Intel® UHD Graphics 600 (GLK 2), disk SSD, 450 GB, paměť DDR 4 - 3,7 GiB.

JirkaZ

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 1778
  • Dlouholetý uživatel Linuxu a open source obecně.
Re:Instal. balíček nelze nainstalovat
« Odpověď #18 kdy: 29 Června 2023, 11:00:21 »
Zkusil bych to instalovat přes aptitude, při problémech (zvlášť se závislostmi) nabízí postupně možnost je řešit různými způsoby a můžeš si vybrat.

Kód: [Vybrat]
man aptitude
a pak

Kód: [Vybrat]
sudo aptitude
resp. přímo

Kód: [Vybrat]
sudo aptitude install nazev_baliku.deb
« Poslední změna: 29 Června 2023, 11:02:01 od JirkaZ »

Roman Vacho

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 6085
Re:Instal. balíček nelze nainstalovat
« Odpověď #19 kdy: 29 Června 2023, 21:04:32 »
Kód: [Vybrat]
ln -s /etc/alternatives/mysql.cnf /etc/mysql/mysql.cnfa pak zase zase
Kód: [Vybrat]
dpkg --configure -a
Vyřešená vlákna je vhodné uzavřít "Topic Solved" dole pod vláknem.
Dlouhé výpisy prosím dávat při psaní příspěvku do bloku funkcí Vložit kód.
Děkujeme.

Kvido

  • Stálý člen
  • **
  • Příspěvků: 532
    • nekecamweb.cz
Re:Instal. balíček nelze nainstalovat
« Odpověď #20 kdy: 30 Června 2023, 06:16:20 »
@JirkaZ
Háže pořád stejně chyba v mysql server8.
Přivedl jsi mě ale na myšlenku aptitude, ten také ale nemohu nainstalovat pač to háže tu chybu mysql server8.
Tak jsem šel na problém zde:
https://packages.ubuntu.com/jammy/amd64/mysql-server-8.0/download
Resp.:
Ak používate Ubuntu, dôrazne sa odporúča používať správcu balíkov ako aptitude alebo synaptic na sťahovanie a inštaláciu balíkov namiesto manuálneho sťahovania z tejto webstránky.
Mali by ste byť schopný použiť ktorékoľvek z uvedených zrkadiel pridaním riadka do vášho súboru /etc/apt/sources.list takto:
deb http://security.ubuntu.com/ubuntu jammy-security main

Takže to zkusím dnes.
Díky!!!


OS: Ubuntu 23.04
PC: Intel® Celeron(R) J4005 CPU @ 2.00GHz × 2, grafika: Mesa Intel® UHD Graphics 600 (GLK 2), disk SSD, 450 GB, paměť DDR 4 - 3,7 GiB.

Roman Vacho

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 6085
Re:Instal. balíček nelze nainstalovat
« Odpověď #21 kdy: 30 Června 2023, 08:59:11 »
Není v mých silách všechno vysvětlovat. Ale zkus postup, co jsem dával ve svém předchozím příspěvku. Je jiný než ten předešlý.
Vyřešená vlákna je vhodné uzavřít "Topic Solved" dole pod vláknem.
Dlouhé výpisy prosím dávat při psaní příspěvku do bloku funkcí Vložit kód.
Děkujeme.

Kvido

  • Stálý člen
  • **
  • Příspěvků: 532
    • nekecamweb.cz
Re:Instal. balíček nelze nainstalovat
« Odpověď #22 kdy: 30 Června 2023, 11:04:30 »
Už jsem to také zkoušel a psal, že to háže pořád stejnou chybu na ten mysql server8.
OS: Ubuntu 23.04
PC: Intel® Celeron(R) J4005 CPU @ 2.00GHz × 2, grafika: Mesa Intel® UHD Graphics 600 (GLK 2), disk SSD, 450 GB, paměť DDR 4 - 3,7 GiB.

Kvido

  • Stálý člen
  • **
  • Příspěvků: 532
    • nekecamweb.cz
Re:Instal. balíček nelze nainstalovat
« Odpověď #23 kdy: 30 Června 2023, 12:02:41 »
kvetoslav@kvetoslav:~/Stažené$ sudo dpkg -i mysql-server-8.0_8.0.33-0ubuntu0.22.04.2_amd64.deb
[sudo] heslo pro kvetoslav:
dpkg: varování: degraduji balík mysql-server-8.0 z verze 8.0.33-0ubuntu0.22.04.3 na 8.0.33-0ubuntu0.22.04.2
(Načítá se databáze … nyní je nainstalováno 285296 souborů a adresářů.)
Připravuje se nahrazení mysql-server-8.0_8.0.33-0ubuntu0.22.04.2_amd64.deb …
Rozbaluje se mysql-server-8.0 (8.0.33-0ubuntu0.22.04.2) přes (8.0.33-0ubuntu0.22.04.3) …
dpkg: varování: mysql-server-8.0: konfigurační soubor „/etc/mysql/mysql.conf.d/mysqld.cnf“ není souborem ani symbolickým odkazem (= „/etc/mysql/mysql.conf.d/mysqld.cnf“)
dpkg: nesplněné závislosti zamezily konfiguraci balíku mysql-server-8.0:
 mysql-server-8.0 závisí na mysql-server-core-8.0 (= 8.0.33-0ubuntu0.22.04.2); avšak:
  Verze mysql-server-core-8.0 v systému je 8.0.33-0ubuntu0.22.04.3.

dpkg: chyba při zpracovávání balíku mysql-server-8.0 (--install):
 problém se závislostmi - nechávám nezkonfigurované
Při zpracování nastaly chyby:
 mysql-server-8.0
kvetoslav@kvetoslav:~/Stažené$
OS: Ubuntu 23.04
PC: Intel® Celeron(R) J4005 CPU @ 2.00GHz × 2, grafika: Mesa Intel® UHD Graphics 600 (GLK 2), disk SSD, 450 GB, paměť DDR 4 - 3,7 GiB.

Ventero

  • Závislák
  • ***
  • Příspěvků: 3582
Re:Instal. balíček nelze nainstalovat
« Odpověď #24 kdy: 30 Června 2023, 12:05:47 »
Kód: [Vybrat]
ln -s /etc/alternatives/mysql.cnf /etc/mysql/mysql.cnfa pak zase zase
Kód: [Vybrat]
dpkg --configure -a

Co natvrdo kopírovat, ať je to v obou umístěních?
Zvuky jsou mantrami a myšlenky moudrostí, prostě proto, že se mohou objevovat ...

 

Provoz zaštiťuje spolek OpenAlt.