Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: V Hardym přestalo fungovat připojení k ethernetu  (Přečteno 18969 krát)

Jirina

  • Člen
  • **
  • Příspěvků: 126
    • Zobrazit profil
V Hardym přestalo fungovat připojení k ethernetu
« kdy: 24 Duben 2008, 17:54:46 »
Zdravím, dnes jsem upgradoval na Hardyho a mám problém. S novým jádem 2.6.24 mi přestal správně fungovat ethernetový adaptér.

Výpis z syslogu:
Kód: [Vybrat]
Apr 24 17:21:44 jirka-laptop kernel: [   53.976920] r8169: eth0: link up
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  eth0: Device is fully-supported using driver 'r8169'.
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  nm_device_init(): waiting for device's worker thread to start
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  nm_device_init(): device's worker thread started, continuing.
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Now managing wired Ethernet (802.3) device 'eth0'.
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Deactivating device eth0.
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Will activate wired connection 'eth0' because it now has a link.
Apr 24 17:21:44 jirka-laptop NetworkManager: <debug> [1209050504.917115] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/storage_model_DVDRAM_GSA_T10N').
Apr 24 17:21:44 jirka-laptop NetworkManager: <debug> [1209050504.917534] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/computer_logicaldev_input_5').
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  SWITCH: no current connection, found better connection 'eth0'.
Apr 24 17:21:44 jirka-laptop NetworkManager: <WARN>  nm_dhcp_manager_get_state_for_device(): dhcdbd not running!
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Will activate connection 'eth0'.
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Device eth0 activation scheduled...
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Activation (eth0) started...
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 1 of 5 (Device Prepare) scheduled...
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 1 of 5 (Device Prepare) started...
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) scheduled...
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 1 of 5 (Device Prepare) complete.
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) starting...
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) successful.
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) scheduled.
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) complete.
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) started...
Apr 24 17:21:44 jirka-laptop NetworkManager: <WARN>  nm_dhcp_manager_begin_transaction(): dhcdbd not running!
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Activation (eth0) failure scheduled...
Apr 24 17:21:44 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) complete.
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Activation (eth0) failed.
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Deactivating device eth0.
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  SWITCH: no current connection, found better connection 'eth0'.
Apr 24 17:21:45 jirka-laptop NetworkManager: <WARN>  nm_dhcp_manager_get_state_for_device(): dhcdbd not running!
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Will activate connection 'eth0'.
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Device eth0 activation scheduled...
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Activation (eth0) started...
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 1 of 5 (Device Prepare) scheduled...
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 1 of 5 (Device Prepare) started...
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) scheduled...
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 1 of 5 (Device Prepare) complete.
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) starting...
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) successful.
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) scheduled.
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) complete.
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) started...
Apr 24 17:21:45 jirka-laptop NetworkManager: <WARN>  nm_dhcp_manager_begin_transaction(): dhcdbd not running!
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Activation (eth0) failure scheduled...
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) complete.
Apr 24 17:21:45 jirka-laptop kernel: [   54.399866] NET: Registered protocol family 10
Apr 24 17:21:45 jirka-laptop kernel: [   54.400140] lo: Disabled Privacy Extensions
Apr 24 17:21:45 jirka-laptop kernel: [   54.401034] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Activation (eth0) failed.
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  Deactivating device eth0.
Apr 24 17:21:45 jirka-laptop NetworkManager: <info>  SWITCH: no current connection, found better connection 'eth0'.
Apr 24 17:21:45 jirka-laptop NetworkManager: <WARN>  nm_dhcp_manager_get_state_for_device(): dhcdbd not running!

Zkoušel jsem bootovat s noacpi i irqpoll a nic.
Pokud se zkusím znovu připojit pomocí networkmanageru, objeví se tohle
Kód: [Vybrat]
Apr 24 17:34:16 jirka-laptop kernel: [  800.599111] r8169: eth0: link up
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  eth0: Device is fully-supported using driver 'r8169'.
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  nm_device_init(): waiting for device's worker thread to start
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  nm_device_init(): device's worker thread started, continuing.
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Now managing wired Ethernet (802.3) device 'eth0'.
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Deactivating device eth0.
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Will activate wired connection 'eth0' because it now has a link.
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  SWITCH: no current connection, found better connection 'eth0'.
Apr 24 17:34:16 jirka-laptop dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.reason
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Will activate connection 'eth0'.
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Device eth0 activation scheduled...
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Activation (eth0) started...
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 1 of 5 (Device Prepare) scheduled...
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 1 of 5 (Device Prepare) started...
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) scheduled...
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 1 of 5 (Device Prepare) complete.
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) starting...
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) successful.
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) scheduled.
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 2 of 5 (Device Configure) complete.
Apr 24 17:34:16 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) started...
Apr 24 17:34:17 jirka-laptop NetworkManager: <info>  Activation (eth0) Beginning DHCP transaction.
Apr 24 17:34:17 jirka-laptop dhclient: wmaster0: unknown hardware address type 801
Apr 24 17:34:17 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 3 of 5 (IP Configure Start) complete.
Apr 24 17:34:17 jirka-laptop NetworkManager: <info>  DHCP daemon state is now 12 (successfully started) for interface eth0
Apr 24 17:34:18 jirka-laptop dhclient: wmaster0: unknown hardware address type 801
Apr 24 17:34:18 jirka-laptop NetworkManager: <info>  DHCP daemon state is now 1 (starting) for interface eth0
Apr 24 17:34:19 jirka-laptop NetworkManager: <info>  User request to disable wireless.
Apr 24 17:34:19 jirka-laptop NetworkManager: <info>  Deactivating device wlan0.
Apr 24 17:34:19 jirka-laptop NetworkManager: <info>  Old device 'eth0' activating, won't change.
Apr 24 17:34:20 jirka-laptop dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
Apr 24 17:34:23 jirka-laptop dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 5
Apr 24 17:34:26 jirka-laptop NetworkManager: <info>  Old device 'eth0' activating, won't change.
Apr 24 17:34:28 jirka-laptop dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 9
Apr 24 17:34:37 jirka-laptop dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
Apr 24 17:34:51 jirka-laptop dhclient: No DHCPOFFERS received.
Apr 24 17:34:51 jirka-laptop avahi-autoipd(eth0)[8600]: Found user 'avahi-autoipd' (UID 105) and group 'avahi-autoipd' (GID 113).
Apr 24 17:34:51 jirka-laptop avahi-autoipd(eth0)[8600]: Successfully called chroot().
Apr 24 17:34:51 jirka-laptop avahi-autoipd(eth0)[8600]: Successfully dropped root privileges.
Apr 24 17:34:51 jirka-laptop avahi-autoipd(eth0)[8600]: Starting with address 169.254.6.56
Apr 24 17:34:57 jirka-laptop avahi-autoipd(eth0)[8600]: Callout BIND, address 169.254.6.56 on interface eth0
Apr 24 17:35:01 jirka-laptop avahi-autoipd(eth0)[8600]: Successfully claimed IP address 169.254.6.56
Apr 24 17:35:01 jirka-laptop NetworkManager: <info>  DHCP daemon state is now 9 (fail) for interface eth0
Apr 24 17:35:01 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 4 of 5 (IP Configure Timeout) scheduled...
Apr 24 17:35:01 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 4 of 5 (IP Configure Timeout) started...
Apr 24 17:35:01 jirka-laptop NetworkManager: <info>  No DHCP reply received.  Automatically obtaining IP via Zeroconf.
Apr 24 17:35:01 jirka-laptop NetworkManager: <info>  avahi-autoipd running on eth0, assuming IPv4LL address
Apr 24 17:35:01 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 5 of 5 (IP Configure Commit) scheduled...
Apr 24 17:35:01 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 4 of 5 (IP Configure Timeout) complete.
Apr 24 17:35:01 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 5 of 5 (IP Configure Commit) started...
Apr 24 17:35:01 jirka-laptop NetworkManager: <info>  not touching eth0 configuration, was configured externally
Apr 24 17:35:01 jirka-laptop NetworkManager: <info>  Activation (eth0) Finish handler scheduled.
Apr 24 17:35:01 jirka-laptop NetworkManager: <info>  Activation (eth0) Stage 5 of 5 (IP Configure Commit) complete.
Apr 24 17:35:01 jirka-laptop NetworkManager: <info>  Activation (eth0) successful, device activated.
Apr 24 17:35:01 jirka-laptop dhcdbd: Unrequested down ?:3
Apr 24 17:35:01 jirka-laptop NetworkManager: <info>  DHCP daemon state is now 14 (normal exit) for interface eth0

Ruční nastavení ip nepomáhá, restart daemona dhcbd, vypnutí networkmanageru a nastavení pomocí ifconfig a route taky nepomáhá.

Momentálně jedu na tom samém Hardym, akorát se starým jádrem 2.6.22, tam to jede v pohodě.
Nevíte někdo, co s tím?
« Poslední změna: 17 Květen 2008, 01:32:55 od Anna Taliánová »
Dell Latitude E6400, Ubuntu 13.10 + W8.1

Jirina

  • Člen
  • **
  • Příspěvků: 126
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #1 kdy: 24 Duben 2008, 20:47:01 »
To nebude tím. Ty poznámky se týkají /etc/nework/interfaces, který se standardně na desktopu vůbec nenastavuje, protože se používá network manager.
Dell Latitude E6400, Ubuntu 13.10 + W8.1

Petr Merlin Vaněček

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5039
    • Zobrazit profil
    • Lomítkáři
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #2 kdy: 24 Duben 2008, 21:59:17 »
Skoro bych řekl, že eth0 běží, jen nekomunikuje s ničím dál :) Zkuste sem dát výpis ifconfig. Také by pomohlo, pokud sem můžete dát info o tom, jakou IP adresu jste běžně dostával, jaká je maska, IP GW případně i IP DNS serveru.
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

Jirina

  • Člen
  • **
  • Příspěvků: 126
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #3 kdy: 24 Duben 2008, 22:29:53 »
Teď se mi nehodí přebootovat na jádro 2.6.24, ale v ifconfigu nebylo nic mimořádného, položky inet adr, všesměr, netmask chyběly úplně, pokud jsem je nenastavil ručně (a to stejně nepomohlo). Jinak všechno normální. V network manageru byly u všeho samé nuly, ale rychlost spoje 1000Mb/s to ukázalo správně. Kdyby nefungovalo jen dhcp, tak by mi to alespoň fungovalo se statickou ip adresou.

Na ip adrese ani dhcp serveru není nic zvláštního, jedná se o kolej. Ve WinXp, Debianu Etch, Ubuntu FF a GG, nikdy nebyl sebemenší problém.
Tento problém se objevil už když jsem asi před dvěma měsíci dal do gutsyho jádro 2.6.24 z hardyho bety. Přesně to samé. Tehdy jsem tomu nevěnoval pozornost, prostě jsem to jádro zas dal pryč.
Dell Latitude E6400, Ubuntu 13.10 + W8.1

Petr Merlin Vaněček

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5039
    • Zobrazit profil
    • Lomítkáři
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #4 kdy: 24 Duben 2008, 22:39:43 »
No jde o to, jak jste statickou nastavoval - zda pomocí NM, nebo pěkně ifdown eth0, ifconfig eth0 192.168.1.1 netmask 255.255.255.0 up route add default gw ... atd. atd.
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

Jirina

  • Člen
  • **
  • Příspěvků: 126
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #5 kdy: 24 Duben 2008, 22:53:34 »
Zkoušel jsem obojí. S linuxem Debian dělám několik let a nastavovat ručně síťování umím.
Prostě nastavený to bylo, v ifconfig to bylo všechno hezky zobrazený a stejně jsem se nedostal do sítě.

Prostě linka nereaguje ani na fyzické vypojení a zapojení kabelu. S jádrem 2.6.22 mi to hezky v syslogu zahlásí link down ..... a pak link up .... S jádrem 2.6.24 na toto nereaguje.
Už to začínám vidět černě, že to bude problém v jaderném modulu.
Dell Latitude E6400, Ubuntu 13.10 + W8.1

Jirina

  • Člen
  • **
  • Příspěvků: 126
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #6 kdy: 24 Duben 2008, 23:46:49 »
Tak jsem přebootoval. Po ručním nastavení ip pomocí ifconfig se v syslogu obejví toto:
Kód: [Vybrat]
Apr 24 23:37:35 jirka-laptop kernel: [  940.820464] r8169: eth0: link up
Apr 24 23:37:35 jirka-laptop avahi-daemon[6954]: New relevant interface eth0.IPv4 for mDNS.
Apr 24 23:37:35 jirka-laptop avahi-daemon[6954]: Registering new address record for 10.40.10.50 on eth0.IPv4.
Apr 24 23:37:35 jirka-laptop avahi-daemon[6954]: Withdrawing address record for 10.40.10.50 on eth0.
Apr 24 23:37:35 jirka-laptop avahi-daemon[6954]: Leaving mDNS multicast group on interface eth0.IPv4 with address 10.40.10.50.
Apr 24 23:37:35 jirka-laptop avahi-daemon[6954]: Interface eth0.IPv4 no longer relevant for mDNS.
Apr 24 23:37:35 jirka-laptop avahi-daemon[6954]: Joining mDNS multicast group on interface eth0.IPv4 with address 10.40.10.50.
Apr 24 23:37:35 jirka-laptop avahi-daemon[6954]: New relevant interface eth0.IPv4 for mDNS.
Apr 24 23:37:35 jirka-laptop avahi-daemon[6954]: Registering new address record for 10.40.10.50 on eth0.IPv4.
Apr 24 23:37:37 jirka-laptop avahi-daemon[6954]: Registering new address record for fe80::216:17ff:fe54:18eb on eth0.*.
Apr 24 23:37:46 jirka-laptop kernel: [  946.193909] eth0: no IPv6 routers present
Apr 24 23:38:23 jirka-laptop kernel: [  969.345015] NETDEV WATCHDOG: eth0: transmit timed out
Apr 24 23:38:23 jirka-laptop kernel: [  969.353254] r8169: eth0: link up

Ifconfig ukáže, že je vše v pořádku, ale síť prostě nechodí.
Dell Latitude E6400, Ubuntu 13.10 + W8.1

ufaak

  • Závislák
  • ****
  • Příspěvků: 2296
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #7 kdy: 25 Duben 2008, 00:03:22 »
a nestacilo by proste zakazat IPv6?
notebook MSI EX720X, Ubuntu 10.10

Jirina

  • Člen
  • **
  • Příspěvků: 126
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #8 kdy: 25 Duben 2008, 00:35:17 »
Takže přátelelé, strávil jsem s tim příjemných pár hodin a přišel jsem na to. Je to skutečně tím ovladačem - modulem.

Návod pro ty, kterým se stane to samé co mě:
Moje síťovka je Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
Je třeba vyhodit ovladač r8169, který fungoval v gutsym a zkompilovat nový ovldadač r8168 s patchem pro hardyho. Návod je zde : http://ubuntuforums.org/showthread.php?p=4718501
Pak stačí připojit modul r8168 a network manager si to za chvíli ošahá a jede to!!!!!!
Nakonec se musí nastavit, aby se nespouštěl po startu r8169, ale r8168. To už nechám na zítřek, dneska už jsem s tím zabil času moc, bude na to nejspíš třeba editace /etc/modules.
Dell Latitude E6400, Ubuntu 13.10 + W8.1

Petr Merlin Vaněček

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5039
    • Zobrazit profil
    • Lomítkáři
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #9 kdy: 25 Duben 2008, 08:25:31 »
Tuším jednoduše do /etc/modprobe.d/blacklist dát
Kód: [Vybrat]
blacklist r8169
a do /etc/modules
Kód: [Vybrat]
r8168

díky moc za návod, hádám se bude pár lidem hodit ;)
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

Jirina

  • Člen
  • **
  • Příspěvků: 126
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #10 kdy: 25 Duben 2008, 09:06:54 »
Jo kéž by. Do blacklistu jsem ho dal, /etc/modules jsem upravil a nepomáhá :-(. Po startu si to natáhne oba moduly, jak r8169, tak r8168, přičemž ale síťovka používá ten r8169. Takže je třeba ho odebrat pomocí rmmod a pak znova zavést r8168. Dokonce jsem ho už přesunul z /lib/modules/2.4.24/kernel/drivers/net/r8169.ko pryč a přejmenoval, ale stejně si ho ta mrcha pro startu někde najde a zavede. Nechápu.
Dell Latitude E6400, Ubuntu 13.10 + W8.1

Pavelp

  • Host
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #11 kdy: 25 Duben 2008, 09:09:22 »
nainstalujte si modconf, zkuste ty moduly najit a zmenit pomoci modconfu a pak dejte update-modules. A pak se podivejte do /etc/modules, co jste zpusobil ....
« Poslední změna: 25 Duben 2008, 09:10:17 od Petr 'Merlin' Vaněček »

Petr Merlin Vaněček

  • Moderátor
  • Guru
  • ***
  • Příspěvků: 5039
    • Zobrazit profil
    • Lomítkáři
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #12 kdy: 25 Duben 2008, 09:12:46 »
Předpokládám, že ta verze jádra z /lib/modules je 2.6.24 ... protože pokud ne, tak je vše jasné :D
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

Jirina

  • Člen
  • **
  • Příspěvků: 126
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #13 kdy: 25 Duben 2008, 09:15:59 »
Jasně, nejsem blbej  ;D.
Mám tu jen dvě jádra 2.6.24 a 2.6.22, teď už jedu stále jen na 2.6.24, když už mi tu chodí ta síť.

Update: Takže aby jste mi věřili, překládám screenshot. Takový je stav po restartu http://home.tiscali.cz/cb385542/obrazovka-18.jpg
« Poslední změna: 25 Duben 2008, 09:53:39 od Jirina »
Dell Latitude E6400, Ubuntu 13.10 + W8.1

LS

  • Závislák
  • ****
  • Příspěvků: 3849
    • Zobrazit profil
    • http://linux.euweb.cz
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #14 kdy: 25 Duben 2008, 09:22:53 »
Jaky presny typ zakladni desky mate? Mam tady zrovna jeden stroj s touto sitovkou (deska GA-P35-DS4 rev.1.1), tak bych mohl vyzkouset, jestli je to obecny jev, nebo specificky pro vas konkretni typ zakladni desky.

Jirina

  • Člen
  • **
  • Příspěvků: 126
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #15 kdy: 25 Duben 2008, 09:54:51 »
Jedná se o notebook MSI L735.
lspci:
Kód: [Vybrat]
00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:04.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.3 Co-processor: nVidia Corporation MCP51 PMU (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
04:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce Go 7600] (rev a1)
05:04.0 CardBus bridge: O2 Micro, Inc. OZ711MP1/MS1 MemoryCardBus Controller (rev 21)
05:04.2 SD Host controller: O2 Micro, Inc. Integrated MMC/SD Controller (rev 01)
05:04.3 Bridge: O2 Micro, Inc. Integrated MS/xD Controller (rev 01)
05:04.4 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)
05:09.0 Network controller: RaLink RT2561/RT61 rev B 802.11g
Dell Latitude E6400, Ubuntu 13.10 + W8.1

Fracty

  • Stálý člen
  • ***
  • Příspěvků: 809
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #16 kdy: 25 Duben 2008, 14:50:13 »
divný....mám tu samou síťovku (používá ten samý modul) a jela zkoušel jsem v RC 8.04 - jelo avahi i DHCP...

Jirina

  • Člen
  • **
  • Příspěvků: 126
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #17 kdy: 25 Duben 2008, 15:19:06 »
Tak se to mrdá asi jenom mě. Jenom prostě nechápu, proč mi to tam furt cpe ten r8169 modul :-/
Dell Latitude E6400, Ubuntu 13.10 + W8.1

aprilio

  • Návštěvník
  • *
  • Příspěvků: 5
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #18 kdy: 26 Duben 2008, 10:34:15 »
No mam tiez notebook MSI L735 a tiez ta sietovka nejde.Skusal som tam dat aj ten novy ovladac len akosi ten navod uz nefunguje lebo je novsia verzia ovladaca. :(Nevie niekto s tym poradit? 7.10 isla perfektne.

Lenny

  • Návštěvník
  • *
  • Příspěvků: 11
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #19 kdy: 26 Duben 2008, 14:11:31 »
Hm me se to mrda tez:(

Podarilo se mi to jakz takz rozchodit pomoci vyse uvedeneho navodu, nicmene mam stejny problem, tzn. po nabootovani se mi natahnou oba dva moduly a sitovka nefacha. Pak musim odpojit r8169 i r8168 a znova nacist r8168, nasledne provest nakou aktualizaci v network manageru [cokoli co se naj zmeni & ulozit, aby se to spravne zaktualizovalo], a pak teprve muzu na net...fakt sux.

Otazka tedy zni, jak z kompu uplne vyhostit ten driver r8169, aby se mi po startu automaticky nacetl r8168?

No mam tiez notebook MSI L735 a tiez ta sietovka nejde.Skusal som tam dat aj ten novy ovladac len akosi ten navod uz nefunguje lebo je novsia verzia ovladaca. :(Nevie niekto s tym poradit? 7.10 isla perfektne.
Ten novy ovladac je to sami, je to akorat minoritni bugfix, staci si prepsat jmeno souboru v tech prikazech v navodu na r8168-8.006.00 + to sami prepsat vsude v souboru toho patche (r8168-8.005.00.hardy.diff.txt)...

Mno, doufam ze se objevi nejaka rada, ponevadz tohle je fakt nahovno...btw pak ze je Ubuntu strasne bezproblemovej system pro uzivatele windows:(

Jirina

  • Člen
  • **
  • Příspěvků: 126
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #20 kdy: 26 Duben 2008, 17:06:57 »
Mě ten patch fungoval na 8.006 bez přepisování :-). Při tý "výměně" modulů není třena na network manager sahat. Stačí po startu odebrat r8169 i r8168 a tak tam následně dát zpátky r8168. Za pár vteřin se network manager připojí sám (pokud je aktivní cestovní mód). Alespoň u mě.

Citace
Otazka tedy zni, jak z kompu uplne vyhostit ten driver r8169, aby se mi po startu automaticky nacetl r8168?
To je otázka. Já i když jsem ho fyzicky odstranil, tak se stále někde bere.
« Poslední změna: 26 Duben 2008, 17:13:08 od Jirina »
Dell Latitude E6400, Ubuntu 13.10 + W8.1

Lenny

  • Návštěvník
  • *
  • Příspěvků: 11
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #21 kdy: 26 Duben 2008, 17:47:34 »
Mě ten patch fungoval na 8.006 bez přepisování :-)

Zajimavy, me to puvodne hazelo nejaky chyby. Usoudil sem, ze je to tou spatnou verzi, udelal sem par zmen, prepsal sem to a spustil znovu, ale mozna sem nekde neco prehlid...

Při tý "výměně" modulů není třena na network manager sahat. Stačí po startu odebrat r8169 i r8168 a tak tam následně dát zpátky r8168. Za pár vteřin se network manager připojí sám (pokud je aktivní cestovní mód). Alespoň u mě.

Nj, ja mel cestovni mod vyplej, to bude tim...

To je otázka. Já i když jsem ho fyzicky odstranil, tak se stále někde bere.

:-(( doufam ze nekoho neco napadne, ponevadz bych byl docela rad kdybych se nemusel po kazdym spusteni pocitace srat s netem...

Fracty

  • Stálý člen
  • ***
  • Příspěvků: 809
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #22 kdy: 27 Duben 2008, 10:06:03 »
dát si na to script do rc??
jinak dívali jste se jestli je to už na launchpadě? aby se to opravilo?

Jirina

  • Člen
  • **
  • Příspěvků: 126
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #23 kdy: 27 Duben 2008, 19:37:55 »
Scipt je samozřejmě možné snadno udělat, ale mě to nevadí tam ty tři příkazy dát. 1. stejně jedu většinou na wifině, 2. aspoň se dozvím, když se to po nějaké aktualizaci opraví.

No napsal jsem to zatím jen v programu "Hardware testing", který to snad odeslal.
Dell Latitude E6400, Ubuntu 13.10 + W8.1

Pepe999

  • Stálý člen
  • ***
  • Příspěvků: 775
    • Zobrazit profil
Re: V hardym přestalo fungovat připojení k ethernetu
« Odpověď #24 kdy: 27 Duben 2008, 19:47:47 »
Hm me se to mrda tez:(

Podarilo se mi to jakz takz rozchodit pomoci vyse uvedeneho navodu, nicmene mam stejny problem, tzn. po nabootovani se mi natahnou oba dva moduly a sitovka nefacha. Pak musim odpojit r8169 i r8168 a znova nacist r8168, nasledne provest nakou aktualizaci v network manageru [cokoli co se naj zmeni & ulozit, aby se to spravne zaktualizovalo], a pak teprve muzu na net...fakt sux.

Otazka tedy zni, jak z kompu uplne vyhostit ten driver r8169, aby se mi po startu automaticky nacetl r8168?

No mam tiez notebook MSI L735 a tiez ta sietovka nejde.Skusal som tam dat aj ten novy ovladac len akosi ten navod uz nefunguje lebo je novsia verzia ovladaca. :(Nevie niekto s tym poradit? 7.10 isla perfektne.
Ten novy ovladac je to sami, je to akorat minoritni bugfix, staci si prepsat jmeno souboru v tech prikazech v navodu na r8168-8.006.00 + to sami prepsat vsude v souboru toho patche (r8168-8.005.00.hardy.diff.txt)...

Mno, doufam ze se objevi nejaka rada, ponevadz tohle je fakt nahovno...btw pak ze je Ubuntu strasne bezproblemovej system pro uzivatele windows:(
Jestli chcete zavadet pouze jeden modul, tak se to da udelat jednoduse..
Zapsat presny nazev(pravdepodobne r8169) na blacklist.
sudo gedit /etc/modprobe.d/blacklist
na konec vypisu napsat pouze
blacklist r8169
tim bude system system tento modul pri startu ignorovat a loadne se pouze ten, ktery chcete..