Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: (vyriesene) problem s Plymouth 10.10  (Přečteno 4408 krát)

Palikee

  • Návštěvník
  • Příspěvků: 62
(vyriesene) problem s Plymouth 10.10
« kdy: 26 Října 2010, 15:15:43 »
podla toho navodu
http://www.n00bsonubuntu.net/content/install-ubuntu-1004-and-1010-plymouth-splash
som si chcel zmenit plymouth vsetko prebehlo ako ma, ale po restarte sa mi nezobrazi nic iba cierna obrazovka a potom nabehne rovno plocha.. ale pri vypinani sa mi na sekundu zobrazi ten novy plymouth ale pri zapinani zasa nic.. skusal som to dat aj s5 na default ale je to stale rovnake.. nevie niekto co je s tym?..
« Poslední změna: 31 Října 2010, 15:50:16 od Palikee »
ASUS K53SV-SX966, Intel Core i5 2430M s frekvencí 2,4 GHz, 8 GB DDR3 1333  MHz, NVIDIA GeForce GT540M s 2 GB vlastní paměti,

winni

  • Návštěvník
  • Příspěvků: 35
Re: problem s Plymouth 10.10
« Odpověď #1 kdy: 26 Října 2010, 20:49:43 »

jenda93

  • Stálý člen
  • **
  • Příspěvků: 653
  • software engineer
Re: problem s Plymouth 10.10
« Odpověď #2 kdy: 27 Října 2010, 00:22:02 »
To winni:

Ten odkaz asi nebude řešení. Týká se proprietárních Nvidia resp. ATI ovladačů.

Předpokládám, že tazatel v Ubuntu 10.10 používá defaultní ovladače Nouveau.

Chtělo by to upřesnit dotaz.

Hlavním úkolem vývojářů je chválit nový software

Rover623

Re: problem s Plymouth 10.10
« Odpověď #3 kdy: 27 Října 2010, 00:29:49 »
Prvně musíš mít ve složce /etc/initramfs-tools/conf.d soubor s názvem "splash" jehož obsahem je toto FRAMEBUFFER=y,pak si vyber téma které chceš a do teminálu dej "sudo update-initramfs -u" a nezapomeň,že při změně Plymouth musíš ten příkaz provést znovu aby se změna načetla

Palikee

  • Návštěvník
  • Příspěvků: 62
Re: problem s Plymouth 10.10
« Odpověď #4 kdy: 27 Října 2010, 21:49:22 »
To winni:

Ten odkaz asi nebude řešení. Týká se proprietárních Nvidia resp. ATI ovladačů.

Předpokládám, že tazatel v Ubuntu 10.10 používá defaultní ovladače Nouveau.

Chtělo by to upřesnit dotaz.

ano mam defaultny ovladac lebo som skusal instalovat ovladac cez dodatocne ovladace a tam dodatocny ovladac ale potom mi nespustilo system vobec.. neviem kde bola chyba =// a graficku mam nvidia gt 130M
« Poslední změna: 27 Října 2010, 21:56:17 od Palikee »
ASUS K53SV-SX966, Intel Core i5 2430M s frekvencí 2,4 GHz, 8 GB DDR3 1333  MHz, NVIDIA GeForce GT540M s 2 GB vlastní paměti,

Palikee

  • Návštěvník
  • Příspěvků: 62
Re: problem s Plymouth 10.10
« Odpověď #5 kdy: 27 Října 2010, 22:38:36 »
Prvně musíš mít ve složce /etc/initramfs-tools/conf.d soubor s názvem "splash" jehož obsahem je toto FRAMEBUFFER=y,pak si vyber téma které chceš a do teminálu dej "sudo update-initramfs -u" a nezapomeň,že při změně Plymouth musíš ten příkaz provést znovu aby se změna načetla

no ten splash som tam nemal.. spravil som teda toto

echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash
sudo update-initramfs -u

a aj tak to nepomohlo =/
ASUS K53SV-SX966, Intel Core i5 2430M s frekvencí 2,4 GHz, 8 GB DDR3 1333  MHz, NVIDIA GeForce GT540M s 2 GB vlastní paměti,

jenda93

  • Stálý člen
  • **
  • Příspěvků: 653
  • software engineer
Re: problem s Plymouth 10.10
« Odpověď #6 kdy: 28 Října 2010, 02:11:52 »
Tak jsem to schválně zkusil, přesně podle návodu, a v Ubuntu 10.10 mi to normálně funguje.

Ale není to nic moc, viz obrázek http://img514.imageshack.us/img514/2524/screendu.png

Bílé logo a kolečko, které se při nabíhání systému vzdaluje od loga. Skoro to nestojí za tu práci s instalací.

Hlavním úkolem vývojářů je chválit nový software

Palikee

  • Návštěvník
  • Příspěvků: 62
Re: problem s Plymouth 10.10
« Odpověď #7 kdy: 28 Října 2010, 13:46:37 »
ale zaujimave je ze ked dam
sudo plymouthd
sudo plymouth --show-splash

tak mi to normalne nabehne... ale pri zapinani to tam vobec nieje.. a niekedy sa mi dokonca system ani nezapne.. az na restart alebo dokonca az na druhy... :-&
ASUS K53SV-SX966, Intel Core i5 2430M s frekvencí 2,4 GHz, 8 GB DDR3 1333  MHz, NVIDIA GeForce GT540M s 2 GB vlastní paměti,

Rover623

Re: problem s Plymouth 10.10
« Odpověď #8 kdy: 28 Října 2010, 15:48:28 »
Jakou máš GK?

Palikee

  • Návštěvník
  • Příspěvků: 62
Re: problem s Plymouth 10.10
« Odpověď #9 kdy: 28 Října 2010, 20:00:25 »
Jakou máš GK?

pisal som uz hore nvidia geforce gt 130M 1GB
ASUS K53SV-SX966, Intel Core i5 2430M s frekvencí 2,4 GHz, 8 GB DDR3 1333  MHz, NVIDIA GeForce GT540M s 2 GB vlastní paměti,

Rover623

Re: problem s Plymouth 10.10
« Odpověď #10 kdy: 29 Října 2010, 06:44:00 »
Takže pokud máš to co jsem uvedl výše (nejlépe se přesvědčit manuálně),tj. v adresáři conf.d máš soubor splash s obsahem FRAMEBUFFER=y,tak zkus použít tenhle skript http://kyleabaker.com/2010/07/11/how-to-fix-your-ubuntu-boot-screen/

Palikee

  • Návštěvník
  • Příspěvků: 62
Re: problem s Plymouth 10.10
« Odpověď #11 kdy: 30 Října 2010, 09:43:56 »
Takže pokud máš to co jsem uvedl výše (nejlépe se přesvědčit manuálně),tj. v adresáři conf.d máš soubor splash s obsahem FRAMEBUFFER=y,tak zkus použít tenhle skript http://kyleabaker.com/2010/07/11/how-to-fix-your-ubuntu-boot-screen/

isiel som presne podla toho navodu... ta uvodna obrazovka sa mi uz zacala zobrazovat.. ale ubuntu sa mi nespusti v grafickom mode ale iba v prikazovom riadku tt1, a ked zadam
sudo service gdm start
vypise mi..
start: Job is already running: gdm
« Poslední změna: 30 Října 2010, 11:01:19 od Palikee »
ASUS K53SV-SX966, Intel Core i5 2430M s frekvencí 2,4 GHz, 8 GB DDR3 1333  MHz, NVIDIA GeForce GT540M s 2 GB vlastní paměti,

Rover623

Re: problem s Plymouth 10.10
« Odpověď #12 kdy: 30 Října 2010, 13:39:21 »
startx provede co?

Palikee

  • Návštěvník
  • Příspěvků: 62
Re: problem s Plymouth 10.10
« Odpověď #13 kdy: 30 Října 2010, 15:28:53 »
startx provede co?

par warningov, fatal error a potom hlaska ze mam pozriet na jeden log.
davam do prilohy

[attachment deleted by admin]
ASUS K53SV-SX966, Intel Core i5 2430M s frekvencí 2,4 GHz, 8 GB DDR3 1333  MHz, NVIDIA GeForce GT540M s 2 GB vlastní paměti,

Rover623

Re: problem s Plymouth 10.10
« Odpověď #14 kdy: 30 Října 2010, 17:47:59 »
Mám to,v souboru /etc/default/grub si najdi řádek GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1024x768-24,mtrr=3,scroll=ywrap" a v těch uvozovkách nech jen "quiet splash"

Rover623

Re: problem s Plymouth 10.10
« Odpověď #15 kdy: 30 Října 2010, 17:49:40 »
Případně by mohlo stačit odmazat parametr nomodeset z té řádky

Palikee

  • Návštěvník
  • Příspěvků: 62
Re: problem s Plymouth 10.10
« Odpověď #16 kdy: 30 Října 2010, 18:11:41 »
Případně by mohlo stačit odmazat parametr nomodeset z té řádky

nepomohlo ani jedno =//
« Poslední změna: 30 Října 2010, 19:15:24 od Palikee »
ASUS K53SV-SX966, Intel Core i5 2430M s frekvencí 2,4 GHz, 8 GB DDR3 1333  MHz, NVIDIA GeForce GT540M s 2 GB vlastní paměti,

Rover623

Re: problem s Plymouth 10.10
« Odpověď #17 kdy: 30 Října 2010, 19:40:37 »
Takže to způsobuje ten program který se instaluje na opravu toho Plymouthu.Mimochodem,vygeneroval jsi si po úpravě toho souboru nový Grub (sudo update-grub).Takže to musíme vrátit do původního stavu./etc/default/grub uprav tak aby v té řádce bylo jen "quiet splash",potom zadej
Kód: [Vybrat]
sudo apt-get remove v86d -y a nakonec je nutné generovat nový grub
Kód: [Vybrat]
sudo update-grub a restart
Kód: [Vybrat]
sudo shutdown -r now

Palikee

  • Návštěvník
  • Příspěvků: 62
Re: problem s Plymouth 10.10
« Odpověď #18 kdy: 30 Října 2010, 19:57:02 »
no.. okrem toho ze sa mi uvodna obrazovka zmenila na niecko kockate..sa inak nestalo nic.. stale to spusta v tom tty1 =//

na zaciatku ked sa to spusta mi tam nabehne
video unknow parameter no automatic change   mozno to pomoze =//
ASUS K53SV-SX966, Intel Core i5 2430M s frekvencí 2,4 GHz, 8 GB DDR3 1333  MHz, NVIDIA GeForce GT540M s 2 GB vlastní paměti,

Rover623

Re: problem s Plymouth 10.10
« Odpověď #19 kdy: 30 Října 2010, 20:06:45 »
Zakomentuj řádek GRUB_GFX_MODE= a vygeneruj nový grub.Taky by nebylo na škodu podívat se do souboru /etc/X11/xorg.conf do sekce "Screen" jestli tam není co se týče rozlišení obrazovky nějaká pitomost

Palikee

  • Návštěvník
  • Příspěvků: 62
Re: problem s Plymouth 10.10
« Odpověď #20 kdy: 30 Října 2010, 20:25:44 »
Zakomentuj řádek GRUB_GFX_MODE= a vygeneruj nový grub.Taky by nebylo na škodu podívat se do souboru /etc/X11/xorg.conf do sekce "Screen" jestli tam není co se týče rozlišení obrazovky nějaká pitomost
s tym rozlisenim to asi nebude.. lebo bootovacie okno mi nabehne.. hoc bolo vo vyssom rozliseni ale nabehlo mi to... teraz som to samozrejme zmenil a vygeneroval novy grub ako si mi kazal ale aj tak mi to stale spusti v prikazovom riadku =/
a ten xorg.conf.failsafe vyzera takto

Section "Device"
   Identifier   "Configured Video Device"
   Driver      "vesa"
EndSection

Section "Monitor"
   Identifier   "Configured Monitor"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Monitor      "Configured Monitor"
   Device      "Configured Video Device"
EndSection
ASUS K53SV-SX966, Intel Core i5 2430M s frekvencí 2,4 GHz, 8 GB DDR3 1333  MHz, NVIDIA GeForce GT540M s 2 GB vlastní paměti,

Rover623

Re: problem s Plymouth 10.10
« Odpověď #21 kdy: 30 Října 2010, 20:44:36 »
Takhle to nejde,jako driver musí být nvidia to především.Teď mě tak napadá,používáš ovladače od nVidia nebo ještě lépe,než se začalo experimentovat s tím Plymounthem,měl si je nainstalované,pokud ano,tak celý soubor xorg.conf vytvoř znova nalej do něj obsah mého starého xorgu (najdeš v tomhle tématu http://forum.ubuntu.cz/index.php/topic,50223.0.html ),poedituj sekce Monitor,Driver a Screen podle potřeby a zkus to znova nahodit

Palikee

  • Návštěvník
  • Příspěvků: 62
Re: problem s Plymouth 10.10
« Odpověď #22 kdy: 30 Října 2010, 20:50:55 »
Takhle to nejde,jako driver musí být nvidia to především.Teď mě tak napadá,používáš ovladače od nVidia nebo ještě lépe,než se začalo experimentovat s tím Plymounthem,měl si je nainstalované,pokud ano,tak celý soubor xorg.conf vytvoř znova nalej do něj obsah mého starého xorgu (najdeš v tomhle tématu http://forum.ubuntu.cz/index.php/topic,50223.0.html ),poedituj sekce Monitor,Driver a Screen podle potřeby a zkus to znova nahodit

problem bol ten ze ked som si nahodil ovladac nvidiu cez dodatocne ovladace tak pri starte mi len scernala obrazovka a nedalo sa robit nic.. tak som to potom asi vratil s5 na predvoleny ovladac ale 3D akceleracia mi sla.... mam teda robit to s tym xorg?..
ASUS K53SV-SX966, Intel Core i5 2430M s frekvencí 2,4 GHz, 8 GB DDR3 1333  MHz, NVIDIA GeForce GT540M s 2 GB vlastní paměti,

Palikee

  • Návštěvník
  • Příspěvků: 62
Re: problem s Plymouth 10.10
« Odpověď #23 kdy: 30 Října 2010, 20:56:56 »
ked som dal nainstalovat teraz cez dodatocne ovladace tak mi to nainstalovalo... ale nespustim to v grafickom rezime iba cez prikazovy riadok stale...=/ a ked som v nudzovom grafickom rezime a dam nvidia x server setings nabehne mi hlaska..
You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.
ASUS K53SV-SX966, Intel Core i5 2430M s frekvencí 2,4 GHz, 8 GB DDR3 1333  MHz, NVIDIA GeForce GT540M s 2 GB vlastní paměti,

Rover623

Re: problem s Plymouth 10.10
« Odpověď #24 kdy: 30 Října 2010, 21:00:44 »
je to tam napsané,napiš sudo nvidia-xconfig a resetni

 

Provoz zaštiťuje spolek OpenAlt.